Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 11-12-2011, 03:50 AM   #1
OpenMindedWorld
 
Join Date: Aug 2011
Reputation: 84
Posts: 13
Skyrim tweaks

Hello!

I'm trying to make a list of Skyrim tweaks to improve the quality of graphics or improve the game.

I warn that changes are not mine, credit must go to the people who has researched first. You can find them at the end of the post.

Disabling mouse smoothing/acceleration
Quote:
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and search for [Controls] section
  3. Change bMouseAcceleration=1 to bMouseAcceleration=0

Fixing vsync. "laggy mouse" problem

Fixing vertical mouse movement and horizontal mouse movement (thz to KleyMEN)
Note: Probably fixed in 1.2 future update: 1.2 update Release Notes
Quote:
Originally Posted by KleyMEN View Post
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and check for [Controls] section. If it's not present, just create one at the end of the file.
  3. Add fMouseHeadingYScale=0.0200 and fMouseHeadingXScale=0.0200
  4. Note: You may have to tweak the numbers until you discover what works for you.

Memory limit increase - fix lagging (thz to TurkeyStyle)
Quote:
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open skyrim.ini, and check for [Papyrus] section. If it's not present, just create one at the end of the file.
  3. Add iMinMemoryPageSize=100000 and iMaxMemoryPageSize=5000000
  4. Add iMaxAllocatedMemoryBytes=1800000000
  5. WARNING! Do not increase iMaxAllocatedMemoryBytes value, because memory fragmentation may cause the game to crash or freeze.

Changing FOV (fDefaultWorldFOV thz to pyide, Ultrakonkret, Supersnake and sNeep1)
Quote:
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and search for [General] section
  3. Add fdefaultfov=XX at the end of the section. (where XX is the FOV value you want to change to). For example add fdefaultfov=90
  4. Open Skyrim.ini, and search for [Display] section
  5. Add fDefaultWorldFOV=XX (where XX is the FOV value you put in fdefaultfov)
  6. Add fDefault1stPersonFOV=xx.0000 (where XX is the FOV value you put in fdefaultfov)
  • Note: thz to Supersnake post #221 (15/02/2012):

    After implementing these instructions it is recommended that you change Skyrim.ini and SkrimPrefs.ini files to "Read-only" files. Located at C:\Users\[USERNAME]\Documents\My Games\Skyrim\ [Skyrim.ini | SkyrimPrefs.ini]
    If you don't make them Read-only files, the game will have permission to revert your FOV back to the default value. Do this by right clicking on the files and opening their properties window, then place a check mark in the Read-only box. Warning: that you may have to temporarily remove the check mark prior to installing any future Skyrim updates or making any other changes to those two files.

  • Alternatively (thz to sNeep1 #222), you can open the console and type in "fov 90" (for example) every time you launch the game.

Enabling tree and rock self-shadowing
Quote:
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini
  3. Change bDrawLandShadows=0 to bDrawLandShadows=1
  4. Change bTreesReceiveShadows=0 to bTreesReceiveShadows=1
--------

Other Fixes

How do I fix the crash to desktop?
Note: Probably fixed in 1.2 future update: 1.2 update Release Notes
Quote:
  1. Go to Start -> Control Panel -> Sound
  2. In the Playback tab, right click on Speakers (or whatever has a green tick next to it), then click Properties
  3. In the advanced tab on this new window, select 24 bit, 44100Hz (Studio Quality) in the drop down menu


How do I fix some sound issues, such as hearing static during NPC dialogue?
Note: Probably fixed in 1.2 future update: 1.2 update Release Notes
Quote:
  1. Go to Start -> Control Panel -> Sound
  2. In the Playback tab, right click on Speakers (or whatever has a green tick next to it), then click Properties
  3. In the advanced tab on this new window, select 24 bit, 44100Hz (Studio Quality) in the drop down menu

Deactivate quest-marker: (thz to floyd ryan)
Quote:
  1. Go to C:\Users\[USERNAME]\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and search for [GamePlay] section
  3. Change bShowFloatingQuestMarkers=1 to bShowFloatingQuestMarkers=0
  4. Change bShowQuestMarkers=1 to bShowQuestMarkers=0

Deactivate compass: (thz to floyd ryan)
Quote:
  1. Go to C:\Users\USERNAME\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and search for [Interface] section
  3. Change bShowCompass=1 to bShowCompass=0

Assign Weapons and Items to Number Keys: (thz to snagglefox and floyd ryan)
Note: Probably fixed in 1.2 future update: 1.2 update Release Notes
Note: Remapping will be bugfixed in the next Skyrim update. Take a look on this post for more info: Remapping issues


Quote:
  1. Assign item to favorites with F key
  2. Open favorites with Q key
  3. Scroll to the item you want
  4. Press the number you want to assign it to
--------

Direct links to relevant and useful tweak/addons post


Permanent crosshair (disabled by default when using arrows or spells) : (thz to CurrentUser)
Quote:
  1. Go to C:\Users\USERNAME\Documents\My Games\Skyrim
  2. Open SkyrimPrefs.ini, and search for [MAIN] section
  3. Change bCrosshairEnabled=0 to bCrosshairEnabled=1

INI preset for max quality without too much fps drop: (thz to gareth_shaggy)
ˇˇˇCaution with sD3DDevice property!!!
Quote:
Originally Posted by gareth_shaggy View Post

Other major tweaks list by vizionblind: (thz to vizionblind)
Quote:
Originally Posted by vizionblind View Post

Other major tweaks and mods list by JJops: (thz to JJops)
Quote:
Originally Posted by JJops View Post




Feel free to put more tweaks!

---------
Sources:

Last edited by OpenMindedWorld: 02-15-2012 at 10:03 AM. Reason: added more info on FOV Tweak thz to Supersnake and sNeep1
OpenMindedWorld is offline  
Reply With Quote
Old 11-12-2011, 04:06 AM   #2
OpenMindedWorld
 
Join Date: Aug 2011
Reputation: 84
Posts: 13
reserved
OpenMindedWorld is offline   Reply With Quote
Old 11-12-2011, 04:19 AM   #3
pyide
 
 
 
Join Date: Sep 2007
Reputation: 52
Posts: 215
Just wanted to let you know that fDefaultWorldFOV=xx is the fool proof field of view tweak, same one that worked best in Fallout 3 and NV.

Using a custom setting with the console fov command or fdefaultfov in the config can revert back to the default 70 fov after certain triggers in the game. You can add fDefaultWorldFOV= and your desired value to the [Display] section of the inis in documents\my games\skyrim.
pyide is offline   Reply With Quote
Old 11-12-2011, 04:57 AM   #4
floyd ryan
 
Join Date: Nov 2009
Reputation: 1
Posts: 192
Deactivate quest-marker:

C:\Users\USERNAME\Documents\My Games\Skyrim\SkyrimPrefs.ini

[GamePlay]
bShowFloatingQuestMarkers=0
bShowQuestMarkers=0


But places and enemies remain! If you don't want this either:

Deactivate compass:

C:\Users\USERNAME\Documents\My Games\Skyrim\SkyrimPrefs.ini

[Interface]
bShowCompass=0
floyd ryan is offline   Reply With Quote
Old 11-12-2011, 05:10 AM   #5
Shadders
 
Join Date: Apr 2006
Reputation: 11
Posts: 64
Thanks for this!
Shadders is offline   Reply With Quote
Old 11-12-2011, 09:29 AM   #6
OpenMindedWorld
 
Join Date: Aug 2011
Reputation: 84
Posts: 13
Updated with new tweaks thz to pyide and floyd ryan!!
OpenMindedWorld is offline   Reply With Quote
Old 11-12-2011, 10:42 AM   #7
malmute
 
Banned
Join Date: Sep 2011
Reputation: 147
Posts: 396
There is no skyrim.ini file in this location.

Go to your Steam Directory -> steamapps -> common -> Skyrim
Open skyrim.ini,

I assume it means Skyrim_default.ini
malmute is offline   Reply With Quote
Old 11-12-2011, 10:48 AM   #8
surfrock22
 
 
 
Join Date: Mar 2008
Reputation: 5355
Posts: 13,758
This should be stickied. Nice work.
surfrock22 is offline   Reply With Quote
Old 11-12-2011, 11:53 AM   #9
floyd ryan
 
Join Date: Nov 2009
Reputation: 1
Posts: 192
Quote:
Originally Posted by malmute View Post
There is no skyrim.ini file in this location.

Go to your Steam Directory -> steamapps -> common -> Skyrim
Open skyrim.ini,

I assume it means Skyrim_default.ini
i'r recommend to edit you private ini in you documents/my games/skyrim folder. the one in the steam folder is for defaults.
floyd ryan is offline   Reply With Quote
Old 11-12-2011, 12:34 PM   #10
Supersnake
 
Join Date: Apr 2010
Reputation: 6
Posts: 46
Requesting a definite answer to which file do we teak? We are being given conflicting recommendations in this thread. Is it:
C:\ Users [Your Name] \ Documents \ My Games\ Skyrim\ Skyrim.ini

-or

C:\ Program Files (x86) \ Steam \SteamApps \ common\ skyrim \ Skyrim \ SkyrimPrefs.ini

or is it both?
Supersnake is offline   Reply With Quote
Old 11-12-2011, 12:51 PM   #11
surfrock22
 
 
 
Join Date: Mar 2008
Reputation: 5355
Posts: 13,758
Only tweak the Skyrim.ini in My Games. The one in the Steam directory is used as default, so I would not adjust it.
surfrock22 is offline   Reply With Quote
Old 11-12-2011, 12:57 PM   #12
Lurpsukka
 
 
 
Join Date: Dec 2009
Reputation: 314
Posts: 2,295
Have some +rep, sweet tweaks.
Lurpsukka is offline   Reply With Quote
Old 11-12-2011, 01:16 PM   #13
Medium_Rare
 
Join Date: Dec 2010
Reputation: 183
Posts: 2,137
I'm crashing every hour or so and its getting really annoying. I hate back tracking and I try to save often, but not often enough.

Is there any way to fix it? I tried the sound thing and that doesn't seem to fix it.
Medium_Rare is offline   Reply With Quote
Old 11-12-2011, 01:21 PM   #14
bluntpencil
 
Join Date: Jul 2009
Reputation: 10
Posts: 25
Quote:
Originally Posted by Medium_Rare View Post
I hate back tracking and I try to save often, but not often enough.
I don't have a fix for you sadly, but just making sure: You can quicksave on F5, in case you don't know. Nice and handy. I tend to use it TOO much, really... >_>
bluntpencil is offline   Reply With Quote
Old 11-12-2011, 01:27 PM   #15
Medium_Rare
 
Join Date: Dec 2010
Reputation: 183
Posts: 2,137
I'm going to try disabling steam community in game... I'll post back with results in about an hour.
Medium_Rare is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:01 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.