Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 11-12-2011, 06:02 AM   #1
rupok2
 
 
 
Join Date: Jun 2010
Reputation: 134
Posts: 1,976
Is the FPS issue going to be fixed?

myself and others are experiencing a fps dip where the game runs at 60fps and goes down to 20 for no reason. Everyone who has the issue has capable hardware to run the game. This same problem was in oblivion and never got fixed so I am kind of scared it won't be fixed in skyrim either.
rupok2 is offline  
Reply With Quote
Old 11-12-2011, 07:02 AM   #2
PrivateBurke
 
Join Date: Jan 2010
Reputation: 148
Posts: 575
I really hope so because I'm having the same issue.

Everytime I make a tweak and see that solid 60 FPS for the fist minute then Bam! 22FPS a little of me dies.
PrivateBurke is offline   Reply With Quote
Old 11-12-2011, 07:34 AM   #3
TurkeyStyle
 
 
 
Join Date: Sep 2011
Reputation: 24
Posts: 154
You guys are not alone. I don't have the greatest PC in the world, but it should run this better than it is. There's some really goofy things going on with this engine and the two .ini files. First here's my specs:

Intel Core 2 Quad 2.4 GHz (no overclocking, which I'll get to)
4GB DDR2 @ 667 MHz
NVidia Geforce GTX 470 w/ 1280 MB DDR5
Windows Vista x64
7200 RPM HD
Latest beta drivers (285.79)

Okay, so here's my pretty crappy experience with battling FPS instead of trolls & imperial guards. I first started the game maxed out on ultra with 4x AA (no FXAA cause it makes everything blurry). I was getting dips from 120 FPS to 12 FPS constantly, and this occurred all the way past the firs dungeon and out into the actual world where things got worse. Just moving the camera around was really jerky cause it would go from 120 FPS to 12 FPS to 72 FPS to 28 FPS... you get the picture. The camera would move from slow to fast to slow to stuttery and back to fast again. How do you play the game like this?

I then dropped the graphics settings to high instead of ultra. I got the same thing. Jittery FPS and jittery camera movement.

Then I dropped the graphics to low for kicks, and guess what? SAME THING! Okay, so the FPS were not getting as low as 12 FPS this time, but I was still hitting lows around 20-25 FPS. The game is unplayable like this.

Okay, now for why I think the game engine is completely broken *FOR AT LEAST ME, maybe not everyone* and why changing .ini files are a gamble *FOR AT LEAST ME, maybe not everyone*. I read somewhere that if you disable 2 of your 4 cores, it stopped the jittery camera. So I did that and it helped a lot. I also used a hacked .dll which limits the FPS to 30. This helped a lot too. Thing is, it only helped when running the game executable out of Steam. That's right, the game runs without Steam, out of the box with a legit retail copy. It's only the launcher.exe that wants Steam running. So when Steam's running, any tweaks to the .ini files don't work. They only work when you run the game straight from the main executable, not the launcher. The FPS limiter (.dll) only works this way too. So after all this trouble I'm running the game on Ultra much more smoothly than I was, but when I get to some outdoor towns, the FPS drops to around 15 FPS. Okay, so I change the graphics to low again and I still get the same drops but at 20 FPS instead of 15 FPS on ultra. This makes NO sense!

*Here's the important things I've realized that may help some*

This game is CPU heavy. In fact, my CPU is bottlenecking my GPU, in that I'm getting about 100% load on CPU but only 40% load on GPU when playing. The thing that made the game from unplayable to playable (some would still argue otherwise) was limiting my CPU affinity to 2 processors instead of 4. The 30 FPS limiter (hacked .dll) helped a lot to stop the FPS from going from 15FPS to 120FPS which made camera control really bad. Also, I have to run the game without Steam and I miss the achievements. I don't want to have to do this.

Does anyone else have ANY advise? All my drivers are current, all my redstributables are installed and current. My hard drive is defragged. I have nothing running in the background. No antivirus. All NVidia control panel options set to application controlled. I don't get this. Oblivion runs at a solid 60 FPS compeltely maxed with all .ini files tweaked to the max and high res texture mod installed. This game is broken for me.

The only thing I can think of is buying a motherboard that will allow CPU overclocking for my Core 2 Quad 2.4 GHz. I currently can not overclock as it's an OEM motherboard. Since this game is so CPU heavy I'd imagine OC'ing to 3.4 GHz would help a lot. Can anyone confirm if this is a good idea?

Here's a link to the .dll file I explained above:
http://skyrimnexus.com/downloads/file.php?id=34#content

Sorry for bad grammar and spelling

Last edited by TurkeyStyle: 11-12-2011 at 07:39 AM.
TurkeyStyle is offline   Reply With Quote
Old 11-12-2011, 09:05 AM   #4
PrivateBurke
 
Join Date: Jan 2010
Reputation: 148
Posts: 575
I fixed my issue by disabling AA completely and turning on FXAA. Now I run the game at Ultra with FPS in between 50 - 60.
PrivateBurke is offline   Reply With Quote
Old 11-12-2011, 09:09 AM   #5
NasherUK
 
 
 
Join Date: Feb 2007
Reputation: 160
Posts: 1,069
I think there is a memory leak somewhere, the game gets slower and slower then you start to get glitches and sometimes it will crash. Classic memory leak symptoms. This also happened in fallout 3 when it was released from what I remember :/

I can get as high as 100fps when I first start the game, but after maybe 15-30 mins it's pretty much unplayable and I have to restart it. The other annoying thing is mouse sensitivity seems to change with the FPS

Last edited by NasherUK: 11-12-2011 at 09:11 AM.
NasherUK is offline   Reply With Quote
Old 11-12-2011, 11:01 AM   #6
tomduffus
 
 
 
Join Date: Mar 2011
Reputation: 0
Posts: 179
the .dll you linked killed my fps. I capped at 30 (which is something i really want to do) but my framrates ended up in the low teens. It's working for you? That suprised me. It seems like a dx9 .dll
tomduffus is offline   Reply With Quote
Old 11-12-2011, 11:05 AM   #7
chipset35
 
Join Date: Jan 2010
Reputation: 80
Posts: 633
No issues here running at Ultra settings.
Just make sure you shut off Anti Aliasing and Astropic Filtering in teh games display settings.
I was able to go from High to Ultra by first shutting those off and then turning back up to 4x.
i7 920 and a ATI 5870 vid card
chipset35 is offline   Reply With Quote
Old 11-12-2011, 11:13 AM   #8
Spyridon
 
 
 
Join Date: Jul 2010
Reputation: 0
Posts: 13
I don't know man, I have a pretty old PC (dual core 2.6, 4gb ram, NVidia GTX460 video card) and I'm running above High without any problems. It runs better than Oblivion does for me.

I can even run ultra, but all the distance settings are not worth it for me, so I go with High and turn all the non-distance settings up.

Here are the exact settings I use: In Options hit the Detail: "High" button, then set Antialiasing off, anisotropic 8, go in Advanced, in Detail set "High, High, High, Ultra", FXAA unchecked, and all 4 Water checkboxes checked.

Then Close/Okay and you should be set. If my old PC can do it anyone with a similar or quad core should be having no issues.

Last edited by Spyridon: 11-12-2011 at 11:15 AM.
Spyridon is offline   Reply With Quote
Old 11-12-2011, 11:50 AM   #9
Yuki Chuki
 
Guest
Posts: n/a
Yeah, this really sucks!
I have:
- Phenom II X4 965 CPU
- 8GB RAM
- 2x GTX 560TI (SLI)
- Win7 64bit

I also installed the latest beta drivers. I get a good 28k points in 3D Mark Vantage an about 7k points in 3D Mark 11.
I can play Witcher 2 with everything enabled in 1080p. Even with Ubersampling turned on, I get a good 20FPS.

Yet, I can't play Skyrim even on low without having my FPS droping randomly to values between 10-20 FPS.
Heck, even on the Windows installation on my 2009 Mac Book Pro (2.53Ghz dual core CPU, 9600M GT with 256MB VRAM, 4GB RAM) I don't have this problems on medium(!).
That just sucks, especially in combat.

But there's one other thing: Where do we best report such things and has anyone allready done it?
No sense in getting worked up on this and hopping for it to get better if Bethesda doesn't even know about it.

Last edited by Yuki Chuki: 11-12-2011 at 11:54 AM.
  Reply With Quote
Old 11-13-2011, 07:49 AM   #10
rupok2
 
 
 
Join Date: Jun 2010
Reputation: 134
Posts: 1,976
its not a performance issue. Its something wrong with the game. If it was a performance issue I wouldn't be running at constant 60fps and then randomly dropping to 20. And it happens in any setting.

Hope this crap gets fixed cause bethesda never fixed this bug in oblivion and it looks like it carried over.
rupok2 is offline   Reply With Quote
Old 11-13-2011, 07:52 AM   #11
cwy
 
Join Date: Aug 2009
Reputation: 97
Posts: 114
This happens occasionally but only when I go outdoors or indoors, when I may suddenly see slide show frame rates. Have to exit to desktop (not main menu) to fix it.
cwy is offline   Reply With Quote
Old 11-13-2011, 07:59 AM   #12
DrSNAFU
 
Join Date: Oct 2009
Reputation: 55
Posts: 669
Yeah I'm running a pretty sweet setup with my computer too, I can play crysis 2 at ultra settings. But for some reason a lot of the interior zones of Skyrim really slow me down.

I heard somewhere that shadows are rendered on the CPU for some reason. Have you tried turning down ONLY your shadows? See if that's the problem?
DrSNAFU is offline   Reply With Quote
Old 11-13-2011, 08:58 AM   #13
Nanobotter
 
 
 
Join Date: Jul 2010
Reputation: 10
Posts: 208
Try running the game in windowed mode.
Nanobotter is offline   Reply With Quote
Old 11-13-2011, 09:01 AM   #14
z0diakwarrior
 
Join Date: Oct 2010
Reputation: 15
Posts: 122
Changed my Fov and it runs ALOT more smooth from my angle and Ive never had the real HARD CHOPS.

Hit ` type "Fov XX" no quotes and experiment the XX is your angle at 90 it alot more enjoyable for me. i think the Fov that is vanilla probably works wonders for the console users.....
z0diakwarrior is offline   Reply With Quote
Old 11-13-2011, 09:07 AM   #15
Wertoret
 
 
 
Join Date: Nov 2010
Reputation: 46
Posts: 886
Quote:
Originally Posted by chipset35 View Post
No issues here running at Ultra settings.
Just make sure you shut off Anti Aliasing and Astropic Filtering in teh games display settings.
I was able to go from High to Ultra by first shutting those off and then turning back up to 4x.
i7 920 and a ATI 5870 vid card
lol? i thought what made ultra to be ultra was the 16 samples of anisotropic filtering and the 8 samples of antialiasing...

hey now I can run at ultra at a steady 30 FPS outdoors then.
Wertoret is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.