Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 11-12-2011, 01:45 PM   #16
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Quote:
Originally Posted by Cha0s_St0rm View Post
Ive looked through both the SkyrimPrefs and the Skyrim files in both locations and noticed that there is 'iShadowMapResolutionPrimary' and a secondary version but cant see one that is just 'iShadowMapResolution- edit the primary?
You're looking in the wrong location. Look for the SkyrimPrefs.ini file that's located in My Documents/My Games/Skyrim/SkyrimPrefs.ini.

Just change iShadowMapResolution=0. Usually this will be: iShadowMapResolution=4096 or 2048 or 512
Changing to 0 removes shadow completely.

Don't edit iShadowMapResolutionPrimary

Last edited by Flakz: 11-12-2011 at 01:50 PM.
Flakz is offline   Reply With Quote
Old 11-12-2011, 01:53 PM   #17
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Quote:
Originally Posted by Gelbvieh View Post
I'm gonna try it now. Just out curiosity, if I put a very high number into that field rather than 0, could I improve the shadows? I'd rather have some than none for atmospheric reasons, but the lego sets that are default are really irritating me.
Yes they are irritating. I guess you could raise it, but you would take a huge performance hit. At, Ultra the setting is 4096. So keep in mind you need to raise it double that, so 8192 would be the step up from there. So on, and so forth.
Flakz is offline   Reply With Quote
Old 11-12-2011, 01:55 PM   #18
City Builder
 
 
 
Join Date: Mar 2009
Reputation: 41
Posts: 1,331
Quote:
Originally Posted by robotosis View Post
i did this and lost 30fps. my brain melted
Yup, you are not alone. I lost 15fps when I set it to 0, I returned it to 512 and got back my lost 15fps.

I know for me shadows are almost always the biggest system hog in the games that I play and turning them off completely almost always makes a game that might be borderline playable, shoot up to ultra smooth fps, apparently doing this however does the opposite and actually loses me fps.

Strange.
City Builder is offline   Reply With Quote
Old 11-12-2011, 01:57 PM   #19
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Quote:
Originally Posted by City Builder View Post
Yup, you are not alone. I lost 15fps when I set it to 0, I returned it to 512 and got back my lost 15fps.

I know for me shadows are almost always the biggest system hog in the games that I play and turning them off completely almost always makes a game that might be borderline playable, shoot up to ultra smooth fps, apparently doing this however does the opposite and actually loses me fps.

Strange.
Hmmm, what kind of video card are you using?

Just asking cause, it essentially doubles my fps with the shadows turned off (testing with V-sync off).

I'm using a GTX 560Ti.

Last edited by Flakz: 11-12-2011 at 02:05 PM.
Flakz is offline   Reply With Quote
Old 11-12-2011, 02:04 PM   #20
Pat1487
 
Join Date: Jan 2008
Reputation: 72
Posts: 310
When shadows are at Ultra they look good (with any other setting they are blocky) but the game performs pretty bad for me

I found setting shadows to Medium and then going to the INI (in my games\skyrim) and changing/adding these lines to this:

iShadowMapResolution=4096
iShadowMapResolutionSecondary=4096
iShadowMapResolutionPrimary=4096

It makes the shadows look almost as good as Ultra (they arent all blocky) but the performance runs as if it were still set to Medium
I dont know why this works like it does
Pat1487 is offline   Reply With Quote
Old 11-12-2011, 02:06 PM   #21
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Quote:
Originally Posted by Pat1487 View Post
When shadows are at Ultra they look good (with any other setting they are blocky) but the game performs pretty bad for me

I found setting shadows to Medium and then going to the INI (in my games\skyrim) and changing/adding these lines to this:

iShadowMapResolution=4096
iShadowMapResolutionSecondary=4096
iShadowMapResolutionPrimary=4096

It makes the shadows look almost as good as Ultra (they arent all blocky) but the performance runs as if it were still set to Medium
I dont know why this works like it does
Will give this a shot then report back

EDIT: Gave this a shot, FPS went from ~115fps to ~25fps.....

Last edited by Flakz: 11-12-2011 at 02:11 PM.
Flakz is offline   Reply With Quote
Old 11-12-2011, 02:13 PM   #22
City Builder
 
 
 
Join Date: Mar 2009
Reputation: 41
Posts: 1,331
Quote:
Originally Posted by Flakz View Post
Hmmm, what kind of video card are you using?

Just asking cause, it essentially doubles my fps with the shadows turned off (testing with V-sync off).

I'm using a GTX 560Ti.
Nvidia GTX 460
City Builder is offline   Reply With Quote
Old 11-12-2011, 02:15 PM   #23
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Quote:
Originally Posted by City Builder View Post
Nvidia GTX 460
Very strange. It works for me like a charm. Sorry it's not helping you out!
Flakz is offline   Reply With Quote
Old 11-12-2011, 02:17 PM   #24
City Builder
 
 
 
Join Date: Mar 2009
Reputation: 41
Posts: 1,331
No biggie, I'm getting a solid 60fps when I turn SLI in the nvidia control panel, or maybe it's not turned on, specifically for the game, well whatever, it's a solid 60 fps in the game right now so no need for me to go up more than that. If it starts to bog down at some point in the game then I'm sure I'll start frantically looking for help.
City Builder is offline   Reply With Quote
Old 11-12-2011, 02:25 PM   #25
Pat1487
 
Join Date: Jan 2008
Reputation: 72
Posts: 310
Quote:
Originally Posted by Flakz View Post
Will give this a shot then report back

EDIT: Gave this a shot, FPS went from ~115fps to ~25fps.....
Thats weird, it works for me
When i did what you said, to turn them off, i lose FPS, like others here


For those that lost FPS by turning off shadows like what was said here
Try doing what i said in my last post
Pat1487 is offline   Reply With Quote
Old 11-12-2011, 02:27 PM   #26
gueber
 
Join Date: Jun 2011
Reputation: 11
Posts: 25
If you don't want to turn off your shadows completely try playing with

iBlurDeferredShadowMask=3

Setting it lower will make the shadows sharper, this may make them look nicer if your pc can handle higher res shadow maps.

iBlurDeferredShadowMask=1
iShadowMapResolution=4096
iShadowMapResolutionSecondary=4096
iShadowMapResolutionPrimary=4096

If your pc can't handle 4096 shadow maps, and I know mine cant then try actually turning up the blur mask it will help cover the jaggedness of lower res shadows.

iBlurDeferredShadowMask=6
iShadowMapResolution=2048
iShadowMapResolutionSecondary=2048
iShadowMapResolutionPrimary=2048
gueber is offline   Reply With Quote
Old 11-12-2011, 02:29 PM   #27
Gelbvieh
 
Join Date: Jul 2011
Reputation: 18
Posts: 470
Quote:
Originally Posted by Pat1487 View Post
When shadows are at Ultra they look good (with any other setting they are blocky) but the game performs pretty bad for me

I found setting shadows to Medium and then going to the INI (in my games\skyrim) and changing/adding these lines to this:

iShadowMapResolution=4096
iShadowMapResolutionSecondary=4096
iShadowMapResolutionPrimary=4096

It makes the shadows look almost as good as Ultra (they arent all blocky) but the performance runs as if it were still set to Medium
I dont know why this works like it does
Ah this all certainly does work quite well, just murders FPS. Thanks though, I'll just have a play around with different values.

Ah brilliant! iBlurShadowMask=6 and the resolutions at 2048 works excellently and makes shadows bearable. Thanks!

Last edited by Gelbvieh: 11-12-2011 at 02:33 PM.
Gelbvieh is offline   Reply With Quote
Old 11-12-2011, 02:30 PM   #28
PereKermann
 
Join Date: Apr 2011
Reputation: 24
Posts: 148
I've got a GTX 560 Ti, and the first suggestion dropped my FPS by about 30.

The second (increasing the values to 4096), however, made my FPS more stable... It just evened out. Slightly lower max number, and no drops so far. And the shadows look amazing.

This game is weird.

Last edited by PereKermann: 11-12-2011 at 02:36 PM.
PereKermann is offline   Reply With Quote
Old 11-12-2011, 02:32 PM   #29
Flakz
 
Join Date: Oct 2011
Reputation: 30
Posts: 292
Ok guys I figured it out. Disabling shadows completely increases FPS INDOORS. OUTSIDE it actually lowers FPS. I'm not sure why this is. I was testing in a dungeon because that's where it seemed I lost most of my FPS.

EDIT: I'm guessing it has something to do with the dynamic shadows from the Sunlight/Moonlight outside. Weird tho.
Flakz is offline   Reply With Quote
Old 11-12-2011, 02:36 PM   #30
HorseRotorvator
 
 
 
Join Date: Jun 2009
Reputation: 168
Posts: 1,256
By turning off shadows I went from 60 fps outside Riften and 90 fps inside a dungeon on 8xaf, medium textures, medium radial to 15 fps outside Riften and 30 fps inside a dungeon with everything on low.

Radeon HD 5670

Pat's method did pretty much the same thing.
HorseRotorvator is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.