Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 11-18-2011, 05:14 PM   #1
Batguano
 
Join Date: Jun 2011
Reputation: 61
Posts: 344
Possible Solution to Input Lag or Stuttering (Prob already posted)

This has probably already been posted, but I did not see it on the main OP on the Tweak Sticky.

So far, the game runs extremely well for me (AMD 1090t w/6970 2gig). Except, I was getting god awful lag when looking left or right. It was bad with the 360 gamepad and unplayable with the mouse.

I could eliminate the lag if I turned off the vysnch by placing
iPresentInterval=0 under the Display section of the Skyrim.ini that is in your Mygames/Skyrim folder.

No lag or stuttering when turning, except my game was running at 200FPS+ in dungeons and the vertical look was completely broken.

There is a program you can use to limit FPS called DXtory (http://dxtory.com/v2-home-en.html) that you can download and run. When you run it, turn off the Overlay (unless you want to see the FPS using this program) and open the Advanced Section (icon looks like a chip).
At the bottom of that screen is the limit VideoFPS. Set it to what you want. I set it to 60FPS.

Minimize the program. It will detect whatever game you run and automatically limit the FPS to whatever you set.

If you now run Skyrim it will limit the FPS to 60 and should fix the input lag and stuttering (It did for me)

The problem now is the screen has god awful tearing when looking around.

On a whim, I set RadeonPro to force Vsync on my Skyrim profile just to see if it would work in conjuction with the FPS limiting of Dxtory.

It does. No screen tearing and no horrible stuttering when looking around.

Now, I still get some stutter around certain lights, but the overall lag/stutter is gone.

RadeonPro is simply a tweak progrma for adjusting the graphic card settings for ATI cards. I think Nvidia Inspector is the equivalent for Nvidia cards.

I use it because the CCC for ATI cards isn't very robust at all. Nvidia's card control program through their drivers is better, but I don't know if it can force vsynce worth a crud. ATI's CCC cannot, that is why you need to use RadeonPro or perhaps D3DOverider.

I suspect that turning the iPresentInterval back to 1 would work as well as forcing the vsync through RadeonPro. But, it is working for me this way and experience has taught me that when playing a Gamebyro engine game (the Creation engine sure feels like a hopped up Gamebyro engine) once you get it good, leave it alone.

Like I said, this has probably been posted before, and it may be one of those things that only work for a few.

So after that giant wall of text, here is more:
  1. Open Skyrim.ini and under the Display section place iPresentInterval=0
  2. Download and install Dxtory. Open the Advanced Section of this program and set the VideoFPS to what you want.
  3. Force Vsync through the Graphics Driver or through the tweak program for your card.
  4. Profit.


Bats
Batguano is offline  
Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.