Go Back   Steam Users' Forums > Steam Game Discussions > H - L > L.A. Noire

Reply
 
Thread Tools Display Modes
Old 11-22-2011, 10:22 AM   #1
clcjune
 
Guest
Posts: n/a
Launch but failed to open the game

I launched the game

then it showed me ( failed to load library "d3dx9_43.dll" )

and nothing happened!


What should I do?

BTW Mine is retail version!
 
Reply With Quote
Old 11-22-2011, 11:40 AM   #2
HellAvenger
 
Join Date: Aug 2011
Reputation: 49
Posts: 749
Quote:
Originally Posted by clcjune View Post
I launched the game

then it showed me ( failed to load library "d3dx9_43.dll" )

and nothing happened!


What should I do?

BTW Mine is retail version!
That look like directx 9 issue. Reintall directx 9 from CD 1 of L.A. Noire

I have even worse problem. No error message, just appear in task manager and dissapear again. Never launched.
HellAvenger is offline   Reply With Quote
Old 11-25-2011, 05:59 AM   #3
Teh_Saccade
 
 
 
Join Date: Mar 2010
Reputation: 38
Posts: 328
Are you using Win 7?

I've got this problem too, and have reinstalled DX SDK - dxdiag states all is working fine, 9 through 11, nvidia control panel states all is a-ok...

However, when I verify the game files, it keeps saying 2 files failed to verify - 5gb...
I even deleted the folders and reinstalled, but the same error occurs. Then it says the same 2 files failed to validate.

Meh, at least it was 50% off. I'm glad I waited. Hopefully I'll figure out how to fix it.
This is a brand new installation of Win7Pro on a new SSD I got - I'm installing progs and games on the 2nd hdd, since the ssd is only 128gb.

Don't think that has anything to do with it, but...

Have you tried to do this?
http://www.microsoft.com/download/en/details.aspx?id=35

If you figure it out, CLCJune - will you let us know, please?
I'll do the same if I get it working.

So many people have problems, then fix them and don't let the community know about it :P

Last edited by Teh_Saccade: 11-25-2011 at 06:16 AM. Reason: correct link
Teh_Saccade is offline   Reply With Quote
Old 11-27-2011, 09:15 AM   #4
distorto_666
 
Guest
Posts: n/a
@clcjune - I had the same d3dx9_43.dll error message, but then downloaded and installed DirectX 9c components (they are compatible with Windows 7)... error is now gone, but now I'm at the same spot as @HellAvenger - game doesn't launch at all... but with no errors either...pretty effing frustrating...

Suggestions have been to turn off UAC - which, admittedly, I haven't done yet. I would think launching Steam as an admin would suffice, but apparently not.
  Reply With Quote
Old 02-24-2012, 04:41 PM   #5
mooncow
 
Join Date: Feb 2012
Reputation: 0
Posts: 1
I got this exact message on first installing LAN, and used the link in Teh_Saccade's post to install the DirectX update. Works fine now. Thanks.
mooncow is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > L.A. Noire


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.