Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Battlefield series

Reply
 
Thread Tools Display Modes
Old 11-23-2011, 07:24 PM   #1
LOL-ness
 
Join Date: Jun 2009
Reputation: 110
Posts: 628
Ultimate Battlefield 3 fixes guide

Heads up guys. Just encountered a thread on the EA Forums regarding a few BF3 fixes post-patch. Some of the fixes are pretty new, while some are variations of existing fixes, so it might help the sizable portion of players who are having trouble with the game right now.

LINK HERE


From the thread:

Quote:
I see that a lot of ppl are still having issues with the game (crashes, rubberbanding, disconnections etc etc). I resolved most of my problem, now the game is stable and i only get disconnected if the whole server that i'm playing in, crash, or if an admin log in with a reserved slot .

Here's a complete and detailed list with things you can try in order to completely fix your battlefield:

Problem 1:
The game ALWAYS crash after 2-5 minutes/pc reboot itself after 2-5 minutes.

Solution:
-Reboot your computer, open the bios (by spamming del on your keyboard)
-Get to the motherboard configuration-north bridge configuration
-Disable HD audio. if it's enabled, you simply press + till it says is disabled.

IMPORTANT:
by doing this, your PC audio will be completely disabled unless you have an audio card or an USB headset or something similiar (usb).
To re-enable audio, simply get back to the settings and enable HD audio again.

Problem 2:
The game crash randomly after about 15/20 minutes.

Solution:
-Press start (or the windows logo)
-Type in the searchbar "cmd" without the "
-Press enter
-a command windows should open up. write "bcdedit /set increaseUserVa 3072" without the "
-Press enter

Case 1: operation concluded succesfully (or a similiar message)
-reboot PC

Case 2: you are not allowed to do that (or a similiar message)
-Press start again
-Click "all programs"
-Click "accessories"
-RIGHT click "command prompt" and click "Run As Admin"
-Type in the command windows "bcdedit /set increaseUserVa 3072" as always without the "
-Reboot

This will fix the problem, wich is caused by memory leak

Problem 3:
Get disconnected very often without a reason.

Solution 1:
-Download PBsetup from here: PunkBuster Online Countermeasures
-Extract the files in a folder
-Run PBSETUP.exe
-Click "add a game"
-Select "Battlefield 3". The path of the game should be detected automatically, if not, point it to the right path.
-Click check for updates
-Once the downloads are over, you'll get a message "battlefield 3 is up to date" or similiar. you may now close the application.

Solution 2
-Click on the windows logo/start button
-In the searchbar, type services.msc
-Press ENTER
-A list of services should now be in front of you.
-Click "extended" tab
-Search for "UPnP host devices" or something similiar (the description is something like: Allow hosting of UPnP devices blablabla)
-Right click it
-Click Properties
-I don't know how to translate this, but there is an option like "startup", in the general tab. You can choose between: Automatic (delayed startup), Automatic, Manually, Disabled. You must choose Disabled.
-Click on "stop service"
-Click "apply" and close that little windows.
-Search for "SSPD discovery" and do the same things that you did above.
-Close everything
-Reboot.

Solution 3
-Open chrome/IE/firefox
-Type in the adress bar 192.168.0.1 and press enter. if nothing work with that IP, try with one of these: 192.168.1.1, 127.0.0.1, 127.0.1.1. With one of these IPs you should be able to open up your router's page.
-Log into the router panel (username is usually "admin" or "administrator", aswell as the password)
-Once you are in, you should search for an option called UPnP, and disable it. it might be somewhere in the advanced options, i really can't help you with this one because it's not on my router, and every router it's different, so you might or might not have it.

In case you still have the problem...well...go to the nearest churc and turn on a candle, then prey for a bit.

Problem 4:
EXTREME rubberbanding, mostly in Caspian Borders, Teheran Highway and Grand Bazhaar.

what's rubberbanding?
Battlefield 3 Rubberbanding. - YouTube

Solution:
-Reboot your computer
-Spam DEL till you open the biones panel again
-Search for advanced options
-CPU configuration
-Look for an option named "HTT" or "Hyper Treading" or "Hyper Treading Technology" and press + till it's disabled.
-Save and exit

I know this might look strange, but it fixed me, and 5 other friends, the rubberbanding issue (different cpu's, 4 intel and 2 amd).
You will still notice some rubberbanding if the server is lagging.
edit: no idead what to do with the amd, since i've been reported that htt it's just for intel :> i guess the 2 amd guys didn't have the problem in the first place or disabled another tech, i'll ask them and report here

Problem 5:
The screen goes black and the game crashes everytime i try to join a server

This happened me yesterday too, basically i was playing CQ64 on metro, and the game crashed (probably god punishment or karma :P). After that, i tried to rejoin on metro like 5/6 times, everytime the game was not loading at all, and eventually crashing during the map loading:

Solution 1:
-Join a server with a different map, this will eventually restore the whole game (worked for me)

Solution 2:
-Run a repair from Origin (right click battlefield 3 on origin, and click reapair)

ALL THE SOLUTION WROTE ABOVE ARE REVERSIBLE, SO FEEL FREE TO TEST OUT EVERYTHING, IT MIGHT HELP YOU.

Last edited by LOL-ness: 11-23-2011 at 07:39 PM.
LOL-ness is offline  
Reply With Quote
Old 11-24-2011, 04:06 PM   #2
LOL-ness
 
Join Date: Jun 2009
Reputation: 110
Posts: 628
/Bump

Just tried the Solution to Problem 2 (Changing the value to '3072' rather than '2500'). It works! I can play again.
LOL-ness is offline   Reply With Quote
Old 11-24-2011, 11:41 PM   #3
icedude90
 
 
 
Join Date: Dec 2010
Reputation: 42
Posts: 381
+ rep to u buddy
icedude90 is offline   Reply With Quote
Old 11-24-2011, 11:59 PM   #4
Ace Quat
 
Join Date: Jul 2006
Reputation: 190
Posts: 3,149
Quote:
Originally Posted by LOL-ness View Post
/Bump

Just tried the Solution to Problem 2 (Changing the value to '3072' rather than '2500'). It works! I can play again.
be careful though. changing the value to 3072 on my win7 64bit once gave me a 'bf3.exe stopped working' error because the kernel went out of available memory (as you're basically restricting its value with that command)
Ace Quat is offline   Reply With Quote
Old 11-25-2011, 12:23 AM   #5
hahahehe
 
 
 
Join Date: Sep 2010
Reputation: 832
Posts: 2,343
@Problem One

Isnt that like telling someone with sight issues that the best way to correct their vision is to remove their eyes?

Much easier fix

1) Right Click on the Speaker icon.
2) Right click "Speakers" and select properties.
3) Advanced tab (far right)
4) Uncheck "Allow applications to take exclusive control of this device".

@Problem 4

Disabling Hyper Threading will significantly reduce your PCs performance for everything, your effectively halving the amount of CPU power you have in one go.

Last edited by hahahehe: 11-25-2011 at 03:02 AM.
hahahehe is offline   Reply With Quote
Old 11-25-2011, 01:30 AM   #6
MSTRB
 
 
 
Join Date: Mar 2011
Reputation: 1045
Posts: 1,751
Quote:
Originally Posted by LOL-ness View Post
/Bump

Just tried the Solution to Problem 2 (Changing the value to '3072' rather than '2500'). It works! I can play again.
This solution is only for 32 bit users I believe.
MSTRB is offline   Reply With Quote
Old 11-25-2011, 10:51 AM   #7
Minamimoto Sho
 
Join Date: Oct 2011
Reputation: 33
Posts: 294
Quote:
Disabling Hyper Threading will significantly reduce your PCs performance for everything, your effectively halving the amount of CPU power you have in one go.
Disabling Intel's gimmicky multithreading technology will not halve your CPU performance.

/facepalm
Minamimoto Sho is offline   Reply With Quote
Old 11-27-2011, 05:56 PM   #8
LOL-ness
 
Join Date: Jun 2009
Reputation: 110
Posts: 628
Quote:
Originally Posted by Ace Quat View Post
be careful though. changing the value to 3072 on my win7 64bit once gave me a 'bf3.exe stopped working' error because the kernel went out of available memory (as you're basically restricting its value with that command)
I have yet to encounter this error (been running BF3 for 2-3 hrs at a time), but thanks for the warning.


Quote:
Originally Posted by MSTRB View Post
This solution is only for 32 bit users I believe.
That is correct. I was under the impression that this problem is mostly suffered by people running 32-bit machines though (because they are restricted by how much RAM they can add to their machines, hence more adversely affected by BF3's memory leak problems).

Last edited by LOL-ness: 11-27-2011 at 06:00 PM.
LOL-ness is offline   Reply With Quote
Old 12-12-2011, 07:07 PM   #9
SoA-Fanatic
 
Banned
Join Date: Aug 2005
Reputation: 0
Posts: 174
Quote:
Originally Posted by LOL-ness View Post
I have yet to encounter this error (been running BF3 for 2-3 hrs at a time), but thanks for the warning.




That is correct. I was under the impression that this problem is mostly suffered by people running 32-bit machines though (because they are restricted by how much RAM they can add to their machines, hence more adversely affected by BF3's memory leak problems).
ok well i changed value before i read this post , i am running windows 7 64bit and i tryed changing value to 3072 , it didnt hellp
game still crashes , so is ther other solution for 64bit or and how do i change to original seting
SoA-Fanatic is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Battlefield series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.