Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist

Reply
 
Thread Tools Display Modes
Old 11-26-2011, 03:40 PM   #1
Sacre85
 
Join Date: Jul 2009
Reputation: 21
Posts: 111
Tweaks (FOV workaround, increase settings, run on older systems!)

NOTE: This thread may be useless now thanks to the new official patch! Thanks devs! Find info here - http://forums.steampowered.com/forum....php?t=2280136 - I'll update the post if there are any settings still worth changing, or if you find something worth changing post it.


















After playing for a bit, I got tired of the low FOV and decided to dig around a little. I found the renderer_settings.xml in C:\Users\Myname\AppData\Local\PAYDAY\renderer_sett ings.xml.

Steps to ONLY change the FOV/Aspect Ratio:

1. Make sure you ran the game once first for the settings to establish themselves.
2. Close the game.
3. Open up your renderer_settings.xml using notepad or something (it will be in your AppData\Local\PAYDAY folder - Google if you're not sure how to find it!)
4. Scroll down till you find "aspect_ratio = " and look at the number. I run 1920x1200, so my aspect ratio by default is 1.6. If you run at 1920x1080, it will probably be 1.77 (or thereabouts).
5. Change that number to something a bit higher, and restart the game to see if you like it.

I went from 1.6 to 2.0 and it feels a bit squished - I'll be trying 1.8 or 1.9 next. It's imperfect, but you can tweak it a bit and find what's comfortable for you.


Now, for the other settings!
I used to play GRAW, and we used to edit our renderer_settings.xml files. I noticed that this game has the same name, and some of the same options inside... so I pasted my old GRAW settings in there, set them all to low, and oh lawdy the game looked AWFUL. So I set everything to high, and the game looks fine. My FPS was also slightly lower (from ~110FPS to 95FPS) so I assume *SOMETHING* has improved? I don't have the best eye for this stuff, so I'll let you decide.


Before (@ 1.6 ratio):
https://picasaweb.google.com/1177821...3/PaydayBEFORE

After (@ 2.0 ratio + GRAW high settings - after looking this over I'll probably drop to 1.8 or 1.9):
https://picasaweb.google.com/1177821...33/PaydayAFTER

If you want to use the GRAW settings, change the portion between the renderer_config tags. Make sure you leave your adapter/adapter_index/resolution as your own! Don't change it to NVIDIA GeForce GTX 460, especially if you don't have one!

Code:
<renderer_config>
	<d3d_device
		adapter = "NVIDIA GeForce GTX 460"
		adapter_index = "0"
		resolution = "1920 1200"
		windowed = "false"
		refresh_rate = "59"
		v_sync = "1"
	/>
    <render_settings>
            <variable name="adapter_num" value="0"/>
            <variable name="anti_aliasing" value="disabled"/>
            <variable name="aspect_ratio" value="2.0"/>
            <variable name="brightness" value="1"/>
            <variable name="dynamic_lights" value="true"/>
            <variable name="effect_quality" value="high"/>
            <variable name="environment_detail" value="1"/>
            <variable name="max_anisotropy" value="1"/>
            <variable name="post_effect_quality" value="high"/>
            <variable name="shadow_map_size" value="0"/>
            <variable name="shadow_quality" value="enabled"/>
            <variable name="show_all_res" value="true"/>
            <variable name="texture_quality" value="high"/>
            <variable name="texture_quality_backdrop" value="high"/>
            <variable name="texture_quality_buildings" value="high"/>
            <variable name="texture_quality_buildings_bump" value="high"/>
            <variable name="texture_quality_buildings_low" value="high"/>
            <variable name="texture_quality_characters" value="high"/>
            <variable name="texture_quality_default" value="high"/>
            <variable name="texture_quality_effects" value="high"/>
            <variable name="texture_quality_ground" value="high"/>
            <variable name="texture_quality_ground_bump" value="high"/>
            <variable name="texture_quality_gui" value=""/>
            <variable name="texture_quality_lightmaps" value="high"/>
            <variable name="texture_quality_no_lod" value="high"/>
            <variable name="texture_quality_plants" value="high"/>
            <variable name="texture_quality_player_vehicles" value="high"/>
            <variable name="texture_quality_props" value="high"/>
            <variable name="texture_quality_props_bump" value="high"/>
            <variable name="texture_quality_props_high" value="high"/>
            <variable name="texture_quality_silhouettes" value="high"/>
            <variable name="texture_quality_sky" value="high"/>
            <variable name="texture_quality_vehicles" value="high"/>
            <variable name="texture_quality_weapons" value="high"/>
            <variable name="texture_quality_weapons_third" value="high"/>
    </render_settings>
</renderer_config>

Edit: IF YOU'RE USING THE NVIDIA ANTIALIASING FIX!
I noticed after I applied the nVidia anti-aliasing fix (found here - http://solidlystated.com/software/pa...phics-options/ ) that there's a strong black 'glow' on the bottom half of the screen.

All you need to do is set shadow_quality to disabled:

Code:
<variable name="shadow_quality" value="disabled"/>
And the glow is gone. Worth it for AA IMO.





For running on lower end systems, just use the profile below posted by axlevest, and nudge some things up until it doesn't look awful. PLEASE note - from overkill_bo - that the dynamic_lights must be set to true. It messes up the graphics bad.

Last edited by Sacre85: 12-09-2011 at 07:14 PM.
Sacre85 is offline  
Reply With Quote
Old 11-26-2011, 03:55 PM   #2
axlevest
 
Join Date: Aug 2010
Reputation: 15
Posts: 216
so this lets you change the video settings, sweet jesus u are a god and this needs to be stickied
axlevest is offline   Reply With Quote
Old 11-26-2011, 04:02 PM   #3
axlevest
 
Join Date: Aug 2010
Reputation: 15
Posts: 216
her is the code for Lowest Quality

<renderer_config>
<d3d_device
adapter = "NVIDIA GeForce 9400M"
adapter_index = "0"
resolution = "800 600"
windowed = "false"
refresh_rate = "59"
v_sync = "0"
/>
<render_settings>
<variable name="adapter_num" value="0"/>
<variable name="anti_aliasing" value="disabled"/>
<variable name="aspect_ratio" value="2.0"/>
<variable name="brightness" value="1"/>
<variable name="dynamic_lights" value="false"/>
<variable name="effect_quality" value="low"/>
<variable name="environment_detail" value="0"/>
<variable name="max_anisotropy" value="1"/>
<variable name="post_effect_quality" value="low"/>
<variable name="shadow_map_size" value="0"/>
<variable name="shadow_quality" value="enabled"/>
<variable name="show_all_res" value="true"/>
<variable name="texture_quality" value="high"/>
<variable name="texture_quality_backdrop" value="low"/>
<variable name="texture_quality_buildings" value="low"/>
<variable name="texture_quality_buildings_bump" value="low"/>
<variable name="texture_quality_buildings_low" value="low"/>
<variable name="texture_quality_characters" value="low"/>
<variable name="texture_quality_default" value="low"/>
<variable name="texture_quality_effects" value="low"/>
<variable name="texture_quality_ground" value="low"/>
<variable name="texture_quality_ground_bump" value="low"/>
<variable name="texture_quality_gui" value=""/>
<variable name="texture_quality_lightmaps" value="low"/>
<variable name="texture_quality_no_lod" value="low"/>
<variable name="texture_quality_plants" value="low"/>
<variable name="texture_quality_player_vehicles" value="low"/>
<variable name="texture_quality_props" value="low"/>
<variable name="texture_quality_props_bump" value="low"/>
<variable name="texture_quality_props_high" value="low"/>
<variable name="texture_quality_silhouettes" value="low"/>
<variable name="texture_quality_sky" value="low"/>
<variable name="texture_quality_vehicles" value="low"/>
<variable name="texture_quality_weapons" value="low"/>
<variable name="texture_quality_weapons_third" value="low"/>
</render_settings>
</renderer_config>
axlevest is offline   Reply With Quote
Old 11-26-2011, 04:07 PM   #4
Sacre85
 
Join Date: Jul 2009
Reputation: 21
Posts: 111
Quote:
Originally Posted by axlevest View Post
her is the code for Lowest Quality

<renderer_config>
<d3d_device
adapter = "NVIDIA GeForce 9400M"
adapter_index = "0"
resolution = "800 600"
windowed = "false"
refresh_rate = "59"
v_sync = "0"
/>
<render_settings>
<variable name="adapter_num" value="0"/>
<variable name="anti_aliasing" value="disabled"/>
<variable name="aspect_ratio" value="2.0"/>
<variable name="brightness" value="1"/>
<variable name="dynamic_lights" value="false"/>
<variable name="effect_quality" value="low"/>
<variable name="environment_detail" value="0"/>
<variable name="max_anisotropy" value="1"/>
<variable name="post_effect_quality" value="low"/>
<variable name="shadow_map_size" value="0"/>
<variable name="shadow_quality" value="enabled"/>
<variable name="show_all_res" value="true"/>
<variable name="texture_quality" value="high"/>
<variable name="texture_quality_backdrop" value="low"/>
<variable name="texture_quality_buildings" value="low"/>
<variable name="texture_quality_buildings_bump" value="low"/>
<variable name="texture_quality_buildings_low" value="low"/>
<variable name="texture_quality_characters" value="low"/>
<variable name="texture_quality_default" value="low"/>
<variable name="texture_quality_effects" value="low"/>
<variable name="texture_quality_ground" value="low"/>
<variable name="texture_quality_ground_bump" value="low"/>
<variable name="texture_quality_gui" value=""/>
<variable name="texture_quality_lightmaps" value="low"/>
<variable name="texture_quality_no_lod" value="low"/>
<variable name="texture_quality_plants" value="low"/>
<variable name="texture_quality_player_vehicles" value="low"/>
<variable name="texture_quality_props" value="low"/>
<variable name="texture_quality_props_bump" value="low"/>
<variable name="texture_quality_props_high" value="low"/>
<variable name="texture_quality_silhouettes" value="low"/>
<variable name="texture_quality_sky" value="low"/>
<variable name="texture_quality_vehicles" value="low"/>
<variable name="texture_quality_weapons" value="low"/>
<variable name="texture_quality_weapons_third" value="low"/>
</render_settings>
</renderer_config>
With these settings, the game looks SO AWFUL, it's hilarious.


Also, I changed it from 2.0 to 1.8 and like it much more. So if you have a 1.6 native resolution, try 1.8 and see if that improves your FOV any.
Sacre85 is offline   Reply With Quote
Old 11-26-2011, 04:46 PM   #5
SwissyJim
 
Join Date: Nov 2008
Reputation: 22
Posts: 171
THANK YOU THANK YO THANK YOU!

Dunno if this is all that can be done, but the FoV is slightly better now. I went with the 1.9 change...
SwissyJim is offline   Reply With Quote
Old 11-26-2011, 04:47 PM   #6
Dr.Greenthumb
 
Join Date: Oct 2009
Reputation: 37
Posts: 285
Any way to change FOV without squishing the aspect ratio?
Dr.Greenthumb is offline   Reply With Quote
Old 11-26-2011, 04:51 PM   #7
Sacre85
 
Join Date: Jul 2009
Reputation: 21
Posts: 111
Quote:
Originally Posted by Dr.Greenthumb View Post
Any way to change FOV without squishing the aspect ratio?
Not really. GRAW didn't have a FOV setting in the renderer_settings.xml, so I'm not sure how. I tried tags named fov, field_of_view, etc but nothing changed. 0.1-0.3 above your default seems to add some extra horizontal viewing without squishing, but it really depends on how sensitive your eyes are to it.
Sacre85 is offline   Reply With Quote
Old 11-26-2011, 04:54 PM   #8
Dr.Greenthumb
 
Join Date: Oct 2009
Reputation: 37
Posts: 285
grr why won't the devs say anything about this. Starting to feel like the L4D2 v_model fov fiasco. Took valve forever to budge and give us a command to change it.
Dr.Greenthumb is offline   Reply With Quote
Old 11-26-2011, 05:30 PM   #9
DexterSinister
 
Join Date: Sep 2007
Reputation: 12
Posts: 241
Thanks for posting this. Will try tonight.
+rep
DexterSinister is offline   Reply With Quote
Old 11-27-2011, 04:59 AM   #10
Ricster2k
 
Join Date: Apr 2011
Reputation: 22
Posts: 163
awesome thanks! I'll try this tonight when I get home.
I hate it when games give you tunnel vision, it hurts the eyes.
Ricster2k is offline   Reply With Quote
Old 11-27-2011, 07:03 AM   #11
mister_benn
 
 
 
Join Date: Oct 2009
Reputation: 3
Posts: 56
Heroic work, plays on my laptop now, with the low settings.
mister_benn is offline   Reply With Quote
Old 11-27-2011, 09:37 AM   #12
Sacre85
 
Join Date: Jul 2009
Reputation: 21
Posts: 111
Quote:
Originally Posted by mister_benn View Post
Heroic work, plays on my laptop now, with the low settings.
Haha awesome, didn't even think about that. Guess it'll run on older computers if you drop the settings, yep!
Sacre85 is offline   Reply With Quote
Old 11-28-2011, 05:15 AM   #13
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
Hi guys

If you change these you are a bit on your own until they make it in to the Advanced Gfx menu.

NOTE: <variable name="dynamic_lights" value="false"/>

Never set this to false. This will ruin the new light system.

Thanks

Bo
overkill_bo is offline   Reply With Quote
Old 11-28-2011, 01:04 PM   #14
kufooru
 
Join Date: Dec 2009
Reputation: 184
Posts: 583
Oh.
My.
God.

You, sir, deserve a medal!
kufooru is offline   Reply With Quote
Old 11-30-2011, 10:10 AM   #15
Sacre85
 
Join Date: Jul 2009
Reputation: 21
Posts: 111
Quote:
Originally Posted by overkill_bo View Post
Hi guys

If you change these you are a bit on your own until they make it in to the Advanced Gfx menu.

NOTE: <variable name="dynamic_lights" value="false"/>

Never set this to false. This will ruin the new light system.

Thanks

Bo
Wow, it certainly does mess the visuals up. Lots of flickering and stuff.
Sacre85 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:27 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.