Go Back   Steam Users' Forums > Steam Game Discussions > H - L > inMomentum

Reply
 
Thread Tools Display Modes
Old 12-08-2011, 11:29 AM   #1
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
Red face Crash on Startup

Hi, tried launch game and this happend:

Quote:
Direct3DDevice->CreateVertexShader((DWORD*)&Code(0),(IDirect3DVer texShader9**)VertexShader.GetInitReference()) failed
at D:\inMomentum\UnrealEngine3\Development\Src\D3D9Dr v\Src\D3D9Shaders.cpp:12
with error D3DERR_INVALIDCALL

System.Runtime.InteropServices.SEHException error in IMGame:

V externí součásti došlo k výjimce.

v GuardedMainWrapper(Char* , HINSTANCE__* , HINSTANCE__* , Int32 )
v ManagedGuardedMain(Char* CmdLine, HINSTANCE__* hInInstance, HINSTANCE__* hPrevInstance, Int32 nCmdShow)Address = 0x76fdb727 (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]
appRaiseException() Address = 0x16644e1 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FOutputDeviceWindowsError::Serialize() Address = 0x16b41a4 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FOutputDevice::Logf__VA() Address = 0x166a88b (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
VerifyD3D9Result() Address = 0x315060d (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FD3D9DynamicRHI::CreateVertexShader() Address = 0x31569ad (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
RHICreateVertexShader() Address = 0x13e6585 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FShader::InitRHI() Address = 0x197f977 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FD3D9DynamicRHI::UpdateD3DDeviceFromViewports() Address = 0x3152ba9 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FD3D9Viewport::FD3D9Viewport() Address = 0x3157346 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FD3D9DynamicRHI::CreateViewport() Address = 0x31574b8 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
RHICreateViewport() Address = 0x13e744d (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FViewport::UpdateViewportRHI() Address = 0x1b2582b (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FWindowsViewport::UpdateRenderDevice() Address = 0x31a0bfe (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FWindowsViewport::Resize() Address = 0x31a37b6 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FWindowsViewport::FWindowsViewport() Address = 0x31a53a3 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
UWindowsClient::CreateViewportFrame() Address = 0x31a6c1a (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
UGameEngine::Init() Address = 0x1c2b8a8 (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
FEngineLoop::Init() Address = 0x321e17e (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
GuardedMain() Address = 0x322476a (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
GuardedMainWrapper() Address = 0x322488a (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
WinMain() Address = 0x322497b (filename not found) [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
__tmainCRTStartup() 0x37681fa + 28 bytes [File=f:\dd\vctools\crt_bld\self_x86\crt\src\crtexe .c:547] [in C:\Games\Steam\steamapps\common\inmomentum\Binarie s\Win32\IMGame.exe]
Address = 0x67d66f6 (filename not found)
Address = 0x698021db (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x69824a2a (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x69824bcc (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x69824c01 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x69824c21 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x698fda9b (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x698ecf90 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x698ecda4 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x698ed199 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x698ed09a (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x6996af00 (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\clr. dll]
Address = 0x6bf655ab (filename not found) [in C:\Windows\Microsoft.NET\Framework\v4.0.30319\msco reei.dll]
Address = 0x6c357f16 (filename not found) [in C:\Windows\SYSTEM32\MSCOREE.DLL]
Address = 0x6c354de3 (filename not found) [in C:\Windows\SYSTEM32\MSCOREE.DLL]
Address = 0x77839d72 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]
Address = 0x77839d45 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]
Address = 0x77839d45 (filename not found) [in C:\Windows\SysWOW64\ntdll.dll]
Manualy installed C++ and Framework + DirectX ... i don't have antivirus or stuff like that.

PC: AMD Phenom X4 955BE, 4GB RAM, ati x1600pro 512MB, WIN7 64bit

Last edited by Easy__: 12-09-2011 at 05:48 AM.
Easy__ is offline  
Reply With Quote
Old 12-08-2011, 07:10 PM   #2
lordofterror
 
Join Date: Jul 2010
Reputation: 69
Posts: 1,198
Quote:
Originally Posted by Easy__ View Post
Hi, tried launch game and this happend:



Manualy installed C++ and Framework + DirectX ... i don't have antivirus or stuff like that.

PC: AMD Phenom X4 955BE, 4GB RAM, ati x1600pro 512MB
i exactly get the same problem ati x1400 card and core 2 duo processor , 2gb ram windows 7
lordofterror is offline   Reply With Quote
Old 12-09-2011, 06:59 AM   #3
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
Any advice ? please... 10Euros for Error ? No thanks...
Easy__ is offline   Reply With Quote
Old 12-10-2011, 03:14 AM   #4
TheDesiderium
 
TheDesiderium's Avatar
 
Digital Arrow
Join Date: Oct 2011
Reputation: 28
Posts: 52
Please submit this issue to our support team here

http://support.digital-arrow.com/

and we'll get back to you asap.
TheDesiderium is offline   Reply With Quote
Old 12-10-2011, 03:16 AM   #5
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
Quote:
Originally Posted by TheDesiderium View Post
Please submit this issue to our support team here

http://support.digital-arrow.com/

and we'll get back to you asap.
Done, thanks.
Easy__ is offline   Reply With Quote
Old 12-12-2011, 04:48 AM   #6
lordofterror
 
Join Date: Jul 2010
Reputation: 69
Posts: 1,198
Quote:
Originally Posted by Easy__ View Post
Done, thanks.
any progress ?
lordofterror is offline   Reply With Quote
Old 12-13-2011, 01:37 PM   #7
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
Nothing new...
Easy__ is offline   Reply With Quote
Old 12-13-2011, 06:14 PM   #8
lordofterror
 
Join Date: Jul 2010
Reputation: 69
Posts: 1,198
Quote:
Originally Posted by Easy__ View Post
Nothing new...
guess we cant do anything
lordofterror is offline   Reply With Quote
Old 12-14-2011, 12:32 AM   #9
TheDesiderium
 
TheDesiderium's Avatar
 
Digital Arrow
Join Date: Oct 2011
Reputation: 28
Posts: 52
We are working on it guys. Sorry for the inconvenience.
TheDesiderium is offline   Reply With Quote
Old 12-23-2011, 11:25 AM   #10
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
New update today ? Steam download some files for inMomentum... but i still have this problem
Easy__ is offline   Reply With Quote
Old 12-23-2011, 02:25 PM   #11
WindPower
 
 
 
Join Date: May 2010
Reputation: 372
Posts: 189
Today, I got on startup:


Code:
Rendering thread exception:

Fatal error!



FD3D9DynamicRHI::CreateTexture2D() Address = 0x2576c99  (filename not found) [in c:\steam\steamapps\common\inmomentum\Binaries\Win32\IMGame.exe]

RHICreateTexture2D() Address = 0x806b27   (filename not found) [in c:\steam\steamapps\common\inmomentum\Binaries\Win32\IMGame.exe]

FTexture2DResource::UpdateMipCount() Address = 0xe45f26   (filename not found) [in c:\steam\steamapps\common\inmomentum\Binaries\Win32\IMGame.exe]

TSet<TMapBase<UTexture2D const *,FTextureArrayDataEntry,0,FDefaultSetAllocator>::FPair,TMapBase<UTexture2D const *,FTextureArrayDataEntry,0,FDefaultSetAllocator>::KeyFuncs,FDefaultSetAllocator>::TKeyIterator::RemoveCurrent() Address = 0xe46808   (filename not found) [in c:\steam\steamapps\common\inmomentum\Binaries\Win32\IMGame.exe]

RenderingThreadMain() Address = 0xda4aff   (filename not found) [in c:\steam\steamapps\common\inmomentum\Binaries\Win32\IMGame.exe]
WindPower is offline   Reply With Quote
Old 12-28-2011, 12:37 AM   #12
TheDesiderium
 
TheDesiderium's Avatar
 
Digital Arrow
Join Date: Oct 2011
Reputation: 28
Posts: 52
There was a new update. Please try re-installing inMomentum.

It seems that for some, in order for the update to actually properly go through, the game needs to be reinstalled. Let me know if the problem is still there after a reinstall attempt.
TheDesiderium is offline   Reply With Quote
Old 12-28-2011, 04:01 AM   #13
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
Still have a problem

http://img820.imageshack.us/img820/8412/asdf3.jpg
Easy__ is offline   Reply With Quote
Old 12-28-2011, 10:05 AM   #14
Easy__
 
Join Date: Aug 2010
Reputation: 0
Posts: 36
SOLVED !


Open BaseEngine.ini in inmomentum/engine/config

search

Code:
[Engine.ISVHacks]
bInitializeShadersOnDemand=False
DisableATITextureFilterOptimizationChecks=True
UseMinimalNVIDIADriverShaderOptimization=True
PumpWindowMessagesWhenRenderThreadStalled=False


set the "bInitializeShadersOnDemand" to "True":



[SystemSettings]
...
Distortion=True
FilteredDistortion=True
...

changed "Distorsion" to "False":


And it WORKS !
Easy__ is offline   Reply With Quote
Old 12-29-2011, 08:34 AM   #15
Vanquich
 
Join Date: Dec 2011
Reputation: 0
Posts: 4
Quote:
Originally Posted by Easy__ View Post
SOLVED !


Open BaseEngine.ini in inmomentum/engine/config

search

Code:
[Engine.ISVHacks]
bInitializeShadersOnDemand=False
DisableATITextureFilterOptimizationChecks=True
UseMinimalNVIDIADriverShaderOptimization=True
PumpWindowMessagesWhenRenderThreadStalled=False


set the "bInitializeShadersOnDemand" to "True":



[SystemSettings]
...
Distortion=True
FilteredDistortion=True
...

changed "Distorsion" to "False":


And it WORKS !
Confirmed! Thank you for sharing!
Vanquich is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > inMomentum


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.