Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Polynomial, The

Reply
 
Thread Tools Display Modes
Old 11-28-2010, 01:09 AM   #1
Dmytry
 
Dmytry's Avatar
 
The Polynomial Team
Join Date: Oct 2010
Reputation: 1162
Posts: 635
Exclamation How to use any music file format,any external player, radio, vinyl, even your throat

To use in-game music player with any format, install the codecs. More information.

To use external music player:

PC:
http://www.giantbomb.com/the-polynom...ame/35-460643/
Quote:
1. Follow the instructions here http://www.sevenforums.com/tutorials...ng-enable.html to make a recording device which hears whatever audio is playing on your PC
2. Open whatever music player you use and start playing the music
3. Open the game go to the menu where you would usually import files, there is an option to pick a sound source click this and pick the device you made in step 1
Mac:
http://forums.steampowered.com/forum....php?t=1611784
Quote:
Thanks! It worked!
For clarification for anyone else who is trying to do this, this is how I did it -
Install soundflower, then choose "Built-in Output" (2ch) in the soundflower menu at the top of the screen. Then in system preferences set both your input and output to soundflower (2ch).
Needless to say, by the way of microphone/line in it also supports oldschool radio, vinyl, tube amplifiers, synthesizers, live performances, and really really oldschool way of just singing the song yourself.

ahh, and also. If you are using this to play the demo with own music without having to convert to OGG, please consider buying full game instead, I did not want to lock microphone input out of the demo, but if you are just using the demo with those instructions and you would of gotten full, and there's enough of people who have same reasoning - I will *have* to remove mic input from the demo, no real choice, don't want a demo with low conversion rate.

Last edited by Dmytry: 01-14-2011 at 06:58 AM.
Dmytry is offline  
Reply With Quote
Old 12-03-2010, 03:03 PM   #2
TSED
 
Guest
Posts: n/a
The 'step 1' for PCs doesn't work for me, most likely because of my sound card. That is, there is no "sound" option in my control panel, but instead a "sounds and audio devices," which does not have the necessary option. There IS a 'HD Realtek Output' option in the sound source, but it doesn't do anything. Any other ideas?
  Reply With Quote
Old 12-04-2010, 11:11 AM   #3
kotekzot
 
 
 
Join Date: Dec 2008
Reputation: 46
Posts: 574
Quote:
Originally Posted by TSED View Post
The 'step 1' for PCs doesn't work for me, most likely because of my sound card. That is, there is no "sound" option in my control panel, but instead a "sounds and audio devices," which does not have the necessary option. There IS a 'HD Realtek Output' option in the sound source, but it doesn't do anything. Any other ideas?
you need to find the right drivers for your device. if it's integrated you should check your motherboard's manufacturer website for drivers. i had the same problem because there weren't any windows 7 drivers for my motherboard, but vista drivers are working quite well.
kotekzot is offline   Reply With Quote
Old 12-11-2010, 11:34 PM   #4
Darrosquall
 
Join Date: Dec 2008
Reputation: 7
Posts: 165
is it possible to have a native .flac support?
Darrosquall is offline   Reply With Quote
Old 12-23-2010, 11:10 PM   #5
Snowknight26
 
 
 
Join Date: Jan 2003
Reputation: 15
Posts: 2,075
Quote:
Originally Posted by Darrosquall View Post
is it possible to have a native .flac support?
That'd be a really great selling point. Instead of having to use this roundabout method of playing FLAC tracks, native support would be very much appreciated.

I was a bit disappointed I only found out that FLAC is unsupported after I bought it, but nevertheless, can't complain about there actually being a workaround.

Last edited by Snowknight26: 12-23-2010 at 11:18 PM.
Snowknight26 is offline   Reply With Quote
Old 08-30-2011, 07:24 PM   #6
ManiacDC
 
Guest
Posts: n/a
Playing 32 bit wavpack (maybe other wavpack files, but I don't have any with a lower bit value) via the wavpack splitter/decoder crashes The Polynomial. FLAC plays fine via madFLAC.
  Reply With Quote
Old 08-31-2011, 12:32 AM   #7
Dmytry
 
Dmytry's Avatar
 
The Polynomial Team
Join Date: Oct 2010
Reputation: 1162
Posts: 635
Quote:
Originally Posted by ManiacDC View Post
Playing 32 bit wavpack (maybe other wavpack files, but I don't have any with a lower bit value) via the wavpack splitter/decoder crashes The Polynomial. FLAC plays fine via madFLAC.
Hmm maybe the codec is not very good, try other wavpack codec?

__________________
The Polynomial: Product page | Troubleshooting | Most recent update | Current Poll
Dmytry is offline   Reply With Quote
Old 08-31-2011, 06:32 PM   #8
ManiacDC
 
Guest
Posts: n/a
Quote:
Originally Posted by Dmytry View Post
Hmm maybe the codec is not very good, try other wavpack codec?
Hmm, the only ones I know of are CoreWavPack and its derivatives. All cause the crash. I did some more testing and found the following:

16 bit WavPack = No Crash
24 bit WavPack = Crash
32 bit WavPack = Crash

16 bit Wav = No Crash
24 bit Wav = No Crash
32 bit Wav = Crash

So it seems 32 bit music files could be a partial cause of the crashes?
  Reply With Quote
Old 09-01-2011, 09:31 AM   #9
Dmytry
 
Dmytry's Avatar
 
The Polynomial Team
Join Date: Oct 2010
Reputation: 1162
Posts: 635
Quote:
Originally Posted by ManiacDC View Post
Hmm, the only ones I know of are CoreWavPack and its derivatives. All cause the crash. I did some more testing and found the following:

16 bit WavPack = No Crash
24 bit WavPack = Crash
32 bit WavPack = Crash

16 bit Wav = No Crash
24 bit Wav = No Crash
32 bit Wav = Crash

So it seems 32 bit music files could be a partial cause of the crashes?
Hmm, maybe. Upload the log.txt somewhere please, I'll see if it's anything that I can fix.
Regarding 24 and 32-bit fidelity by the way, majority of audio cards don't really have this, only claim this.

__________________
The Polynomial: Product page | Troubleshooting | Most recent update | Current Poll
Dmytry is offline   Reply With Quote
Old 09-03-2011, 01:49 PM   #10
Dmytry
 
Dmytry's Avatar
 
The Polynomial Team
Join Date: Oct 2010
Reputation: 1162
Posts: 635
Quote:
Originally Posted by ManiacDC View Post
Hmm, the only ones I know of are CoreWavPack and its derivatives. All cause the crash. I did some more testing and found the following:

So it seems 32 bit music files could be a partial cause of the crashes?
I just tested this - indeed, corewavpack crashes, but ffdshow works fine.

Install ffdshow, then via start menu run "Audio decoder configuration" and enable support for wavpack. I recommend using ffdshow, it is the most well behaved in my experience.

__________________
The Polynomial: Product page | Troubleshooting | Most recent update | Current Poll
Dmytry is offline   Reply With Quote
Old 09-05-2011, 06:18 PM   #11
ManiacDC
 
Guest
Posts: n/a
Quote:
Originally Posted by Dmytry View Post
I just tested this - indeed, corewavpack crashes, but ffdshow works fine.

Install ffdshow, then via start menu run "Audio decoder configuration" and enable support for wavpack. I recommend using ffdshow, it is the most well behaved in my experience.
I have 32 bit downmixed to 24 bit in Windows, but 24 bit pcm pipes directly to my receiver via HDMI which handles the 24 bit audio.

Sorry, I was away for the weekend and was unable to test further.

I tried FFDshow (didn't realize it could decode wavpack) and verified that ffdshow was being used as the decoder (checked graphedit, and I could see the icon in the taskbar), but I was still crashing on 24 and 32 bit .wv files. Graphedit shows that I'm still using the CoreWavPack splitter, but when I unregister it then I'm unable to play .wv files as ffdshow is only a decoder - not a splitter. What are you using for a splitter (if you are unsure, you can check in graphedit, just open the wv in it)?
  Reply With Quote
Old 01-01-2012, 12:16 AM   #12
Monukai
 
 
 
Join Date: Dec 2011
Reputation: 3
Posts: 87
Some additional steps you may need to take if you are using a logitech gaming keyboard (and use the audio jack)

After you completed the above you will want to:

1. In the Playback tab (Start/Control Panel/Sound) set your default device to your audio cards audio (should be 'Speakers' - you *don't* want the logitech 'Speakers')

2. Go to the recording tab, and right click on stereo mix and hit properties.

3. In properties go to the 'Listen' tab and checkmark the 'Listen to this device' option, and select Speakers (G### Gaming Keyboard) in the drop down under Playback through this device:

4. (Additional) This probably won't happen to you, but for some reason the microphone I use for mumble/vent was open and streaming through my headset when I enabled this and disabling the mic in the Recording tab didn't stop it. I had to go to my audio cards audio manager (in my case Realtek) and go to the Microphone tab and mute the Playback Volume (never heard it when I was using the logitech audio jack as default).

Hope this helps!

P.S. This essentially enables last.fm/ scrobbling. Talk about killing two birds with one stone. Yay!

Last edited by Monukai: 01-01-2012 at 12:34 AM.
Monukai is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Polynomial, The


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:29 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.