Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V

Reply
 
Thread Tools Display Modes
Old 01-13-2012, 09:40 PM   #1
{RR}Kumquat.
 
Join Date: Oct 2008
Reputation: 34
Posts: 89
Yeah...don't turn off VSync

I have a decent PC and am very used to 100-120fps (with my 120Hz) monitor. So of course I disabled Vsync.

Yeah...that was bad. The physics went wild. Everytime you opened a door half the small object in the room flew around. Additionally, in some "cave" areas where there was water, the player movement was glitchy.

Regredfully, I had to turn it back on. Just FYI.
{RR}Kumquat. is offline  
Reply With Quote
Old 01-13-2012, 09:42 PM   #2
Animositisomina
 
 
 
Join Date: Mar 2009
Reputation: 631
Posts: 3,801
Yeah, you're not supposed to just turn it off. There are two steps needed: 1 - Disable vsync through the in-game options (see Edit below). 2 - Force vsync on in your GPU's control panel. You will get much smoother, more consistent results this way, and the added benefit of the physics not going crazy.

EDIT: Since this post is a little misleading and people are still asking, let me correct myself here: There is no in-game option to disable vsync. What I actually meant was editing the SkyrimPrefs.ini to change iPresentInterval from 1 to 0. This file is located in C:\Users\(your name)\My Documents\My Games\Skyrim\.

Last edited by Animositisomina: 01-22-2012 at 09:54 AM. Reason: Corrected information.
Animositisomina is offline   Reply With Quote
Old 01-13-2012, 09:46 PM   #3
Noizic
 
Join Date: Jan 2011
Reputation: 0
Posts: 182
What's the difference between letting the game have it on and than forcing it through D3DOverrider/Nvidia CP/ATI CCC? Is there any reduced mouse lag or? =)

I recently disabled it because I wanted to see if I could reduce the mouse lag. It worked. To avoid physics going haywire I use FPS limiter to 60FPS and while it won't probably as good as with VSync on it's better than perfect physics and a lot of mouse lag.
Noizic is offline   Reply With Quote
Old 01-13-2012, 09:48 PM   #4
Animositisomina
 
 
 
Join Date: Mar 2009
Reputation: 631
Posts: 3,801
D3DOverrider is also a good option. I haven't used it with Skyrim yet, but it works beautifully with Just Cause 2. Keeps things nice and smooth.
Animositisomina is offline   Reply With Quote
Old 01-13-2012, 10:08 PM   #5
BC2 Cypher
 
 
 
Join Date: Mar 2010
Reputation: 478
Posts: 3,742
If you need Vsync just use D3DOverrider.

You shouldn't need vsync with an 120Hz monitor though, screen tearing should be almost non existent.

I have a 120Hz monitor too.

I don't know if you have an Nvidia card but if you do then do what I did below.

What I did was disable vsync in the game and use NvidiaInspector to limit the fps. As long as the fps is at 60 or lower with vsync off you shouldn't get crazy physics.

Locking the fps with Nvidia Inspector is very important though don't use any other program cause if you do you will get mad delays on things in the game like shooting arrows while indoors and other annoying things (the delays are mostly indoors).

You need driver 290.53 to use Nvidia Inspector with the fps limiter.

I uploaded the latest Nnvidia Inspector with the fps limiter enabled for you.

Get it here: http://www.mediafire.com/?ifpgowf3cduur7d

Last edited by BC2 Cypher: 01-13-2012 at 11:30 PM.
BC2 Cypher is offline   Reply With Quote
Old 01-13-2012, 10:42 PM   #6
chronicpirate
 
Join Date: Oct 2010
Reputation: 38
Posts: 250
Quote:
Originally Posted by Animositisomina View Post
Yeah, you're not supposed to just turn it off. There are two steps needed: 1 - Disable vsync through the in-game options. 2 - Force vsync on in your GPU's control panel. You will get much smoother, more consistent results this way, and the added benefit of the physics not going crazy.
That's strange seeing as last time I checked there was no option to disable v-sync in game.. perhaps you meant through the .ini file?
chronicpirate is offline   Reply With Quote
Old 01-14-2012, 12:51 AM   #7
Animositisomina
 
 
 
Join Date: Mar 2009
Reputation: 631
Posts: 3,801
Quote:
Originally Posted by chronicpirate View Post
That's strange seeing as last time I checked there was no option to disable v-sync in game.. perhaps you meant through the .ini file?
Right, my mistake on that one. You just need to change iPresentInterval to 0 in SkyrimPrefs.ini.
Animositisomina is offline   Reply With Quote
Old 01-14-2012, 03:46 AM   #8
Noizic
 
Join Date: Jan 2011
Reputation: 0
Posts: 182
Quote:
Originally Posted by BC2 Cypher View Post
If you need Vsync just use D3DOverrider.

You shouldn't need vsync with an 120Hz monitor though, screen tearing should be almost non existent.

I have a 120Hz monitor too.

I don't know if you have an Nvidia card but if you do then do what I did below.

What I did was disable vsync in the game and use NvidiaInspector to limit the fps. As long as the fps is at 60 or lower with vsync off you shouldn't get crazy physics.

Locking the fps with Nvidia Inspector is very important though don't use any other program cause if you do you will get mad delays on things in the game like shooting arrows while indoors and other annoying things (the delays are mostly indoors).

You need driver 290.53 to use Nvidia Inspector with the fps limiter.

I uploaded the latest Nnvidia Inspector with the fps limiter enabled for you.

Get it here: http://www.mediafire.com/?ifpgowf3cduur7d
I use the FPS limiter in Enhanced Shaders mod. What's the difference? I've those specific drivers and latest Nvidia Inspector but where's FPS limiter?

EDIT: I found it but still, how is it different compared to that mod I'm using and I think I read somewhere you can add some lines to ini files as well.
Noizic is offline   Reply With Quote
Old 01-14-2012, 04:22 PM   #9
{RR}Kumquat.
 
Join Date: Oct 2008
Reputation: 34
Posts: 89
Thanks for the advice. I am actually running a crossfire AMD6950 setup. I may try the VSync in the graphics options versus the game. I can't remember whether AMD's Catalyst will allow a "smart" VSync like Rage (i.e. 60fps max when it can, but if not it won't drop it to 30fps.)
{RR}Kumquat. is offline   Reply With Quote
Old 01-14-2012, 04:26 PM   #10
BC2 Cypher
 
 
 
Join Date: Mar 2010
Reputation: 478
Posts: 3,742
Quote:
Originally Posted by Noizic View Post
I use the FPS limiter in Enhanced Shaders mod. What's the difference? I've those specific drivers and latest Nvidia Inspector but where's FPS limiter?

EDIT: I found it but still, how is it different compared to that mod I'm using and I think I read somewhere you can add some lines to ini files as well.
As I said, using another program to limit the fps can cause delays when indoors like shooting arrows (after shooting an arrow there will be a delay before the arrow actually leaves the bow) or sometimes it takes a while to get to the level up screen etc.

Using Nvidia Inspector to limit the fps doesn't cause any delays to happen.
BC2 Cypher is offline   Reply With Quote
Old 01-14-2012, 05:17 PM   #11
MellonCollie
 
 
 
Join Date: May 2009
Reputation: 350
Posts: 2,384
Turning off v-sync messes up the ingame clock too. It affects events and quests to a degree.
MellonCollie is offline   Reply With Quote
Old 01-14-2012, 05:41 PM   #12
Vaalyne
 
Join Date: Jun 2010
Reputation: 12
Posts: 113
Yeah, disabling Vsync has caused several issues to arise for my character. One of the most blatant issues I noticed was my inability to shout after loading a save. It will be highlighted in the menu but won't work. If I try switching to Beast Form (as in, select the ability), then back to a shout, it won't even select the shout anymore.

I think it may be best to simply leave it. Not to mention, as MellonCollie said, disabling Vsync will cause NPC timers to be off, and therefore cause quest issues.

Haven't tried forcing Vsync through the CCC yet, though. That may or may not help. At this point I've just accepted the input lag and such; the game is plenty fun for me regardless.
Vaalyne is offline   Reply With Quote
Old 01-14-2012, 06:11 PM   #13
BC2 Cypher
 
 
 
Join Date: Mar 2010
Reputation: 478
Posts: 3,742
Quote:
Originally Posted by MellonCollie View Post
Turning off v-sync messes up the ingame clock too. It affects events and quests to a degree.
Never has for me.

70+ hours played.
BC2 Cypher is offline   Reply With Quote
Old 01-14-2012, 06:47 PM   #14
DarkJeff
 
Join Date: Mar 2009
Reputation: 186
Posts: 2,174
V-Sync has been reported to mess up in-game timings, like the day/night cycle won't match the in-game time, and the NPC schedules will desync as well.

Everything I've ever read for any game tends to have disabling v-sync be a trouble-shooting tweak, with it recommended on. I don't know why people keep turning it off...
DarkJeff is offline   Reply With Quote
Old 01-14-2012, 06:52 PM   #15
{RR}Kumquat.
 
Join Date: Oct 2008
Reputation: 34
Posts: 89
Quote:
Originally Posted by DarkJeff View Post
Everything I've ever read for any game tends to have disabling v-sync be a trouble-shooting tweak, with it recommended on. I don't know why people keep turning it off...

I was enjoying my much smoother 80fps in dungeons.

Additionally with Vsync on, when the max fps drops below 60fps, Vsync will drop everything down to 30fps, which is just horribly choppy.

Basically, Vsync is a way to get a free 20fps boost and significantly smoother gameplay. But, in Skyrim's case, it comes as a very steep cost.
{RR}Kumquat. is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Skyrim, The Elder Scrolls V


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.