Go Back   Steam Users' Forums > Steam Discussions > Steam Mobile

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 01-26-2012, 03:36 PM   #1
Eirreann
 
Join Date: Jun 2011
Reputation: 0
Posts: 18
Needs compatibility for older devices! (3G, 3GS, and 2nd Gen iPod Touch)

I've been looking forward to this app for quite literally years, but when I tried to get it I am told that my iPod Touch 2nd Generation is too old! Well sooooorrry that I can't afford anything better!
Seriously, though, what about this app is incompatible with the older iDevices? As far as I could tell it pretty much just incorporated the Community and Store features.
Sorry, Valve, I'm just a little disappointed, that's all.

_______________
VALVE DEVELOPER RESPONSES:
Quote:
Originally Posted by JasonM View Post
This appears to have been an oversight on our part. The next release should be flagged to be compatible with the 3G, 3GS and 2nd Gen iPod Touch.
Quote:
Originally Posted by JasonM View Post
The next release of the app (ideally next week) should be flagged to be compatible with the 3G, 3GS and 2nd Gen iPod Touch.

Last edited by smash: 01-27-2012 at 05:32 PM. Reason: added dev responses
Eirreann is offline  
Reply With Quote
Old 01-26-2012, 03:39 PM   #2
vansoffboard
 
 
 
Join Date: Sep 2011
Reputation: 0
Posts: 1
I would also love to see this, as my iTouch 3rd gen cant use it
Please do an update to make it compatible with other versions.
vansoffboard is offline   Reply With Quote
Old 01-26-2012, 04:26 PM   #3
Mangr0v3
 
 
 
Join Date: Sep 2008
Reputation: 4313
Posts: 13,608
The MinimumOSVersion in Info.Plist is set to 4.0, so you should be able to run it if you're running iOS 4.0 or above.

The 2nd- and 3rd-generation iPod Touches can both run iOS 4.0.

What exact error are you getting?
Mangr0v3 is offline   Reply With Quote
Old 01-26-2012, 04:42 PM   #4
Engerz
 
 
 
Join Date: Nov 2009
Reputation: 12
Posts: 126
If you're getting these as I posted here:

http://forums.steampowered.com/forum...5&postcount=12

Then for now there isn't anything we can do. A Valve employee sent me a PM and I replied with the error. So here's hoping for us.
Engerz is offline   Reply With Quote
Old 01-26-2012, 04:57 PM   #5
Mangr0v3
 
 
 
Join Date: Sep 2008
Reputation: 4313
Posts: 13,608
Hmm, it's marked as compatible with armv6 and armv7. I wonder what they set that screwed it up.

Edit: I have a feeling that adding armv7 to UIRequiredDeviceCapabilities is what caused this.

Last edited by Mangr0v3: 01-26-2012 at 07:32 PM.
Mangr0v3 is offline   Reply With Quote
Old 01-26-2012, 07:27 PM   #6
Orihuela
 
Join Date: Nov 2006
Reputation: 0
Posts: 103
I have the same problem with my iPhone 3G, I can't install the app.

iOS Ver: 4.2.1
Model: MB496LE
Orihuela is offline   Reply With Quote
Old 01-27-2012, 09:41 AM   #7
Mu6o
 
Join Date: May 2009
Reputation: 33
Posts: 270
Can someone suggest what should I do with my iPhone 3G

I mean with what to flash it just to run the app?
Mu6o is offline   Reply With Quote
Old 01-27-2012, 09:58 AM   #8
cylon
 
 
 
Join Date: Nov 2009
Reputation: 780
Posts: 3,422
Update the firmware to 4.0+
cylon is offline   Reply With Quote
Old 01-27-2012, 10:07 AM   #9
Mu6o
 
Join Date: May 2009
Reputation: 33
Posts: 270
Well basically I don't use the iPhone too much... so can you explain how or an article would help, thanks.
Mu6o is offline   Reply With Quote
Old 01-27-2012, 10:15 AM   #10
Thebigone
 
 
 
Join Date: May 2010
Reputation: 656
Posts: 521
You must spoof the SystemVersion.plist file to bypass the firmware / hardware requirement. (Jailbreak / SSH / full filesystem access required).
I do not recommend doing this if you don't know what you're doing.

First, connect to the computer using USB and ensure the device is charging. Complete a full sync & backup with iTunes.

The file you need to modify is located at ./System/Library/CoreServices/SystemVersion.plist
Change ProductBuildVersion and ProductVersion to 8J2 and 4.3.3 respectively.
Reboot your device.
It will show the firmware upgrade progress bar briefly and proceed to reboot itself once more. After about 2 minutes, it'll return to SpringBoard and ask for the PIN code like normal.

The installation should now complete successfully.

Last edited by Thebigone: 01-27-2012 at 10:20 AM.
Thebigone is offline   Reply With Quote
Old 01-27-2012, 10:44 AM   #11
Mu6o
 
Join Date: May 2009
Reputation: 33
Posts: 270
I'm a pro n00b this should be okay.

PS: This is legally to do, right?

Last edited by Mu6o: 01-27-2012 at 10:47 AM.
Mu6o is offline   Reply With Quote
Old 01-27-2012, 10:50 AM   Click here to go to the next staff post in this thread.   #12
JasonM
 
JasonM's Avatar
 
Valve
Join Date: Nov 2008
Reputation: 106
Posts: 78
This appears to have been an oversight on our part. The next release should be flagged to be compatible with the 3G, 3GS and 2nd Gen iPod Touch.
JasonM is offline   Reply With Quote
Old 01-27-2012, 10:51 AM   Click here to go to the next staff post in this thread.   #13
JasonM
 
JasonM's Avatar
 
Valve
Join Date: Nov 2008
Reputation: 106
Posts: 78
The next release of the app (ideally next week) should be flagged to be compatible with the 3G, 3GS and 2nd Gen iPod Touch.
JasonM is offline   Reply With Quote
Old 01-27-2012, 10:56 AM   #14
Mu6o
 
Join Date: May 2009
Reputation: 33
Posts: 270
Oh god, thank. I didn't wanted to jailbrake it, neither to buy a new one, even the HTC Sensation XE was a good choice just because of this app.
You should make a Steam Phone just for games and this app :P
Mu6o is offline   Reply With Quote
Old 01-27-2012, 01:45 PM   #15
AlabasterSlim
 
 
 
Join Date: May 2007
Reputation: 2
Posts: 159
3GS is currently already compatible.
AlabasterSlim is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Steam Mobile


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.