Go Back   Steam Users' Forums > Steam Game Discussions > # - C > BRINK

Reply
 
Thread Tools Display Modes
Old 02-04-2012, 07:44 AM   #1
badsanta98
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 19
Red face BRINK Crashes on mission start up.

Help please !
I just got brink today I really want to play it, but it crashes as soon as I start a mission, now I feel really ripped off, I've de-fraged, Updated graphics drivers and verified integrity of game cache and I'm still getting this problem !

My specs are

Windows 7 PRO 64bit
AMD Radeon HD 6770 1GB DDR5.
AMD Athlon II X4 640 3.00GHZ (Quad core).
8GB of Corsair DDR3 ram.

As you can see my PC specs are more than enough to run the game the game, I've spent hours looking on forums and still no luck. So please, If you have a solution let me know
Thanks

OK Guys ! FIXED IT Download Catalyst 12.2 preview drivers here
http://support.amd.com/us/kbarticles...iewdriver.aspx

Have Fun, and enjoy BRINK !

Last edited by badsanta98: 02-05-2012 at 04:04 AM.
badsanta98 is offline  
Reply With Quote
Old 02-04-2012, 12:54 PM   #2
HomerPepsi
 
Join Date: Oct 2008
Reputation: 454
Posts: 740
Me too

2x 6950 cfx
win 7 64bit
Phenom II x4 965 BE (3.6ghz)
8 gb ddr3 ram
HomerPepsi is offline   Reply With Quote
Old 02-04-2012, 12:57 PM   #3
badsanta98
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 19
Quote:
Originally Posted by HomerPepsi View Post
Me too

2x 6950 cfx
win 7 64bit
Phenom II x4 965 BE (3.6ghz)
8 gb ddr3 ram
At least I know I'm not the only one hope you get it sorted out, I still haven't got mine working, It's really frustrating me ! I wanna play so bad.
badsanta98 is offline   Reply With Quote
Old 02-04-2012, 09:17 PM   #4
varrathw
 
Join Date: Nov 2011
Reputation: 0
Posts: 2
Me also

It keeps crashing as soon as I do the 'press any key' action - is that's what's happening to you? And, yes, very frustrating.
It's been about a year since the game was released and I'm beginning to suspect it may be that the servers are no longer interested in running it on them. So, internal game drivers are setting up the mission but as soon as it has to interact with a gamer server it crashes because they're no longer supporting it? Just a thought...

Last edited by varrathw: 02-04-2012 at 09:20 PM.
varrathw is offline   Reply With Quote
Old 02-04-2012, 11:49 PM   #5
theNiZer
 
Join Date: Oct 2011
Reputation: 6
Posts: 37
come on, look in the forum there are loads of threads and answers, eg this:
http://forums.steampowered.com/forum....php?t=2510223
theNiZer is offline   Reply With Quote
Old 02-05-2012, 03:41 AM   #6
sackhai
 
Join Date: Jan 2011
Reputation: 4
Posts: 60
omg do you guys know the search funktion!? there are a few threads where the problem is fixed. dam use search finktion and update the ATI driver to 12.2 beta.

who ever can read is in advantage.
sackhai is offline   Reply With Quote
Old 02-05-2012, 03:43 AM   #7
badsanta98
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 19
Quote:
Originally Posted by varrathw View Post
It keeps crashing as soon as I do the 'press any key' action - is that's what's happening to you? And, yes, very frustrating.
It's been about a year since the game was released and I'm beginning to suspect it may be that the servers are no longer interested in running it on them. So, internal game drivers are setting up the mission but as soon as it has to interact with a gamer server it crashes because they're no longer supporting it? Just a thought...
Yep, Crashes right after press any key.

Last edited by badsanta98: 02-05-2012 at 03:48 AM.
badsanta98 is offline   Reply With Quote
Old 02-05-2012, 03:44 AM   #8
sackhai
 
Join Date: Jan 2011
Reputation: 4
Posts: 60
dude search funktion is difficult to use, we solved the problem.
sackhai is offline   Reply With Quote
Old 02-05-2012, 03:51 AM   #9
badsanta98
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 19
OK, I'm seeing a lot of people who say it is fixed by Disabling Catalyst AI or by installing the 12.2 preview drivers for ATi cards, So I'm going to try both, then I'll tell you guys if they worked.

I'm starting to think this may just be a problem with AMD/ATi graphics cards and not so much with Nvidia.

Last edited by badsanta98: 02-05-2012 at 03:57 AM.
badsanta98 is offline   Reply With Quote
Old 02-05-2012, 04:04 AM   #10
badsanta98
 
 
 
Join Date: Feb 2011
Reputation: 0
Posts: 19
OK Guys ! FIXED IT Download Catalyst 12.2 preview drivers here
http://support.amd.com/us/kbarticles...iewdriver.aspx

Have Fun, and enjoy BRINK !
badsanta98 is offline   Reply With Quote
Old 02-05-2012, 04:10 AM   #11
sackhai
 
Join Date: Jan 2011
Reputation: 4
Posts: 60
lol thats what i said to search the forum propper we have posted enogh links!



no problem with ATI just need to be updated and set propper. i only use ATI and AMD never ever problems.

only install the driver and dont need to tun anything off.

Last edited by sackhai: 02-05-2012 at 04:13 AM.
sackhai is offline   Reply With Quote
Old 02-05-2012, 06:34 PM   #12
beira.
 
Join Date: Nov 2011
Reputation: 0
Posts: 15
http://www.ati-forum.de/allgemein/do...-12-2-preview/

WORKED 4 ME

THX
beira. is offline   Reply With Quote
Old 02-05-2012, 06:42 PM   #13
HomerPepsi
 
Join Date: Oct 2008
Reputation: 454
Posts: 740
12.2 preview killed rage performance for me, so I use an expanded opengl dll in the brink directory and 12.1 drivers. Works fine.

That solution wasn't in search.
HomerPepsi is offline   Reply With Quote
Old 02-06-2012, 05:30 PM   #14
sackhai
 
Join Date: Jan 2011
Reputation: 4
Posts: 60
<---6870 never problems.
well porst solution them, so we don´t fu..in g have hundreds of threads of the same sh...it.

oh i forgott, BRINK IS SH..IT
sackhai is offline   Reply With Quote
Old 02-06-2012, 05:47 PM   #15
HomerPepsi
 
Join Date: Oct 2008
Reputation: 454
Posts: 740
Quote:
Originally Posted by sackhai View Post
<---6870 never problems.
well porst solution them, so we don´t fu..in g have hundreds of threads of the same sh...it.

oh i forgott, BRINK IS SH..IT
Contradicting yourself? You say use search and don't make new threads, then you say post a solution either in a new thread or in the existing one (which I did). So make up your mind and quit ing about people posting with their technical difficulties, if you haven't noticed, that's what the majority of the threads in SPUF's game forums are about.

Also, given BRINK's past of technical difficulties, I'd say its only fair to expect a large amount of threads in this forum regarding problems related to the game.

P.S. You say 'who ever can read is in advantage.' yet, by the way you post, it is clear you can not write nor understand grammar.

My point is sometimes it's not appropriate to say "USE THE SEARCH FUNCTION OMGR!!@!#!#!"
HomerPepsi is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > BRINK


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.