Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Anno series

Reply
 
Thread Tools Display Modes
Old 02-22-2012, 12:18 PM   #1
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
Unhappy ANNO 2070 is not working

Hello everyone i have a problem with my coppy of ANNO 2070.

this is basicly what is hapening:
i start ANNO from the steam client as usual,
than it takes about 27 seconds (ive checked with a stop watch, dont ask why) and than a white error screen pops up with this message:

Ubisoft Game Launcher Error
Ubisoft game launcher has not been found. Please reinstall ANNO 2070.

i have tried to reinstall ANNO 2070 3 times, the last time i removed everything relating to ANNO and Ubisoft on the computer befor installing it again.

i have also tried to install the game launcher manually but without results.

Last i whant to clarify that i do not whant the game on an official Ubisoft client, if i whanted that i would have gotten it on one.

Please help me becious i really whant to play this game, i love the ANNO series and this is really bugging me.

ps, i have tried to google it many times and searched the forum so dont send me a link to "just fing google it"
svetressito is offline  
Reply With Quote
Old 02-22-2012, 01:35 PM   #2
Tellarion
 
Join Date: Feb 2009
Reputation: 4
Posts: 66
As far as I know, you HAVE to use the ubisoft uplay launcher to correctly launch the game
Tellarion is offline   Reply With Quote
Old 02-26-2012, 11:53 AM   #3
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
But i've used steam to launch the game 6 times during a period of 2 weeks befor this problem appeared
svetressito is offline   Reply With Quote
Old 02-29-2012, 08:09 AM   #4
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
Could someone please help me?
I can still not Play my game
svetressito is offline   Reply With Quote
Old 02-29-2012, 09:13 AM   #5
Robotkio
 
 
 
Join Date: Aug 2010
Reputation: 174
Posts: 1,258
If you got to the "Steam/steamapps/common/anno 2070/" folder and start the "anno5.exe" file, does the game start?

Edit:

Also, does Steam give you the message or does some other program give you the message? If it's Steam: is Steam starting with administrative privileges? If it is, are you running an anti-virus program that may have updated or changed recently?

Last edited by Robotkio: 02-29-2012 at 09:16 AM.
Robotkio is offline   Reply With Quote
Old 03-01-2012, 12:27 PM   #6
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
Starting it via the anno folder did not work

steam is not giving me the message, it is a white windows 7 standard error message of sorts.
svetressito is offline   Reply With Quote
Old 03-01-2012, 09:02 PM   #7
zuffy
 
Join Date: Jul 2010
Reputation: 0
Posts: 2
Anno 2070 requires The ubisoft " u play" to log into the game. This is there so they can control DRM, and stop people pirating. So your out of luck if your trying to skip this part.

Some things you could try.
1/
Make sure the Ubisoft ports are open:
TCP: 80, 13000, 13005, 13200-13999

Also make sure Anno ports are also open:
TCP/UDP: 80, 3074

You can check your ports are open using this program:
Port Checker: http://portforward.com/help/portcheck.htm

2/
I realise this could be a push. Your other option is install in Administrator mode... Maybe something is being blocked on the install because you don't have rights???
zuffy is offline   Reply With Quote
Old 03-12-2012, 01:44 AM   #8
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
ive now checked those ports and they are all open,
also i do have full administrator rights on my computer,
the game is installed with full rights.

anyone else got an idea?
svetressito is offline   Reply With Quote
Old 03-12-2012, 04:37 PM   #9
superecnate
 
Join Date: Jan 2012
Reputation: 0
Posts: 4
I also have the same problem. And I do not have it on steam. I have it on the game stop app thing. I had played it fine for a couple of months before. I think that it is a glich with the latest patch. Maybe we can contact Ubisoft to get them to fix that?
superecnate is offline   Reply With Quote
Old 03-13-2012, 12:32 AM   #10
TomoSojiro
 
 
 
Join Date: Aug 2011
Reputation: 7
Posts: 201
Ubisoft Data centers will be undergoing maintenance, during which many of our Online Services will not be available.
The maintenance begins at 6.00 AM GMT+1 and should be finished at 2.00 PM GMT+1.
TomoSojiro is offline   Reply With Quote
Old 03-13-2012, 12:33 AM   #11
TomoSojiro
 
 
 
Join Date: Aug 2011
Reputation: 7
Posts: 201
today the 13th mind
TomoSojiro is offline   Reply With Quote
Old 03-15-2012, 02:26 PM   #12
Eqvaliser
 
Join Date: Aug 2009
Reputation: 3
Posts: 145
Same here, why the hell didnt steam include the damn ubisoft launcher in the download..

Eqvaliser is offline   Reply With Quote
Old 03-19-2012, 09:24 PM   #13
gokkan
 
Join Date: Jan 2012
Reputation: 0
Posts: 3
I found my problem was that I had previously installed the uplay launcher using a Ubisoft game that I did not get through Steam. Once I uninstalled it from the Control Panel, then re-installed using the installer in the Anno directory, it worked.

Haven't tried the other game though...
gokkan is offline   Reply With Quote
Old 03-25-2012, 07:23 AM   #14
svetressito
 
Join Date: Feb 2012
Reputation: 0
Posts: 6
Quote:
Originally Posted by gokkan View Post
I found my problem was that I had previously installed the uplay launcher using a Ubisoft game that I did not get through Steam. Once I uninstalled it from the Control Panel, then re-installed using the installer in the Anno directory, it worked.

Haven't tried the other game though...
YAAAAAYY!!!! that worked for me as well ^^,

thanx everyone for helping me with this problem!
svetressito is offline   Reply With Quote
Old 03-29-2012, 02:38 AM   #15
lordfeldur
 
Join Date: Mar 2012
Reputation: 0
Posts: 1
My Anno 2070 isn't starting as well, but i don't get a message at all. I click on play, for some seconds my computer is working but after 5 seconds or so it stops and steam says i'm not in a game anymore.

Funny thing is it worked the frist two days without problems and I haven't started any other ubi-soft game for weeks.

Re-installing the Ubisoft-Gamelauncher isn't working, Re-downloading the game isn't working. The only clue i have is when im verifying game-files, steam is downloading something after checking.

Of course my Win XP is up to date as well as Drivers.

Can someone help?
lordfeldur is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Anno series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:22 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.