Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Left 4 Dead 2

Reply
 
Thread Tools Display Modes
Old 02-24-2012, 08:16 PM   #1
JudgementBullet
 
Join Date: Feb 2010
Reputation: 156
Posts: 858
L4D2 crashes to desktop without errors at random times...

As per title. How can I fix this?I don't want to redownload l4d2 all over again because I have a very slow connection.


Stuffs I've tried:

Quote:
Crash Without Error.

Potential fix for crashes all together : Link
Thanks to : Bishop7

A lot of players are now getting a crash at random without an error message.

Possible fix : put -lv in your game runpath. Warning! This removes all the gore out of the game. Note, this does not solve the issue all together.
Possible fix 2 :
1. Close Steam if running
2. Go to your Steam\Steamapps folder
3. Delete left 4 dead 2 client.ncf
4. Delete client.dll from your steam\steamapps\common\left 4 dead 2\left4dead2\bin folder
5. Start Steam
6. Right click on L4D2 and validate the game
7. After validation is complete, right click on the game and choose Install
8. Let it redownload the file and install it properly
Credit goes out to : atrpunk08
Solved by valve : Unconfirmed.
Taken from: http://forums.steampowered.com/forum....php?t=1028991

Quote:
Left 4 Dead 2 Crashing To Desktop

One of the major reasons why the game crashes seems to be due to a system folder (CSC – Client Side Caching) not having necessary permissions and thus becomes inaccessible from within the game. This problem can be rectified by giving full access to the folder in question.

Browse to your Windows Directory. This is C:\Windows by default for Windows XP/Vista and 7.
Open CSC Directory.
Inside you will see another folder usually named after a version number (i.e. 2.0.6). Try to open this folder.
If you get the error message ‘You don’t currently have permission to access this folder’, Left 4 Dead 2 crash is probably caused by this. If you do not get any error at this point, the crash is not caused by CSC permissions issue.
If you do get an an error, you’ll need to give full access to the folder so that it may be access by L4D2.
Right click the folder and select properties. Open ‘Security’ tab. Press ‘Advanced’ button. Go to the ‘Owner’ tab and press edit. Set Administrator to be the owner of the object. Press ok to all windows and close. Now run the game.

Taken from: http://filenetworks.blogspot.com/200...sktop-ctd.html


Quote:
Random crashes may also be present when multithreading is active. This is fairly easy to fix.

Run the game. While in game open the console by pressing the ~ (tilde) key.
Type the following command and press enter mat_queue_mode 0
This will effectively disable multithreading in game. If the game was in fact using multi threading, you may observe a performance drop after you invoke this command. On the upside all bugs and crashes related to this function will be gone.

Taken from: http://filenetworks.blogspot.com/200...sktop-ctd.html

- Update my video drivers (CCC) to 12.1a
- Verify integrity of game cache

None of them worked at all!


Specs:
16 GB RAM
AMD 6970
Intel i7-2600
1 TB WD caviar black

Last edited by JudgementBullet: 02-24-2012 at 09:50 PM.
JudgementBullet is offline  
Reply With Quote
Old 02-24-2012, 09:19 PM   #2
Riker87
 
 
 
Join Date: Jun 2011
Reputation: 25
Posts: 88
I'm having the same issue. At first it was only doing it on L4D but it has started happening on CSS too.
Riker87 is offline   Reply With Quote
Old 02-24-2012, 09:50 PM   #3
JudgementBullet
 
Join Date: Feb 2010
Reputation: 156
Posts: 858
1st post updated. Still no luck in fixing the problem...
JudgementBullet is offline   Reply With Quote
Old 02-25-2012, 08:49 AM   #4
JudgementBullet
 
Join Date: Feb 2010
Reputation: 156
Posts: 858
Seems I'm the only one with this problem..
JudgementBullet is offline   Reply With Quote
Old 03-01-2012, 05:33 PM   #5
RdkL
 
Join Date: Mar 2009
Reputation: 0
Posts: 11
Same here, tried your list, nothing works.

I run on a Q9450, 4 go DDR3 and a 560 GTX Ti. Everything is up to date, most of my games works properly. Actually, I only have issues with Source powered games : L4D2 and TF2. I dont have enough time to push some tests with CSS or HL² unfortunatly.
RdkL is offline   Reply With Quote
Old 03-02-2012, 10:24 AM   #6
Threesixtyci
 
 
 
Join Date: Feb 2010
Reputation: 265
Posts: 2,885
You try disabling your virus scanner?
Threesixtyci is offline   Reply With Quote
Old 03-02-2012, 10:28 AM   #7
Masterblaster73
 
 
 
Join Date: Feb 2009
Reputation: 566
Posts: 3,133
You using Avast?
Masterblaster73 is offline   Reply With Quote
Old 03-05-2012, 04:09 PM   #8
RdkL
 
Join Date: Mar 2009
Reputation: 0
Posts: 11
No I did not try to disable my antivirus, and yes I use Avast. Why would it change something ?
RdkL is offline   Reply With Quote
Old 03-22-2012, 09:30 AM   #9
gaine
 
Join Date: Nov 2009
Reputation: 0
Posts: 37
i get the exact same problem here.

its like i typed in quit in console, L4D2 goes straight to desktop with no message whatsoever.

it happens randomly and only at the start of the level, whether survivor or infected
gaine is offline   Reply With Quote
Old 03-22-2012, 10:14 AM   #10
Masterblaster73
 
 
 
Join Date: Feb 2009
Reputation: 566
Posts: 3,133
Avast has known issues with L4D2.
Read here https://support.steampowered.com/kb_...9828-SFLZ-9289
Masterblaster73 is offline   Reply With Quote
Old 03-28-2012, 05:56 PM   #11
RdkL
 
Join Date: Mar 2009
Reputation: 0
Posts: 11
I may have fixed the problem so far, by disabling my onboard sound card (Realtek device) and using a PCI sound card instead. I found a lot of people aroud having sound loops and random crash issues due to some Realtek chips. It seems that it's cache memory related, getting saturated (I had some BSOD "memory dump") because of Realtek hardware. I first thought it was kind of stange, but easy to check out, so I made a first try by disabling the onboard card (named Azalia codec) into the bios. Everything worked out (played for 2 hours, crashes occurs after a maximum of 30/40 minutes of play), but of course I had no sound anymore. I removed any Realtek software from my OS, bought a Asus Xonar soundcard, and it did the trick for now. I did not have enough time to make big stress tests, but it works fine for the moment.

I saw a lot of people having this issue on Battlefield Bad Company 2 and Battlefield 3. This problem seems quite common, but not that much on Souce Games. I'll post again if something gets wrong.
RdkL is offline   Reply With Quote
Old 08-18-2012, 11:37 PM   #12
Your Mom
 
Join Date: Jun 2008
Reputation: 0
Posts: 42
Thumbs down

I'm getting the same bull crashes too. It used to happen at random, and so quickly as if I had hit the Windows key instead. Cleanest crash I've ever experienced, without errors.

In general L4D2 has been ing up on me the last 2 weeks or so, with random zombies having bright blue or green shirts, and these crashes. Now, as of today, I successfully crash between maps every time. My onboard ASRock sound is indeed Realtek though.

The strangest thing is that my buddy has been experiencing these same exact problems. We've been crashing at the same time, or just about, and have been experiencing the blue/green shirt issues (as well as scarecrow looking Louis & Francis models), as well as a small handful of other friends. We don't file share or anything to that matter either.

(edit: no Avast, just MS Security Essentials)
Your Mom is offline   Reply With Quote
Old 08-19-2012, 03:36 AM   #13
shadow722
 
Join Date: May 2011
Reputation: 4
Posts: 32
Have had an error message after installing again and it crashing without message to desktop between levels.

Screenshot here:
http://img88.imageshack.us/img88/9465/clipboard01jl.jpg

To Fix:
Uninstall visual c++ runtime from control panel -> programs and features.

Install visual c++ from microsofts website
http://www.microsoft.com/en-us/downl...s.aspx?id=5555 (32bit windows)
http://www.microsoft.com/en-us/downl....aspx?id=14632 (64 bit windows)

If that don't work try disabling antivirus, my game is not crashing now.

Last edited by shadow722: 08-21-2012 at 11:39 AM.
shadow722 is offline   Reply With Quote
Old 08-19-2012, 05:51 AM   #14
Zagiel
 
Join Date: Feb 2012
Reputation: 0
Posts: 5
I have the same problem since several days :/

Motherboard: Asus P5QC
Processor: Intel Core 2 Duo E8500 3.16GHz
Video Card: Asus Radeon HD 6870
Sound Card: Sound Blaster Audigy SE
Operation System: Windows 7 Professional 64-bit
Zagiel is offline   Reply With Quote
Old 12-01-2012, 09:01 PM   #15
grodus
 
 
 
Join Date: Oct 2012
Reputation: 0
Posts: 1
Red face Crash depending on operating system?

Starting a few months ago, I crash most often while transitioning maps, but sometimes crash mid-game with no message. However, if I change my installation from Windows XP to Windows 7, (Leaving every other component of the computer the same, including my Steam folder) the crashes stop.

On XP it crashes every 2-3 maps, on 7 it doesn't crash at all.

I have tried everything on this list a good 5 times each. Still no change

ASUS P5Q
Core 2 Duo 3Ghz
4G RAM
nVidia GTS250 512MB
grodus is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Left 4 Dead 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.