Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Space series

Reply
 
Thread Tools Display Modes
Old 02-28-2012, 11:01 AM   #1
Darksonic22
 
Join Date: Aug 2010
Reputation: 0
Posts: 4
Dead Space 2 won't launch

When I try launch it it does that activation process, when it's successful the game won't start, I've tried going into 3d applications with Nvidia and I've changed every possible setting to Prefer Maximum Performance.
Darksonic22 is offline  
Reply With Quote
Old 03-01-2012, 07:27 AM   #2
Darksonic22
 
Join Date: Aug 2010
Reputation: 0
Posts: 4
I really need help with this?
Darksonic22 is offline   Reply With Quote
Old 03-12-2012, 08:18 PM   #3
TeatimeAssassin
 
Join Date: Mar 2012
Reputation: 0
Posts: 1
I know its a bit late responding but I had the exact same problem. I tried everything i could find and nothing seemed to work,until I tried this. In case you are still having problems I thought I would share. I can't promise it will work for you but its worth a try.

I have Windows 7 64-bit. I'm using NVIDIA GeForce GTX 560 Ti
I downloaded and installed DeadSpace 2 through steam (obviously

I booted into Safemode with networking
I ran the dead space 2 exe file from program files (for me it was C:\Program Files (x86)\Steam\steamapps\common\dead space2\deadspace2.exe)
I went through the activation and got the "activation successful" message.
Dead Space2 then attempted to load but errored out
I rebooted into windows like normal
Dead Space2 ran without a problem

Hope this helps

Last edited by TeatimeAssassin: 03-12-2012 at 08:20 PM.
TeatimeAssassin is offline   Reply With Quote
Old 03-13-2012, 06:55 PM   #4
Dragline
 
 
 
Join Date: Aug 2011
Reputation: 2
Posts: 12
i have the exact same problem and i've tried multiple fixes, including teatimeassassin's, sadly i have yet to have anything work for me.
Dragline is offline   Reply With Quote
Old 03-20-2012, 05:32 AM   #5
Menchi
 
 
 
Join Date: May 2011
Reputation: 0
Posts: 53
Sadly i have this problem too...but i was thinking...maybe we need origin to make it run...? (it's just a thought,i still have to try it)
Menchi is offline   Reply With Quote
Old 03-21-2012, 10:13 PM   #6
zbobg
 
Join Date: Jul 2005
Reputation: 0
Posts: 60
One month after I last played DS2 the game now won't run. Really, I had valid savegame files so I know it was running last month. [Win 7 Pro x64]

This time when I started it it asked for online CD-Key validation. It is a Steam download version but the key validation is still required I guess. But... Why would I have to revalidate the game when it was running last month? This is when I knew something was very wrong.

So, I verified the cache files. A total of six files were found to be bad, worse it was a total of 8.663 Gb of bad files that now needed to re-download (on my system about 8 hours of download). NOT NICE!

I'm absolutely sure those files are(were) not corrupt. My opinion is that something in the Steam client changed that caused the game files to become nonfunctional or noncompliant.

I haven't tried other games, I expect to have trouble with some of the others.
zbobg is offline   Reply With Quote
Old 03-29-2012, 06:42 PM   #7
Rehevkor
 
Join Date: May 2010
Reputation: 0
Posts: 31
I have the same problem and none of the proposed solutions work for me. Glad I only paid $5 for this game... EA doesn't deserve a single cent for this garbage though.
Rehevkor is offline   Reply With Quote
Old 06-19-2012, 03:03 PM   #8
Fallxen
 
 
 
Join Date: Jun 2012
Reputation: 0
Posts: 1
Go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

This worked for me maybe will work for others! I know this thread was dead but its good to help if people are still having issues.
Fallxen is offline   Reply With Quote
Old 07-26-2012, 11:10 PM   #9
ryuedward
 
Join Date: Jun 2012
Reputation: 0
Posts: 87
Quote:
Originally Posted by Fallxen View Post
Go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

This worked for me maybe will work for others! I know this thread was dead but its good to help if people are still having issues.
after changing my laptop, now it equips with nvidia graphic card. the firs time when I opened the game, thing was happened. then I did what you suggested. it worked. after uninstalling it, reinstall again. it doesn't work no matter how I do. it had no problem with AMD card. I guess that nvidia card, which is based on optimus technology, have major issue.
ryuedward is offline   Reply With Quote
Old 08-14-2012, 08:07 PM   #10
ThaimbomB
 
Join Date: Aug 2012
Reputation: 0
Posts: 6
Robbed of 5 bucks

I heard great things bout this game and I end up wanting to try it out and the freakin game itself doesn't even work either! HELP STEAM WTF!
ThaimbomB is offline   Reply With Quote
Old 08-15-2012, 07:53 AM   #11
shiva7663
 
 
 
Join Date: Jun 2012
Reputation: 0
Posts: 8
I wonder if the authentication server(s) are hosed, so that nothing we do on our end will make any difference. I've tried all of the suggested fixes, to no avail.
shiva7663 is offline   Reply With Quote
Old 08-15-2012, 04:17 PM   #12
Raizak
 
 
 
Join Date: Apr 2012
Reputation: 4
Posts: 78
Here's what I did to fix the problem:
1. Go to your msconfig(type it into the search bar at the Start menu)
2. Click services tab
3. Uncheck Windows Management Instrumentation
4. Restart computer

Game should work after that. Took me 2 whole days of frustration to figure this out.

Last edited by Raizak: 08-15-2012 at 06:16 PM.
Raizak is offline   Reply With Quote
Old 08-15-2012, 09:52 PM   #13
GaryZero
 
Join Date: Mar 2010
Reputation: 4
Posts: 10
Thanks Fallxen, this also worked for me just now. Kinda weird, maybe it will get patched?

Quote:
Originally Posted by Fallxen View Post
Go to windows control panel
select nvidia control panel
select manage 3d settings
select global settings
prefered graphics processor:select high-performance Nvidia processor

This worked for me maybe will work for others! I know this thread was dead but its good to help if people are still having issues.
GaryZero is offline   Reply With Quote
Old 08-17-2012, 12:43 AM   #14
gaspah1981
 
 
 
Join Date: Jul 2012
Reputation: 30
Posts: 223
Quote:
Originally Posted by Raizak View Post
Here's what I did to fix the problem:
1. Go to your msconfig(type it into the search bar at the Start menu)
2. Click services tab
3. Uncheck Windows Management Instrumentation
4. Restart computer

Game should work after that. Took me 2 whole days of frustration to figure this out.
holy cow. this disables
Security Center
VMware Authorization Service
MSMFramework
IP Helper
Intel(R) Rapid Storage Technology

not sure if worth it?

EDIT: Didn't work anyways.


Details of crash:
Code:
Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	deadspace2.exe
  Application Version:	1.0.0.0
  Application Timestamp:	00000000
  Fault Module Name:	deadspace2.exe
  Fault Module Version:	1.0.0.0
  Fault Module Timestamp:	00000000
  Exception Code:	c0000005
  Exception Offset:	003c4902
  OS Version:	6.1.7600.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789


I've tried:

* Launched from game folder
C:\Program Files (x86)\Steam\steamapps\common\dead space 2
Rebooted.. then launched again.

* Compatibility mode (XP SP3)

* Run as administrator

* Launched activation application
C:\Program Files (x86)\Steam\steamapps\common\dead space 2\activation.exe

* I don't have hybrid gpus
(so unable to make nVidia GPU primary)

* Disabled WMI Service
(enabling/disabling this seems to restart the activation process which makes sense, but doesn't help)

* Rebooted PC multiple times

* Tried the below settings for DeadSpace2.exe in nvcplui.exe (nVidia Control Panel)
http://i.imgur.com/YLINm.jpg
http://i.imgur.com/LL20R.jpg

* Validated Steam files
(no errors, but still doesn't launch)

* Checked/deleted settings folder
C:\Users\Admin\AppData\Local\EA Games\Dead Space 2 (folder was empty)

* Unplugged/Disconnected my Wireless Xbox 360 Controller

* Disabled Xbox 360 Wireless Reciever for Windows in Device Manager

* Disable HID Compliant Game Controller in Device Manager

* Disabled Logitech G13 Joystick in Device Manager

* Disabled Logitech Gaming Virtual Mouse in Device Manager

* Uninstalled Logitech Gaming Virtul Keyboard in Device Manager

* Diabled HID-compiant consumer control device

* Unplugged Xbox Wireless Reciever

Ah crap!! I figured out how to fix it, and I'm not happy about it. I disabled 8 of my 12 CPU cores on bootup and now it works.

ahh.. this game can eat a ... no way am i rebooting everytime i want to play it... takes my machine 5-10 minutes to reboot. I've tried every sort of affinity workaround in the book and it still crashes unless i boot with 4 cores running.

(i'll update as i try more things)

or if anyone has any better ideas.

Last edited by gaspah1981: 08-17-2012 at 03:30 AM.
gaspah1981 is offline   Reply With Quote
Old 08-17-2012, 10:01 PM   #15
tk9780
 
Join Date: Apr 2009
Reputation: 3
Posts: 232
idea stopping WMI, basically you've sort of deployed a thermal-nuclear device to kill a mouse.

Activation DS2 - Goto EA.com setup EA/Origin account - install DS2 via Steam onto PC - Check Firewall allow program setting for Steam/DS2 [public] - Run DS2 for the 1st time copy CD Key to clipboard - sign in EA account - wait a moment for DS2 to be Activated - Start DS2 game.
Steam are simply the retail store activation still has to be done via EA
tk9780 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Space series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.