Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Pandora Saga: Weapons of Balance

Reply
 
Thread Tools Display Modes
Old 03-05-2012, 12:53 PM   #1
Tiikii
 
Join Date: Mar 2012
Reputation: 0
Posts: 1
Doesn't even start up when i press play

I click play the game then i get the client update. I click play on that and nothing happens. I've checked to see if it was blocked by my firewall and it's not. I checked to see if it would work with me anti-virus protection off and it still does the same thing. I've also tried re-installing it several times that didn't work. I even went and Dl'd the game from the official website and i got nothing. Please someone tell me what i'm doing wrong.
Tiikii is offline  
Reply With Quote
Old 03-06-2012, 07:46 AM   #2
Ben The Spike
 
Join Date: Nov 2011
Reputation: 0
Posts: 4
Angry Same problem

I am having the same problem. I've done quite a bit of looking online for anything for this, messed with settings, reinstalled the game, restarted my computer, tried getting drunk to fix it, even slapped a baby. Help anyone?
Ben The Spike is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Pandora Saga: Weapons of Balance


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 11:21 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.