Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Terraria

Reply
 
Thread Tools Display Modes
Old 03-22-2012, 03:07 AM   #1
Zortalist
 
 
 
Banned
Join Date: Dec 2011
Reputation: 314
Posts: 877
Game not available/corrupt

This happens almost every time I restart my Steam. 3 of game files somehow go corrupt and as a result the game won't start unless I verify game cache integrity. Then it says 3 files were not validated and needed to be downloaded. Only then will the game start.

Any ideas how to fix this?
Zortalist is offline  
Reply With Quote
Old 03-22-2012, 03:35 AM   #2
Xzalander
 
 
 
Join Date: Oct 2008
Reputation: 171
Posts: 1,104
Sounds like a hardware issue and not so much a steam issue, if steam is validating and downloading the correct files and that allows it to start, then at some point there is some corruption going on your side.

Only thing I can think of suggesting is Defrag your drives, run AVAST and Malwarebytes (or the equivalents of) and keep an ear out for any mechanical clicking from your drive that sounds unusual.
Xzalander is offline   Reply With Quote
Old 03-22-2012, 03:39 AM   #3
Zortalist
 
 
 
Banned
Join Date: Dec 2011
Reputation: 314
Posts: 877
Quote:
Originally Posted by Xzalander View Post
Sounds like a hardware issue and not so much a steam issue, if steam is validating and downloading the correct files and that allows it to start, then at some point there is some corruption going on your side.

Only thing I can think of suggesting is Defrag your drives, run AVAST and Malwarebytes (or the equivalents of) and keep an ear out for any mechanical clicking from your drive that sounds unusual.
I am using a SSD.
Zortalist is offline   Reply With Quote
Old 03-22-2012, 04:20 AM   #4
Xzalander
 
 
 
Join Date: Oct 2008
Reputation: 171
Posts: 1,104
Quote:
Originally Posted by Zortalist View Post
I am using a SSD.
That eliminates mechanical moving parts failure, there could still be some electrical circuit issues inside the SSD though.

Just thought, have you done a CheckDisk yet? Could be a badblock and your terraria install is installing on good clean sections, then the SSD is autofiling it onto a badblock or sector.

Last edited by Xzalander: 03-22-2012 at 04:23 AM.
Xzalander is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Terraria


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.