Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Total War: SHOGUN 2

Reply
 
Thread Tools Display Modes
Old 04-26-2012, 08:36 PM   #1
PrivateJoker
 
Join Date: Sep 2011
Reputation: 11
Posts: 87
Red face Ally support doesn't work

I was just playing the campaign and I besieged a castle and decided to continue the siege until the next turn, in that time an ally of mine approached the castle with his troops. This meant that his army was reinforcing me in the coming battle. This never usually happens to me in the campaign, the reinforcements I usually get are from my own army, so I was interested to see how it would play out. Would I control his troops or would the AI aid me as best he could? Well, what happened was, the battle began, I saw that reinforcements were approaching, but they were just stationary, just outside the map border, they did not move for the entire battle, not once and I could not move them, they were not even within the map so they couldn't fight either. I had to face an overwhelming force on my own (I still won, but lost more troops than I would have liked to). My army was moderately sized so this was not a question of the amount of troops allowed in the battle, my ally just didn't really turn up, though I could see his troops, mocking me from outside the red map line. My question is: is this a common bug? Will this happen every time an ally aids me? If so, why hasn't CA fixed this yet?
PrivateJoker is offline  
Reply With Quote
Old 04-26-2012, 09:42 PM   #2
Teh_Barbarian
 
 
 
Join Date: Nov 2011
Reputation: 25
Posts: 303
What is worse, is that twice now, my ally (In two different campaings) Decided to "aid me" besieging a castle, but waited for me to be pushed off the siege to just walk in and take the castle himself, after the massive effort of money and logistics, not to mention heavy loss of men so I could cap the providence.

Anyway, regarding your issue, it hasn't happened to me. I was in a battle and got reinforcements from the AI where they controlled the troops.
Teh_Barbarian is offline   Reply With Quote
Old 04-27-2012, 12:02 AM   #3
Mr_Eon
 
Join Date: Apr 2009
Reputation: 166
Posts: 1,006
I usually don't rely on Allies coming to help in a siege.

I HAVE refused to participate when an Ally initiated the siege just so he got cut to pieces and blunted the defenders so I could roflstomp them in my next turn.

If that makes me a bad Daimyo then I don't wanna be good.
Mr_Eon is offline   Reply With Quote
Old 04-27-2012, 01:00 AM   #4
PrivateJoker
 
Join Date: Sep 2011
Reputation: 11
Posts: 87
This was actually my first time I'd been in a campaign battle with an ally in Shogun 2, hopefully this is just a one off bug. Thanks for the responses
PrivateJoker is offline   Reply With Quote
Old 04-27-2012, 07:15 AM   #5
Apheirox
 
Join Date: Oct 2009
Reputation: 172
Posts: 1,055
It is just an one-off bug, it usually works. The AI is naive like a child and will never try to trick you or not fully commit to an assault. What Barbarian describes must have been another fluke.
Apheirox is offline   Reply With Quote
Old 04-27-2012, 07:23 AM   #6
masterthehero
 
Join Date: Sep 2009
Reputation: 49
Posts: 697
So far whenever I've had that scenario happen, I usually just click on auto-resolve, because the AI doesn't seem to show up in my battles anyway.
masterthehero is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Total War: SHOGUN 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.