Go Back   Steam Users' Forums > Steam Game Discussions > # - C > BioShock 1 & 2

Reply
 
Thread Tools Display Modes
Old 05-14-2012, 06:05 PM   #1
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
No sound after the intro in Bioshock with Win 7 64-bit, tried about everything...

So far, I have:

Updated all drivers (Stereo, Realtek, etc)
Enabled stereo mixing (and plugged in a microphone!)
Tried various forms of compatibility mode
All while running as an Admin
Added -dx9

I'm still getting sound in the introduction, but no sound after the plane crash. Is this happening to anybody else? Has anyone been able to fix it? I'm using the integrated audio on my Gigabyte motherboard.

Win 7 64 Pro
AMD Phenom II X4 965
16 GB Ram
GIGABYTE GA-970A-UD3 AM3+ AMD 970 SATA 6Gb/s USB 3.0 ATX AMD Motherboard

Last edited by SnakeGatsby: 05-14-2012 at 06:11 PM.
SnakeGatsby is offline  
Reply With Quote
Old 05-14-2012, 07:21 PM   #2
lizard81288
 
 
 
Join Date: Jun 2011
Reputation: 1
Posts: 165
Going to sound dumb, but did you check the sticky?
lizard81288 is offline   Reply With Quote
Old 05-14-2012, 07:31 PM   #3
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
Apparently that's the default response to any question...

Yes, I did. I checked all of them. I googled this like ten million times. Then I listed everything I did, which includes even more than what the stickies suggested.

Any new info would be greatly appreciated!
SnakeGatsby is offline   Reply With Quote
Old 05-15-2012, 08:48 AM   #4
rolandoftheeld
 
 
 
Join Date: Nov 2006
Reputation: 131
Posts: 813
Since you've tried all the smart solutions, how about a dumb one: are you sure the ingame sound sliders aren't at 0?
rolandoftheeld is offline   Reply With Quote
Old 05-15-2012, 02:30 PM   #5
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
Quote:
Originally Posted by rolandoftheeld View Post
Since you've tried all the smart solutions, how about a dumb one: are you sure the ingame sound sliders aren't at 0?
That and I tried every option on the in-game audio settings (Pro Logic, Stereo, etc.).
SnakeGatsby is offline   Reply With Quote
Old 05-17-2012, 09:39 AM   #6
DONUT525
 
Join Date: Jan 2012
Reputation: 0
Posts: 4
Ive had this problem too.
I checked the in game sliders, and everything was set to 0.
It was impossible to change those options. Master Volume. Sound EFX Volume. all of the volume options were at 0, and were unable to change. Other settings, like difficulty, framerate, subtitle, art subtitle options, I WAS able to change, but nothing on audio.
DONUT525 is offline   Reply With Quote
Old 05-17-2012, 03:01 PM   #7
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
Quote:
Originally Posted by DONUT525 View Post
Ive had this problem too.
I checked the in game sliders, and everything was set to 0.
It was impossible to change those options. Master Volume. Sound EFX Volume. all of the volume options were at 0, and were unable to change. Other settings, like difficulty, framerate, subtitle, art subtitle options, I WAS able to change, but nothing on audio.
Unfortunately, that's not the case with mine. Sliders look fine.
SnakeGatsby is offline   Reply With Quote
Old 05-17-2012, 04:00 PM   #8
Hakenaton
 
Join Date: Oct 2009
Reputation: 2
Posts: 43
I have exactly the same issue, no Sound at all.
Hakenaton is offline   Reply With Quote
Old 05-17-2012, 04:45 PM   #9
Hakenaton
 
Join Date: Oct 2009
Reputation: 2
Posts: 43
Got it to work!

There is a post somewhere in the forum suggesting the following and it worked for me, hopefully will work for you as well.

"If you do, go into Control Panel\Hardware and Sound\Sound. In the box that pops up, go into Recording tab, right click a clear space and make sure that 'Show Disabled Devices' is ticked. Once done, a device called 'Stereo Mix' should show. Enable this and enjoy BioShock with sound!"
Hakenaton is offline   Reply With Quote
Old 05-18-2012, 09:41 AM   #10
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
As I said in the OP, I already tried that, but thanks.
SnakeGatsby is offline   Reply With Quote
Old 05-19-2012, 11:18 AM   #11
MADDOGGE
 
Join Date: Jan 2008
Reputation: 11396
Posts: 26,149
Did you remember to remove the -nosound launch parameter if you used it to test?
MADDOGGE is offline   Reply With Quote
Old 05-21-2012, 02:17 PM   #12
SnakeGatsby
 
 
 
Join Date: Mar 2012
Reputation: 17
Posts: 27
I didn't use it to test.
SnakeGatsby is offline   Reply With Quote
Old 05-21-2012, 08:26 PM   #13
Aquarrhea
 
 
 
Join Date: Dec 2011
Reputation: 0
Posts: 7
Do you have any past saves? I had that happen to me, strangely enough though when I went to my last save the sound was working. So I had to branch off of that save to continue with the sound.
Aquarrhea is offline   Reply With Quote
Old 06-04-2012, 11:39 PM   #14
Solid Sawyer
 
 
 
Join Date: Jul 2010
Reputation: 37
Posts: 714
I just started the game for the first time, sound disappears after the plane sequence in the intro. It cuts out between the plane ride and coming up from underwater. Win 7 64bit. I read to run it in XP compatibility mode, going to try that next and see if it helps.

Setting bioshock.exe to Windows XP SP2 compatibility mode seems to have solved the problem.

Last edited by Solid Sawyer: 06-05-2012 at 12:19 AM.
Solid Sawyer is offline   Reply With Quote
Old 07-01-2012, 12:04 PM   #15
lone_virgo
 
 
 
Join Date: May 2011
Reputation: 0
Posts: 15
Thumbs up

For ANY problems in Win 7; Just upgrade your Rapture 3d software that comes with the game.
All problems solved.
lone_virgo is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > BioShock 1 & 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.