Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Metro 2033

Reply
 
Thread Tools Display Modes
Old 05-26-2012, 05:36 AM   #1
thedude3331
 
Join Date: May 2012
Reputation: 0
Posts: 1
Question Stutter 2033

Metro 2033 has been stuttering for me ever since I got it, no other game has done this for me. Please end my frustration.
I have tried DEP method
Verifying Game Files
Reinstalling
and updating drivers

My specs:
Windows 7
Intel I7 870
Nvidia GTX 570
8 GB of ram
thedude3331 is offline  
Reply With Quote
Old 05-26-2012, 09:58 AM   #2
SPG
 
Join Date: May 2010
Reputation: 519
Posts: 961
I had similar problems, but also have a completely different system. You can try the following and see if it helps.

Go to bottom right hand of page under game issues and also check under the tweaks link.

http://gamebytesandbots.com/xgames/metro.html

You can also search this forum as I believe this problem has been addressed before. It just gets buried in old posts.
SPG is offline   Reply With Quote
Old 05-26-2012, 10:33 AM   #3
cyborg34573
 
Join Date: Jun 2010
Reputation: 336
Posts: 2,723
If your stuttering is not performance related, meaning your framerate is stable but you still get stuttering/microstuttering, then try this, its jsut a compilation of stuff ive tried to get the game smooth.

"I found a fix for my stutter/microstutters. For me on ANY setting i get the problem, even just using single GPU the problem would still be there. But in my anger to get the game smooth i tried everything all at once

#Turn off Vsync ingame via config

- To do this just simply go to your
*User Folder - AppData - Local - 4A Games - Metro2033 -
*Open "User.cfg" with notepad
*Change r_vsync to "off" without quotes and save
- If you cannot find AppData folder in your user folder, thats because its by default a hidden folder, to unhide it just do this
*Start - ControlPanel - Change view to "Large Icons" (just to make it easier to find things) - Folder options - View Tab
*Change "Hidden files and folders" to "Show hidden files, folders, or drives". After that you should see AppData in your user folder.

#Force Vsync and Triple-Buffering via D3DOverrider (tho im not sure if D3DOverrider even works for this game, but i do it anyways).

- To do this its pretty straight forward/simple
*Download and installed "Rivatuner", D3DOverrider comes with this program.
Here's the link : http://downloads.guru3d.com/download.php?det=163
*To execute it just do Start - in search type in "D3DOverrider" without quotes, it should pop up.
*In D3DOverrider to force things you just pretty much have to add the games executable, so click on the big plus sign and find/add the games exe file.
*Set program detection to medium or high and make sure to turn on Force Vsync and Triple-Buffering.
- Make sure to have it running in the background before you execute/run your game, or else nothing will be forced, to confirm its working you will hear a confirmation sound play just after you start the game.

#If D3DOverrider doesn't work though then you can try forcing "Adaptive Vsync" in the Nvidia Control Panel.

- To do this
*Right click your desktop and open "Nvidia Control Panel"
*On the top left side click "Manage 3D settings"
*Go to "Program Settings" tab and find Metro2033 Profile, if its not there by default then add in the games executable by clicking add.
*Once you have found the games profile or have made one, just scroll down the list of settings you can force and set "Vertical Sync" to "Adaptive". (If "Adaptive" is not there then that means you dont have the latest drivers, in that case, update your drivers to the latest which is 301.42)
*Apply and you should be done.

Didnt seem to do much but i tried something else, via Dxtory i limited my framerate one frame lower than my monitors RefreshRate and wow was i surprised, 100% smooth ingame, no more stuttering/microstuttering, i tested the places that stuttered the most before and they are now smooth as hell. To see if i was just having a placebo effect, i took out the framerate limit and let it run 60Fps instead of 59Fps and bam the stutter was back. So yeah now i definitely know that the combination of forcing Vsync (Not using ingame Vsync) and limiting framerate fixes it for me.

- To limit framerate Via Dxtory
*Download and install Dxtory, its a recording program, better than fraps imo, but also has the feature to limit framerate
Here's the link: http://dxtory.com/v2-download-en.html
*Open Dxtory and go to the tab that has an icon that looks like a chip
*Set "Processing Threads to the number of cores your processor has
*check "Limit Video FPS" and set the Fps one frame lower than your monitors Refresh Rate, so if your monitor has 60hz then set it to 59FPS, if your monitor has 120hz then set it to 119Fps.
*To confirm the program is running with your game, in Dxtory go to the tab that has the icon that looks like a monitor/screen and check the following, "Use Default Setting", "Video FPS", "Write File FPS".
- Leave the program running in the background for it to have effect. Youl know it its running with the game when you see your framerate displayed by it.

- You can also limit your framerate via "MSI Afterburner" an overclocking tool that has the feature aswell.

But yeah try all those combinations at once and see if it helps you guys out. Good luck.

EDIT:
Also make sure you set your mouse Polling Rate to atleast 500hz or even 1000hz,
having it at 125hz will make your mouse movements "choppy" which will look like stuttering in some games.

EDIT 2:
This will only work if your stuttering btw is not caused by "performance issues", if you stutter/microstutter on ANY setting despite your framerate being always stable then this might work, but if your stutter was just lack of VRAM or video card not powerful enough for the settings your playing then no these "might" not work. It probably might not work too if your stuttering/microstuttering is caused by SLI/Crossfire issues, in that case better drivers might help you more or a better Motherboard chipset. But i myself am using an SLI setup atm with three cards and no microsttutering at all in any of my games."

Last edited by cyborg34573: 05-26-2012 at 10:39 AM.
cyborg34573 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Metro 2033


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 02:59 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.