Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
Click here to go to the first staff post in this thread.  
Thread Tools Display Modes
Old 06-01-2012, 02:23 PM   #1
Metal_Izanagi
 
 
 
Join Date: Jan 2011
Reputation: 113
Posts: 1,010
Can't link Steam account to forum account

When I try to link my accounts, so I can access the trading forums, I get the message with the green Steam button, telling me to click that to log in and link my accounts. After I click on the button, it directs me to

http://forums.steampowered.com/forums/betacheck/

and sits there on a blank screen. I've disabled any addons that could be causing a conflict in Firefox, and still nothing. Any suggestions?

=== UPDATE ===

Quote:
Originally Posted by BurtonJ View Post
Known issue, I'm looking into it. Your patience is appreciated.


In the mean time, here is a list of some of the other places available for you to use:

Games and Coupon trading sites
Team Fortress 2 Items trading sites
Other
Significant Steam Groups

Last edited by BurtonJ: 06-03-2012 at 09:07 AM.
Metal_Izanagi is offline  
Reply With Quote
Old 06-01-2012, 02:32 PM   #2
Atome
 
 
 
Join Date: May 2012
Reputation: 110
Posts: 365
Try to use another browser maybe it will work
Atome is offline   Reply With Quote
Old 06-01-2012, 02:54 PM   #3
eets2
 
 
 
Join Date: Apr 2012
Reputation: 5
Posts: 31
Same here, 3 different browsers
eets2 is offline   Reply With Quote
Old 06-01-2012, 03:06 PM   #4
the kid
 
 
 
Join Date: Nov 2009
Reputation: 0
Posts: 9
Same problem here, tried in 4 different browsers...
the kid is offline   Reply With Quote
Old 06-01-2012, 03:23 PM   #5
Atome
 
 
 
Join Date: May 2012
Reputation: 110
Posts: 365
might be a steam problem, try to do it later.
Atome is offline   Reply With Quote
Old 06-01-2012, 05:02 PM   #6
Schmooblidon
 
 
 
Join Date: Feb 2010
Reputation: 0
Posts: 71
Also having the same bloody problem, this really takes the jarate. Where are the admins?
Schmooblidon is offline   Reply With Quote
Old 06-01-2012, 06:09 PM   #7
r0man
 
Join Date: Jul 2011
Reputation: 0
Posts: 7
Same here.
r0man is offline   Reply With Quote
Old 06-01-2012, 06:29 PM   #8
nutcrackr
 
 
 
Join Date: Jun 2004
Reputation: 65
Posts: 3,854
blank for me too
nutcrackr is offline   Reply With Quote
Old 06-01-2012, 06:32 PM   #9
damaged
 
Join Date: Jul 2008
Reputation: 8738
Posts: 7,270
It's not blank for me, it may be some security software on your systems blocking the page contents. It could also be that you are connecting to a server on the cdn which is having an issue, rebooting your router and PC (or exiting your browser, and doing a ipconfig /flushdns) may get you a new cdn server.
damaged is offline   Reply With Quote
Old 06-01-2012, 07:29 PM   #10
Lucky Mouse
 
Join Date: Jun 2011
Reputation: 0
Posts: 10
Blank for me too. Tried rebooting and three different browsers. Also tried disabling all of my security programs and adblock plus.
Lucky Mouse is offline   Reply With Quote
Old 06-01-2012, 09:33 PM   #11
Panton777
 
Join Date: Dec 2011
Reputation: 0
Posts: 11
same problem
Panton777 is offline   Reply With Quote
Old 06-01-2012, 10:01 PM   #12
jewstin
 
 
 
Join Date: Jun 2011
Reputation: 7
Posts: 43
me tooooooooooooooooooooooooooooooooooooooooooooooooo o
jewstin is offline   Reply With Quote
Old 06-01-2012, 10:28 PM   #13
venom285
 
 
 
Join Date: Dec 2011
Reputation: 0
Posts: 1
me too
venom285 is offline   Reply With Quote
Old 06-01-2012, 11:35 PM   #14
Matt
 
Matt's Avatar
 
Volunteer Moderator - I was on TV!
Join Date: Jun 2003
Reputation: 4718
Posts: 22,912
I sent a note about this problem to the administrators.

__________________
Steam Community and Forum Moderator
Have Fun!
Forum Rules: View
Matt is offline   Reply With Quote
Old 06-02-2012, 02:18 AM   #15
Dz0mba
 
 
 
Join Date: Oct 2011
Reputation: 0
Posts: 4
I have same problem....
Dz0mba is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.