Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Psychonauts

Reply
 
Thread Tools Display Modes
Old 06-23-2012, 02:38 PM   #1
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Annoying Stuttering/Skipping/hiccups

Hey guys, I've searched solutions for the problem, but can't find anything related to my problem. I'm trying this game on my laptop and it worked absolutely fine for hours. It played at a solid 60 frames per second.

After a while, the game suddenly started stuttering for me. Every 3 seconds or so, during in-game dialogue and gameplay the game has this annoying stutter. It makes the sound skip and the screen as well. It doesn't make the game unplayable, but it makes everything awkward and a whole lot less fun.

My graphic drivers are always up to date. I can still play Crysis 2 at high settings between 50-60fps with everything working smoothly. To make sure it's not my laptop that's causing this. I disabled V-sync, which also removes the framecap. The game will run above 160 frames per second, meaning my laptop has no problem handling this game.

My laptop has an Intel i7 card, Nvidia Geforce GT 555M for the graphics. OS is Windows 7 64-bits.

Reading the Double Fine FAQ, I came across the following:

Psychonauts audio is super glitchy and the framerate stutters a lot. How do I make it stop sucking?
On Windows, the most frequent cause of really bad performance on Psychonauts is due to the OpenAL.dll that Pnauts uses for audio playback. The dll that ships with Pnauts is the version that’s the most stable for the most people, but for some people it results in the aforementioned stuttering and choppiness. The fix is to replace the OpenAL.dll in the Psychonauts directory with a newer version, which you can find here http://connect.creativelabs.com/open.../AllItems.aspx.


This sounds like it might be the problem I'm having. The only problem is that I have no idea which file to download from that link. And furthermore, the downloads require me to have an account. Anyone know of a better/more clear solution?

Last edited by Nothankyou: 06-24-2012 at 03:49 AM.
Nothankyou is offline  
Reply With Quote
Old 06-23-2012, 07:56 PM   #2
Obsydiaan
 
 
 
Join Date: Jul 2008
Reputation: 21
Posts: 158
From that link, download oalinst (you shouldn't need an account, I know I didn't), unzip it, install it, find the openal32.dll that it put in system32 and copy that into the Psychonauts directory, replacing the old one.
Obsydiaan is offline   Reply With Quote
Old 06-24-2012, 02:16 AM   #3
Colyeses
 
Join Date: Apr 2011
Reputation: 0
Posts: 15
Quote:
Originally Posted by Obsydiaan View Post
From that link, download oalinst (you shouldn't need an account, I know I didn't), unzip it, install it, find the openal32.dll that it put in system32 and copy that into the Psychonauts directory, replacing the old one.
This is the common answer and I have tried it several times, but the issue isn't resolved by it.
Colyeses is offline   Reply With Quote
Old 06-24-2012, 06:03 AM   #4
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Quote:
Originally Posted by Obsydiaan View Post
From that link, download oalinst (you shouldn't need an account, I know I didn't), unzip it, install it, find the openal32.dll that it put in system32 and copy that into the Psychonauts directory, replacing the old one.
Thanks a lot dude, I'm trying out the game and it's running perfectly again. I did also reinstall the entire game, so I can't be sure what fixed it. I hope this will be a permanent solution.
Nothankyou is offline   Reply With Quote
Old 06-24-2012, 10:49 AM   #5
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Well, I was afraid this would happen. The game is back to being crappy. After exiting, not playing for a few hours and going back, it is again acting up in the same way. Any tips would be very welcome.. cause the game really is incredible.
Nothankyou is offline   Reply With Quote
Old 06-24-2012, 11:20 AM   #6
DFNathan
 
Double Fine Productions
Join Date: Dec 2011
Reputation: 169
Posts: 830
That's very strange, the fact that it didn't work and then worked and then didn't work means suggests one of two things:
1) Steam re-clobbered your OpenAL32.dll. Did you agree to update any files before launching it a second time? Can you check the date stamps on that file to see if they match the version you copied in manually? If the DLL is the one you hand installed, then the most likely case is:
2) Something else running on your system is interfering with the game, perhaps by sapping CPU time (which can cause stuttering). My first recommendation would be to reboot your computer to see if that helps. Second would be to check out any heavy duty background processes like defrag, av/malware scanners, etc.

Let us know if that helps you find anything!
DFNathan is offline   Reply With Quote
Old 06-24-2012, 11:51 AM   #7
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Quote:
Originally Posted by DFNathan View Post
That's very strange, the fact that it didn't work and then worked and then didn't work means suggests one of two things:
1) Steam re-clobbered your OpenAL32.dll. Did you agree to update any files before launching it a second time? Can you check the date stamps on that file to see if they match the version you copied in manually? If the DLL is the one you hand installed, then the most likely case is:
2) Something else running on your system is interfering with the game, perhaps by sapping CPU time (which can cause stuttering). My first recommendation would be to reboot your computer to see if that helps. Second would be to check out any heavy duty background processes like defrag, av/malware scanners, etc.

Let us know if that helps you find anything!
Thanks a lot man, it's good to know you guys are actively helping people out. First of all, I should probably mention that I downloaded the game from the Humble Bundle, not steam. I have been told they are the exact same though.

The date stamps did match the time I manually replaced it. I still tried to use the same method and it failed. I've naturally restarted my laptop and checked for any heavy programs running, but that's not the case.

Your theory of OpenAL32.dll being overwritten made me think of something though. Since it seemed to work perfectly fine after fresh installs, but not after closing the game and trying again, it might be overwriting some files. I'm going to reinstall it again and put all the files on Read Only (except for my save profile). I'll keep you guys posted.
Nothankyou is offline   Reply With Quote
Old 06-24-2012, 12:59 PM   #8
DFNathan
 
Double Fine Productions
Join Date: Dec 2011
Reputation: 169
Posts: 830
Ok, good luck with that. If you're playing the HiB version, you can definitely rule out Steam auto-updates. As you say, they are the same, though, other than Steam integration.

Regarding making things read only, it's a good thing to try but the game may crash if certain files are read only. I'm not sure how robust we are against that in all cases. Probably .ini files are the most likely to behave badly if read-only. However, you can definitely copy the ones you have out and then see if they change and if so maybe that'll be a clue.

One more thing to try is disabling EAX (if it's enabled) or vice versa. Usually, EAX causes more problems than it solves, so I usually recommend disabling it, but YMMV. I definitely think your issue is somehow audio related, we're just not sure exactly what yet.

Always happy to help. We want to make sure everyone enjoys our games with as little fuss as possible
DFNathan is offline   Reply With Quote
Old 06-25-2012, 08:53 AM   #9
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Well, like last time, the game played perfectly fine after a fresh install. After quitting the game and starting it again, the issues returned as usual. Marking files as read only had no effect, neither did enabling EAX (it was disabled by default). Switching up hardwareaccel had no effect either and disabling preloadvoice was a disaster.

I might have to just keep reinstalling the game. It takes about 10 minutes, which is annoying, but it may be worth it. If you have any more tips, I'd be happy to hear them. If we've run out of options, that is completely acceptable to me. It seems like an incredibly rare problem.

Thanks again.
Nothankyou is offline   Reply With Quote
Old 07-08-2012, 12:37 PM   #10
CdrHurricaine
 
Join Date: Jul 2012
Reputation: 0
Posts: 5
Possible Solution

I've been looking for a solution to this for a
while and none completely fixed it. I just
found one that worked 100% for me that
you might want to try:

I'm running Vista Sp3 64-bit on a laptop, and I
have the in-game settings on default,
800x600, 60 refresh rate, V-Sync on. I used
the "OpenAL32.dll" from the install after
using the newer one seemed to make it
worse. Then I opened the Psychonauts
folder and opened "AudioSettings.ini" in
notepad and changed the packet sizes and
disabled hardware acceleration. This is
what mine looks like:


[AudioSettings]
MasterVolume=1.000000
FXVolume=1.000000
MusicVolume=0.458627
VoiceVolume=1.000000
ShowSubtitles=false
HardwareAccel=false
UseEAX=false
PacketSize=850
MusicPacketSize=975
PreloadVoice=true


Once you make your changes, save it.
Lemme know if it works. If it doesn't, you
could adjust the packet size differently, or
verify the cache in Steam to restore the
default audio settings.

Edit: I also have the .exe inside the folder set to win95 compatibility, but i've heard that doesn't work in Steam. I just tested it off and on and it doesn't seem to change anything anyway.

Last edited by CdrHurricaine: 07-08-2012 at 01:00 PM.
CdrHurricaine is offline   Reply With Quote
Old 07-10-2012, 11:31 AM   #11
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Quote:
Originally Posted by CdrHurricaine View Post
I've been looking for a solution to this for a
while and none completely fixed it. I just
found one that worked 100% for me that
you might want to try:

I'm running Vista Sp3 64-bit on a laptop, and I
have the in-game settings on default,
800x600, 60 refresh rate, V-Sync on. I used
the "OpenAL32.dll" from the install after
using the newer one seemed to make it
worse. Then I opened the Psychonauts
folder and opened "AudioSettings.ini" in
notepad and changed the packet sizes and
disabled hardware acceleration. This is
what mine looks like:


[AudioSettings]
MasterVolume=1.000000
FXVolume=1.000000
MusicVolume=0.458627
VoiceVolume=1.000000
ShowSubtitles=false
HardwareAccel=false
UseEAX=false
PacketSize=850
MusicPacketSize=975
PreloadVoice=true


Once you make your changes, save it.
Lemme know if it works. If it doesn't, you
could adjust the packet size differently, or
verify the cache in Steam to restore the
default audio settings.

Edit: I also have the .exe inside the folder set to win95 compatibility, but i've heard that doesn't work in Steam. I just tested it off and on and it doesn't seem to change anything anyway.
Sorry, no effect at all.
Nothankyou is offline   Reply With Quote
Old 07-10-2012, 02:25 PM   #12
CdrHurricaine
 
Join Date: Jul 2012
Reputation: 0
Posts: 5
:(

Ah, well, worth a shot.
CdrHurricaine is offline   Reply With Quote
Old 07-11-2012, 06:48 AM   #13
Finzy
 
Join Date: Feb 2008
Reputation: 8
Posts: 220
This doesn't happen in any other games for you? I used to have a stuttering problem overall in certain sound intensive games where the game would seem to briefly "pause" and then catch up now and then, and it was caused by the power saving settings on my laptop HDD. Namely it was some WD hard drive with forced power savings, so I downloaded an app called hdparm and set advanced power management to 254 (off) with it and since then I've been able to play games fine. Might wanna do a google search for pausing hard drives to find it. (Just shooting in the dark, dunno if it would help in your case)
Finzy is offline   Reply With Quote
Old 07-22-2012, 11:14 AM   #14
Nothankyou
 
Join Date: Apr 2012
Reputation: 0
Posts: 21
Quote:
Originally Posted by Finzy View Post
This doesn't happen in any other games for you? I used to have a stuttering problem overall in certain sound intensive games where the game would seem to briefly "pause" and then catch up now and then, and it was caused by the power saving settings on my laptop HDD. Namely it was some WD hard drive with forced power savings, so I downloaded an app called hdparm and set advanced power management to 254 (off) with it and since then I've been able to play games fine. Might wanna do a google search for pausing hard drives to find it. (Just shooting in the dark, dunno if it would help in your case)
It does not happen in any other games for me. I'm able to most modern games at high settings at a steady 60frames per second. My battery settings are fine and not related to the problem.
Nothankyou is offline   Reply With Quote
Old 07-23-2012, 12:10 PM   #15
DFNathan
 
Double Fine Productions
Join Date: Dec 2011
Reputation: 169
Posts: 830
Quote:
Originally Posted by Nothankyou View Post
It does not happen in any other games for me. I'm able to most modern games at high settings at a steady 60frames per second. My battery settings are fine and not related to the problem.
The fact that it plays well after a fresh install is really suspicious. It means the game is using different settings (probably audio settings) on subsequent installs. I'd suggest you try removing the following lines from your config file and see if it behaves properly. You can also just delete this file entirely if you want to verify my assumption. Basically, the only difference between a first play and subsequent ones is the existence of this file and the settings in it.

HardwareAccel=false
UseEAX=false
PacketSize=850
MusicPacketSize=975
DFNathan is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > Psychonauts


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:49 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.