Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Tribes: Ascend

Reply
 
Thread Tools Display Modes
Old 06-27-2012, 11:52 AM   #1
quantumnerd
 
 
 
Join Date: Oct 2009
Reputation: 42
Posts: 131
Can't install: "cannot find the Hi-Rez installation"

Pretty self explanatory. Even though I've verified files, when I try to install the game through Steam I get an error box with "Hi-Rez/Steam Interface" in the window border and the error text "Cannot find the Hi-Rez installation." Since the game previously worked for me on this computer, that's definitely a Steam problem.

The install script in the game directory seems to imply that I could start the proxy installer by myself, but it seems to be somewhat dependent on being called by Steam, because it balks if I run it as administrator ("interrupted blah blah blah")

Last edited by quantumnerd: 06-27-2012 at 11:57 AM.
quantumnerd is offline  
Reply With Quote
Old 06-27-2012, 12:09 PM   #2
JonnyReLLo
 
Join Date: May 2009
Reputation: 1
Posts: 13
I'm having the same problem, I deleted my old files for Tribes Ascend from before it was on Steam, because of this steam release. When it did start up, with my old files restored, it said it was running a different service than Steam or something, then wouldn't connect to the server after getting to the game's log in screen, we need this Steam/Hi-Rez Installer problem fixed.

EDIT: Alright, I think I fixed it. If Hi-Rez is in your start bar, go to it, and select uninstall all Hi-Rez games, I did that, and tried to access it from Steam, and now it redownloaded Hi-Rez, under Steam it looks like, and now it's patching and all of that, so try it and see if it works for you.

Last edited by JonnyReLLo: 06-27-2012 at 12:14 PM. Reason: Added potential fix for error
JonnyReLLo is offline   Reply With Quote
Old 06-27-2012, 12:27 PM   #3
quantumnerd
 
 
 
Join Date: Oct 2009
Reputation: 42
Posts: 131
Deleted the stuff a while ago so that shortcut pointed to an invalid file. Deleted everything and uninstalled all of the old junk but the game is still messed. Will try poking around regedit.

Edit: no luck. All registry entries for Tribes are gone.
quantumnerd is offline   Reply With Quote
Old 06-27-2012, 12:33 PM   #4
Dark Fread
 
Join Date: Feb 2010
Reputation: 17
Posts: 102
Same problem here. I uninstalled my current non-Steam installation of T:A while (maybe a first bad idea) I was downloading it through Steam.

I noticed junk files remaining from that installation, located where Tribes was installed (D:\Games\Tribes Ascend Beta\). I manually deleted them but one required to kill a Windows service related to Hi-Rez-something. So I killed it (maybe the second bad idea).

Then, when I try to launch T:A via my Steam library, "Cannot find Hirez installation".

I'll try a reboot and a game cache checking.
Dark Fread is offline   Reply With Quote
Old 06-27-2012, 12:36 PM   #5
install gentoo
 
Join Date: Mar 2011
Reputation: 299
Posts: 1,586
RIP TRIBES #SWAG
install gentoo is offline   Reply With Quote
Old 06-27-2012, 12:43 PM   #6
JonnyReLLo
 
Join Date: May 2009
Reputation: 1
Posts: 13
Did you guys go to the Hi-Rez uninstall? In your start bar? Because after doing that it's working for me.
JonnyReLLo is offline   Reply With Quote
Old 06-27-2012, 12:46 PM   #7
quantumnerd
 
 
 
Join Date: Oct 2009
Reputation: 42
Posts: 131
Quote:
Originally Posted by JonnyReLLo View Post
Did you guys go to the Hi-Rez uninstall? In your start bar? Because after doing that it's working for me.
I removed that a while ago. Everything is gone!
quantumnerd is offline   Reply With Quote
Old 06-27-2012, 12:52 PM   #8
Dark Fread
 
Join Date: Feb 2010
Reputation: 17
Posts: 102
Quote:
Originally Posted by JonnyReLLo View Post
Did you guys go to the Hi-Rez uninstall? In your start bar? Because after doing that it's working for me.
Unfortunately I haven't such a thing.

Quote:
Originally Posted by install gentoo View Post
RIP TRIBES #SWAG
[VGQ] Quiet !
Dark Fread is offline   Reply With Quote
Old 06-27-2012, 01:21 PM   #9
SaunaChum
 
 
 
Join Date: Sep 2008
Reputation: 0
Posts: 12
You need to install InstallHirezService from Steam\steamapps\common\tribes\Binaries\Redist. Worked for me. Also I had to restart Windows once to make it say something else than "Cannot find the Hi-Rez installation."
SaunaChum is offline   Reply With Quote
Old 06-27-2012, 01:33 PM   #10
Dark Fread
 
Join Date: Feb 2010
Reputation: 17
Posts: 102
Just found a solution :

0) Uninstall non-Steam T:A (you may want to delete manually all remaining files ; killing a Hirez-related Windows service will be necessary. Windows will tell you)
1) Go to \Steam\SteamApps\common\tribes\Binaries\Redist
2) Launch InstallHirezService.exe
2') (If it displays something about updating, agree and launch it again.)
3) If it displays something about uninstalling something, agree.
4) Launch Tribes Ascend from your library.
5) Prerequisites install properly, game starts.
6) ????
7) PROFIT!
8) Repeat for infinite shazbotness.

Last edited by Dark Fread: 06-27-2012 at 01:36 PM.
Dark Fread is offline   Reply With Quote
Old 06-27-2012, 10:24 PM   #11
xjeykox
 
 
 
Join Date: Dec 2009
Reputation: 1
Posts: 108
Talking

Quote:
Originally Posted by Dark Fread View Post
Just found a solution :

0) Uninstall non-Steam T:A (you may want to delete manually all remaining files ; killing a Hirez-related Windows service will be necessary. Windows will tell you)
1) Go to \Steam\SteamApps\common\tribes\Binaries\Redist
2) Launch InstallHirezService.exe
2') (If it displays something about updating, agree and launch it again.)
3) If it displays something about uninstalling something, agree.
4) Launch Tribes Ascend from your library.
5) Prerequisites install properly, game starts.
6) ????
7) PROFIT!
8) Repeat for infinite shazbotness.
YOU ARE A ING MAGICIAN!!!
But now I have another problem. When I run the game, the launcher displays BUT a message comes up saying "The Steam version is not being run. There is an existing Hirez installation."
Then Steam ingame is disabled, and it doesn't show I am actually playing Tribes on my profile => it does not count hours played.
xjeykox is offline   Reply With Quote
Old 06-28-2012, 03:22 AM   #12
Dark Fread
 
Join Date: Feb 2010
Reputation: 17
Posts: 102
Are you sure you compeletely uninstalled the non-Steam Tribes ?
Dark Fread is offline   Reply With Quote
Old 06-28-2012, 02:36 PM   #13
PixZomb
 
 
 
Join Date: Dec 2011
Reputation: 11
Posts: 30
Dark Fread, many thanks man, problem solved!
PixZomb is offline   Reply With Quote
Old 06-29-2012, 02:43 PM   #14
Spiralz33
 
 
 
Join Date: May 2012
Reputation: 0
Posts: 1
Go to the startbar. Look for Hi-Rez. Click on Uninstall all Hi-Rez games. Now everything is working just fine
Spiralz33 is offline   Reply With Quote
Old 07-13-2012, 07:47 PM   #15
Liquid482
 
Join Date: Dec 2008
Reputation: 0
Posts: 3
Dark Fread you just saved my ! Deleting the non-steam version and getting the steam version caused a few problems but this works perfectly!
Liquid482 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Tribes: Ascend


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.