Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Tribes: Ascend

Reply
 
Thread Tools Display Modes
Old 07-21-2012, 01:18 AM   #1
pcjunior62582
 
 
 
Join Date: Dec 2011
Reputation: 5
Posts: 94
Low FPS on a good computer

Hello. Alright so, I've read all about how this game is poorly optimized and all that. I can't play this game with decent FPS without using one of those ultra low quality ini files where everything is a bunch of blocks and squares and such. Here's the problem: My computer is actually quite fast.

Specs:
i7 proc (1.7 - 2.8 GHz)
Radeon HD 5870
6 Gigs ram
Temps: Mid 60's CPU cores / High 70's GPU (while gaming)
(these are good temps for a laptop so I know it's not temp related)

I can play most modern games at ultra or near maximum settings. My roommate has a desktop that's faster than my laptop but not by much. On most games, he can play with just a slightly better FPS than me on max settings, or with other games he can run an extra setting or two that I need to disable for a smooth frame rate. On this game, he can play at maximum settings, which should mean that I should be able to play at the second highest or at least the medium setttings. I see a very, very minor improvement going to medium, but them from medium to low or minimal there is no FPS improvement.

There is no reason that I should get 20 FPS on minimal settings. It's super smooth with one of those crazy low quality custom ini files, but my computer is far, far too fast to have to deal with that 1999 quake 3 picmip lightmap whatever those settings were crap. So I'm not sure what the deal is here - anyone have any suggestions? Any help would be appreciated. I don't mind the low graphics too badly on most maps, but on one of the maps everything is just a big grey cloud and my view distance is like 2 feet in front of my face.
pcjunior62582 is offline  
Reply With Quote
Old 07-21-2012, 03:11 PM   #2
BurningBalls
 
 
 
Join Date: Jun 2012
Reputation: 110
Posts: 1,049
Something is wrong there. My graphics card is about the same as yours and I can play Tribes Ascend at 1920x1080 at medium settings and get a consistent 30-40 fps on average. Which is not really "optimized" but far better than something like Blacklight.

Maybe your processor is down-clocking itself due to Windows power settings.

Go to Control Panel -> Hardware -> Power options.... and set it to "High Performance". If that doesn't work, try updating your graphics drivers.

Quote:
Originally Posted by pcjunior62582 View Post
My roommate has a desktop that's faster than my laptop but not by much. On most games, he can play with just a slightly better FPS than me on max settings, or with other games he can run an extra setting or two that I need to disable for a smooth frame rate. On this game, he can play at maximum settings, which should mean that I should be able to play at the second highest or at least the medium setttings. I see a very, very minor improvement going to medium, but them from medium to low or minimal there is no FPS improvement.
That's what I thought. The game itself is not as optimized as I would like, but it shouldn't be as bad as you are describing. The fact that your room mate can play it on a nearly equivalent rig is further evidence that perhaps something is going wrong on your end, maybe a driver issue.

Last edited by BurningBalls: 07-21-2012 at 03:13 PM.
BurningBalls is offline   Reply With Quote
Old 07-21-2012, 03:50 PM   #3
pcjunior62582
 
 
 
Join Date: Dec 2011
Reputation: 5
Posts: 94
Hey what's up. I appreciate the response. It isn't any of my hardware settings though because all other games run great. I can play games like Mass Effect 3 pretty much maxed out in 1920x1080. It doesn't run liquid smooth but it's still good enough. But Tribes uses the unreal3 engine, correct? That engine still looks pretty good in other games even though it's an older engine, and it tends to run very well even on weaker hardware. So I'm not sure why Tribes runs so poorly using such a good engine when the graphics aren't even very good in the first place.

I could try some other drivers just to test it out, but other than that I'm not really sure what could be causing the problem. But it does certainly seem like something is wrong.
pcjunior62582 is offline   Reply With Quote
Old 07-21-2012, 04:12 PM   #4
BurningBalls
 
 
 
Join Date: Jun 2012
Reputation: 110
Posts: 1,049
Quote:
Originally Posted by pcjunior62582 View Post
Hey what's up. I appreciate the response. It isn't any of my hardware settings though because all other games run great. I can play games like Mass Effect 3 pretty much maxed out in 1920x1080. It doesn't run liquid smooth but it's still good enough. But Tribes uses the unreal3 engine, correct? That engine still looks pretty good in other games even though it's an older engine, and it tends to run very well even on weaker hardware. So I'm not sure why Tribes runs so poorly using such a good engine when the graphics aren't even very good in the first place.

I could try some other drivers just to test it out, but other than that I'm not really sure what could be causing the problem. But it does certainly seem like something is wrong.
Interestingly... Mass Effect 3, Tribes Ascend and Blacklight Retribution all run on the Unreal Engine.

ME3 runs silky smooth at maximum settings, Tribes runs alright at medium settings, Blacklight runs crap at low settings.

Just goes to show how important it is to optimize the game. Though I probably should be complaining that much since TA and BLR are both free games.

As for your graphics issue, I hope you find a solution. But your computer is powerful enough to run it at high settings, so there must be some sort of driver issue going on. I suggest trying the "high performance" setting in the power options just to eliminate it as an issue, since it applies itself randomly to different games at different times.
BurningBalls is offline   Reply With Quote
Old 07-27-2012, 11:49 AM   #5
pcjunior62582
 
 
 
Join Date: Dec 2011
Reputation: 5
Posts: 94
So, I'm still having FPS issues in this game. I've tried just about everything I can think of. Even using the 8 bit mario config that makes the game look like duke nukem 3d I still dip into the 30's in frame rate in certain spots, and that's just absolutely pathetic coding on someone's part. When I can play games that look ten times better than Tribes on maximum settings, there's just no reason for this. My roommate is having issues now too where the game freezes up for 3 to 5 seconds all the time while playing. At first, it was just on one map. Now it happens on all maps. We've tried all the solutions we could find to fix his problem to no avail. This game is just full of problems it seems. After the latest patch, tech's are having problems dropping turrets. The game won't save your settings if you turn off visor damage, and when you do turn off visor damage, your screen is left with the red taking damage haze around your screen at all times.

Now those last few things are bugs that are related to the latest patch, so I hope they get sorted out quickly. But if anyone has any suggestions for me or my roommate on the low FPS/freezing up issues I'd appreciate it, because we like the game but we're about two seconds away from uninstalling and giving up on it.
pcjunior62582 is offline   Reply With Quote
Old 07-27-2012, 12:01 PM   #6
pcjunior62582
 
 
 
Join Date: Dec 2011
Reputation: 5
Posts: 94
Also I'd like to add that it irks me that HiPatchInstaller runs constantly even when not playing the game. I did a full uninstall of the game and the patcher service and reinstalled using the "Do not run in the background" option and it still runs after I exit the game. If I force close the service, I get an error next time I try to run the game and I have to go into services to restart it since the game can't restart it for whatever reason. Absolutely pathetic programming.
pcjunior62582 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Tribes: Ascend


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.