Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Star Wars Battlefront II

Reply
 
Thread Tools Display Modes
Old 07-21-2012, 02:21 PM   #1
soundhate
 
Join Date: Jul 2012
Reputation: 0
Posts: 2
Red face Battlefront II Windows closes and returns to desktop!

Hi,

I just bought Star Wars Battlefront II.

Everything works but when I try to start a Mission it just returns to desktop and game closes.

Things I already tried:

- Turn Mic in
- turned all sounds off
- compatibility mode
- as administrator run
- windowed mode
- change graphics
- Put the battlefront II exe to work with 1 core


My System Data:

AMD Phenom X4 925 Processor 2,80 GHz
Windows 7 X64 8 GB RAM
ATI Radeon HD 5700 Series


I hope anyone can help me Greetings
soundhate is offline  
Reply With Quote
Old 07-22-2012, 10:27 AM   #2
wootlanter
 
Banned
Join Date: Feb 2010
Reputation: 19
Posts: 261
Try this:

Control panel > hardware and sound > sound > manage audio devices > recording tab > right click an open area under mic and line in > mark a tick next to show disabled devices > right click on the stereo mix icon that appears and click enable
wootlanter is offline   Reply With Quote
Old 07-23-2012, 08:25 PM   #3
d4rkl04f
 
Join Date: Jul 2010
Reputation: 0
Posts: 6
wootlanter, I was having the same problem and your solution worked for me. Thanks!
d4rkl04f is offline   Reply With Quote
Old 07-24-2012, 02:57 AM   #4
McSquigy13
 
 
 
Join Date: Jul 2012
Reputation: 0
Posts: 3
Thanks a bunch wootlander. My game is working now
McSquigy13 is offline   Reply With Quote
Old 07-24-2012, 08:59 AM   #5
soundhate
 
Join Date: Jul 2012
Reputation: 0
Posts: 2
Worked, thanks.
soundhate is offline   Reply With Quote
Old 07-24-2012, 03:25 PM   #6
wizkid5000
 
 
 
Join Date: Dec 2009
Reputation: 56
Posts: 44
Any idea how to fix it with Windows XP.... yeas... XP
wizkid5000 is offline   Reply With Quote
Old 07-25-2012, 07:38 AM   #7
wootlanter
 
Banned
Join Date: Feb 2010
Reputation: 19
Posts: 261
Quote:
Originally Posted by wizkid5000 View Post
Any idea how to fix it with Windows XP.... yeas... XP
I have XP dual booted on the same computer, and it worked straight away, even with sound "hardware" (even though it didn't work on exactly the same hardware, but with windows 7 x64 as the OS, without me doing what is described above).

Is it crashing to the desktop right as you click "new game"?

Also, in the actual star wars game, can you go to options > audio > mixer config > disabled. Does it work then?

BTW, I really think this game works better under XP than it does with 7. While it will work with 7, even after doing the workaround, I still got a crash mid game at one point that 'felt' exactly the same as the crash that occurs when you don't enable stereo mix. Playing with XP, I haven't had any crashes.

Last edited by wootlanter: 07-25-2012 at 07:44 AM.
wootlanter is offline   Reply With Quote
Old 07-25-2012, 03:14 PM   #8
JKZakamurite
 
 
 
Join Date: Jul 2012
Reputation: 0
Posts: 2
Hey all,
It looks like I'm having the exact same problem as everyone else, so I looked in sound>recording and checked the 'show disabled devices', but... no stereo mix. Anything I can do to get it on there?

Edit:
False alarm, tried the immediately above instruction and it worked.

Last edited by JKZakamurite: 07-25-2012 at 03:18 PM. Reason: Fixed Problem
JKZakamurite is offline   Reply With Quote
Old 08-11-2012, 03:06 AM   #9
MasterWarMage
 
Join Date: Jul 2012
Reputation: 0
Posts: 2
have the same problem, I'm just re-installing it and have enabled stereo mix, will see if this has worked, I will be back if it didn't
MasterWarMage is offline   Reply With Quote
Old 08-22-2012, 10:00 AM   #10
jcallsen6
 
 
 
Join Date: Aug 2012
Reputation: 0
Posts: 4
Help

Quote:
Originally Posted by wootlanter View Post
I have XP dual booted on the same computer, and it worked straight away, even with sound "hardware" (even though it didn't work on exactly the same hardware, but with windows 7 x64 as the OS, without me doing what is described above).

Is it crashing to the desktop right as you click "new game"?

Also, in the actual star wars game, can you go to options > audio > mixer config > disabled. Does it work then?

BTW, I really think this game works better under XP than it does with 7. While it will work with 7, even after doing the workaround, I still got a crash mid game at one point that 'felt' exactly the same as the crash that occurs when you don't enable stereo mix. Playing with XP, I haven't had any crashes.
I am running 7, I tried your solution and it works, I want sound though, please help, the other solution did not help because my headphones are enabled already
thanks
jcallsen6 is offline   Reply With Quote
Old 09-03-2012, 01:06 PM   #11
AWanderingFlame
 
Join Date: Feb 2010
Reputation: 1
Posts: 31
I'm running Win 7 32x
I have the same problem, but I can't get a Stereo Mix option to appear under Microphone and Line In, no matter how many times I untick and retick the box and restart.

I'll try wootlanter's in game fix, hopefully that works.

Edit: I found disabling sound and then re-enabling it after worked once, but now it doesn't work anymore. If the sound isn't off when I load a map, the game crashes, and once I'm in a map, it doesn't give me the option to re-enable sound (so I'm not sure how I did it the first time).

The headphone trick doesn't seem to work either (plugging them into the mic slot). I tried doing that at startup, and I tried leaving them in the speaker jack and plugging them back in when the game launches. So it seems the game works fine without sound.

Edit 2: I also downloaded the suggested Realtek drivers, and Stereo Mix still isn't an option.

Last edited by AWanderingFlame: 09-04-2012 at 02:26 PM.
AWanderingFlame is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Star Wars Battlefront II


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.