Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Saints Row The Third

Reply
 
Thread Tools Display Modes
Old 07-21-2012, 06:29 PM   #1
Damiuss
 
Join Date: Oct 2011
Reputation: 0
Posts: 7
Fix for Nvidia GPU users SR3

Alright guys, here is a simple fix. After doing this, most of my graphical errors and crash issues have gone away with the newer cards.

Tried this with a GTX 295 and GTX 680 so I am assuming it will work for all the cards in between.

Open your NVIDIA Control Panel at the bottom right of your screen. Should be able to pop it up from with the arrow pointing up (windows 7) on your desktop tool bar if you do not have a shortcut to it.

Or google "How to open Nvidia Control Panel".

Once you've opened it up, go to "Manage 3D settings", should be the second selection down in the 3D settings tab.

The screen on the right should now have two tabs. Global Settings and Program Settings. Select Program Settings.

You will Select Saints Row:The Third (saintsrow.exe) in the drop down list. If it's not there, select add and navigate to your Steamapps folder and select the exe from there.

Once its on there and you can select the settings from the Nvidia control panel, you will select "Anisotropic Filtering" (second selection down) and "Antialiasing - Mode" (fifth one down) and change those both to "Application Controlled".

Apply the settings (bottom right) and the game should now run with less errors. I won't say all errors are gone, but this has made the game playable.

Let me know if this helps.
Damiuss is offline  
Reply With Quote
Old 07-21-2012, 07:35 PM   #2
cyborg34573
 
Join Date: Jun 2010
Reputation: 336
Posts: 2,723
Aren't they set to application controlled to begin with?. For most Nvidia users the game pretty much works perfect out of the box. Atleast that was the case for me.

EDIT:
Just read you are having issues with your higher end cards, really odd because you shoudnt be having any issues with them. Maybe the game doesn't like your current drivers perhaps?

But idk the game works flawless for me and my brother, no crashes, no performance problems, no weird graphical glitches.


Tried with 3x GTX580's - no issues
Upgraded to 2x GTX680's - no issues
And my brother has a single GTX680 - no issues

Last edited by cyborg34573: 07-21-2012 at 07:42 PM.
cyborg34573 is offline   Reply With Quote
Old 07-21-2012, 08:59 PM   #3
Jordan94jb
 
 
 
Join Date: Jul 2011
Reputation: 39
Posts: 391
What 'issues' does this supposedly fix?
Jordan94jb is offline   Reply With Quote
Old 07-21-2012, 10:15 PM   #4
Damiuss
 
Join Date: Oct 2011
Reputation: 0
Posts: 7
Cyborg, they weren't on mine. Mine was set to the default which was "Use Global Settings".


Jordan, Issues where the character doesn't render correctly in DX 10/11. Also, The game will lag then come to a freeze in between scenes. Explosions will not show up, neither will lasers, fire, smoke and a plethora of other things.

So I found something that worked for me and decided to share it with others. Had I not changed cards and stuck to my 8800 I would doubt that others were having issues since it was running so well on an older card, but having experienced this with newer cards, and messing with the settings, I was able to get great results.

Unfortunately there thousands of possible builds with PCs (and that's being conservative) so some will work flawlessly and others, unfortunately will not be so lucky, as has been posted recently on this forum.

Knowing the limitations of the written word though, I'll just record it with fraps and post it as soon as I clip it together so you can see what it is that I am experiencing and the difference of how tweaking those settings changes them since it's easier to show than to explain since it can be tough to picture an issue if you aren't experiencing it.

Once I've done that, I'll post the vids to YouTube and post the links here, to better explain.

Last edited by Damiuss: 07-21-2012 at 10:17 PM.
Damiuss is offline   Reply With Quote
Old 07-21-2012, 11:27 PM   #5
Booke
 
Join Date: Jul 2011
Reputation: 52
Posts: 494
Quote:
Originally Posted by Damiuss View Post
Cyborg, they weren't on mine. Mine was set to the default which was "Use Global Settings".
Any chance you changed the default global values for AA to something other than off? My default global settings are set to off, and have been for as far as I remember.
Booke is offline   Reply With Quote
Old 07-22-2012, 01:49 AM   #6
Damiuss
 
Join Date: Oct 2011
Reputation: 0
Posts: 7
Quote:
Originally Posted by Booke View Post
Any chance you changed the default global values for AA to something other than off? My default global settings are set to off, and have been for as far as I remember.
Not at all, I did a clean install for the drivers, control panel, etc. I was thinking about that myself, I actually racked by brain a little trying to figure out what I could have messed with, when I realized that it was a fresh install with no saved settings.

Anyhow, here is a link to the vid showing how it looked before I changed these settings.

Address, in case the link is not visible or you prefer to cut and paste: http://www.youtube.com/watch?v=Or0XjuzoaRs

I zoomed in a bit, not enough though, but you can get the gist of things. You will see the rendering around the skin is really off, my writhes in pain (as when flames engulf your character), but you can't see the flames around him after an explosion (you also don't see them on the cars) and you won't see any lasers coming out of the laser weapons.

After changing the settings though, everything worked as intended.
Damiuss is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Saints Row The Third


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.