Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Hitman series

Reply
 
Thread Tools Display Modes
Old 08-13-2012, 10:07 AM   #1
haraldp
 
 
 
Join Date: Aug 2012
Reputation: 0
Posts: 1
Angry Hitman Absolution and Sniper Challenge not for Windows XP

While trying to run Sniper Challenge from Steam it quietly exits. If I try to run it directly I get a popup with:

Quote:
This application has failed to start because dxgi.dll was not found. Re-installing the application may fix this problem.
After a reinstall just to be on the safe side I contacted Square Enix, detailing the problem and my system setup (Core2Duo, 3GHz, Windows XP, GeForce 9800 GTX) and I got this reply back:

Quote:
We are sorry that you are unable to run Hitman Sniper Challenge on your computer.

Unfortunately your system does not meet the minimum requirements, these are:

CPU: 2.4 GHz dual core Intel or AMD processor
RAM: 1GB of system memory
Graphics: DirectX 10 compatible card with 512 MB RAM. Nvidia 8-series or AMD Radeon 3000 series graphics cards.
Operating system: Windows Vista
DirectX compatible sound card
10 GB of hard drive space

We do not yet have the minimum requirements for Hitman Absoultion confirmed, but would expect them to be at least the same as those for Hitman Sniper Challenge. We would therefore advise you to either upgrade your sytem or cancel your pre-order and get a refund from your retailer.
Now, I am not a game developer, but I thought that most games were backwards-compatible with DirectX 9. Googling dxgi.dll tells me that this problem has also been with Ghost Recon: Future Soldier, and they apparently fixed it with a patch, so I can't see why not the new Hitman games shouldn't work on Windows XP. Sure, it may not be as pretty, but it should be playable!

Even more confusing is that XBox360 doesn't have DirectX 10, so if it's the same codebuild they should already have DirectX 9 support there.

Yes I know that XP is old, but it's officially supported until 2014 and according to Steam hardware survey XP still has a 14% userbase. That's 1 in 7 users.

Depending on the effort involved in supporting DirectX 9, is it worth it to turn down 1 out of 7 customers? Don't you want my money?

Well, I guess they already got my money as I preordered.

It just bugs me even more that none of the retailers and none of the official webpages list "Vista and above" as a requirement.
haraldp is offline  
Reply With Quote
Old 09-14-2012, 09:25 AM   #2
InnocentSam
 
 
 
Join Date: Jun 2010
Reputation: 46
Posts: 49
Yes, most websites won't say Vista+ only because it's sort-of a new thing.

And you've got it slightly backwards, Hitman Sniper Challenge supports only DX10+, and XP only supports DX9 and below. Vista and 7 are backwards compatible with DX9 and below, as well as DX10+.
InnocentSam is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > H - L > Hitman series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.