Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls

Reply
 
Thread Tools Display Modes
Old 08-24-2012, 04:09 PM   #1
PhilDogTheMan
 
Join Date: May 2010
Reputation: 4
Posts: 25
AMD Performance Fix

So the reason us AMD guys aren't getting along with the game too well is because our cards aren't deciding to kick into full throttle and are just running at idle speeds.

Here's how to fix that:

1. Open CCC
2. Click "Performance" -> "Overdrive" on the side bar
3. Tick "Enable Graphics Overdrive"
4. Click "Presets" on the side bar
5. Click "Add Preset"
6. Name it "Default" then save
7. Do same again but call this one "Dark Souls"
8. Navigate to C:\Users\*yourusername*\AppData\Local\ATI\ACE\Prof iles
9. Open the Dark Souls file in notepad.

You should see something like this:

<Feature name="CoreClockTarget_PCI_VEN_1002&amp;DEV_6798&am p;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp;0& amp;0018A">
<Property name="Want_0" value="30000" />
<Property name="Want_1" value="112500" />
</Feature>
<Feature name="MemoryClockTarget_PCI_VEN_1002&amp;DEV_6798& amp;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp; 0&amp;0018A">
<Property name="Want_0" value="15000" />
<Property name="Want_1" value="157500" />
</Feature>
<Feature name="CoreVoltageTarget_PCI_VEN_1002&amp;DEV_6798& amp;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp; 0&amp;0018A">
<Property name="Want_0" value="850" />
<Property name="Want_1" value="1170" />


"CoreClockTarget", "MemoryClockTarget" and "CoreVoltageTarget"

are what we are interested in, forget about all the rest of it for now.

The "Want_1" lines values are essentially what value CCC is going to use when you enable overdrive (it has a couple of extra 0s on the notepad values than in CCC). If you haven't played with overdrive before these should be your stock clocks and voltage (!THESE WILL BE DIFFERENT DEPENDING ON GFX CARD DON'T TRY TO COPY MINE ABOVE!). If you have played with it before then you will understand what you are looking at. These Relate to the sliders in CCC.

The "Want_0" lines are what you gfx card downclocks to at idle, and is currently what Dark Souls is using when you play it. So what we are going to do is change the "Want_0" values to match the "Want_1" values so that it forces itself to only use those speeds and voltage with this preset selected.

So in my case my page now looks like this

<Feature name="CoreClockTarget_PCI_VEN_1002&amp;DEV_6798&am p;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp;0& amp;0018A">
<Property name="Want_0" value="112500" />
<Property name="Want_1" value="112500" />
</Feature>
<Feature name="MemoryClockTarget_PCI_VEN_1002&amp;DEV_6798& amp;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp; 0&amp;0018A">
<Property name="Want_0" value="157500" />
<Property name="Want_1" value="157500" />
</Feature>
<Feature name="CoreVoltageTarget_PCI_VEN_1002&amp;DEV_6798& amp;SUBSYS_32111682&amp;REV_00_4&amp;2F1C4782&amp; 0&amp;0018A">
<Property name="Want_0" value="1170" />
<Property name="Want_1" value="1170" />

See how I have matched the values?

Now save the file and you're done!

HOW TO PLAY FIXED DARK SOULS:

Launch CCC and press your "Dark Souls" Preset.

Tick "Enable Graphics Overdrive" if its not already, and click "Apply". You should find that the dials in CCC now correspond to the values you entered! This means no more idling and you can enjoy dark souls properly.

When you are finished gaming just remember to untick "Enable Graphics Overdrive" and select the "Default" Preset we created earlier to put your overclocking options back to how they were.

Enjoy!

Last edited by PhilDogTheMan: 08-24-2012 at 04:30 PM.
PhilDogTheMan is offline  
Reply With Quote
Old 08-24-2012, 04:11 PM   #2
kpsnnf
 
Join Date: Feb 2010
Reputation: 67
Posts: 688
hesitant to try this.. i will wait for others input before fiddling
kpsnnf is offline   Reply With Quote
Old 08-24-2012, 04:14 PM   #3
vocalist
 
 
 
Join Date: Jun 2012
Reputation: 41
Posts: 954
stupid question. what is CCC?
vocalist is offline   Reply With Quote
Old 08-24-2012, 04:15 PM   #4
SrgColman
 
 
 
Join Date: Jul 2011
Reputation: 12
Posts: 135
Quote:
Originally Posted by vocalist View Post
stupid question. what is CCC?
Catalyst Control Center
SrgColman is offline   Reply With Quote
Old 08-24-2012, 04:15 PM   #5
koolaidlips
 
Join Date: Aug 2012
Reputation: 24
Posts: 283
I'll wait till someone tries this.
koolaidlips is offline   Reply With Quote
Old 08-24-2012, 04:16 PM   #6
Sifer2
 
Join Date: Nov 2007
Reputation: 225
Posts: 3,785
It is amusing that the game is still as playable as on console at idle speeds lol.
Sifer2 is offline   Reply With Quote
Old 08-24-2012, 04:17 PM   #7
kpsnnf
 
Join Date: Feb 2010
Reputation: 67
Posts: 688
for some it is, sifer, but i think this is the issue im having.. game is running at extremely low fps, the other "fixes" dont work, for some they do.. but none worked for me..
kpsnnf is offline   Reply With Quote
Old 08-24-2012, 04:18 PM   #8
acidburn1942
 
Join Date: Dec 2009
Reputation: 28
Posts: 156
attempting now
acidburn1942 is offline   Reply With Quote
Old 08-24-2012, 04:20 PM   #9
Teh_Barbarian
 
 
 
Join Date: Nov 2011
Reputation: 25
Posts: 303
Quote:
Originally Posted by vocalist View Post
stupid question. what is CCC?
Catalyst Control Center
Teh_Barbarian is offline   Reply With Quote
Old 08-24-2012, 04:20 PM   #10
acidburn1942
 
Join Date: Dec 2009
Reputation: 28
Posts: 156
didnt change anything for me, I still get 15FPS locked when I look in specific direction, then it bumps straight back up to 30 when im not.
acidburn1942 is offline   Reply With Quote
Old 08-24-2012, 04:23 PM   #11
koolaidlips
 
Join Date: Aug 2012
Reputation: 24
Posts: 283
Quote:
Originally Posted by acidburn1942 View Post
didnt change anything for me, I still get 15FPS locked when I look in specific direction, then it bumps straight back up to 30 when im not.
Damn it
koolaidlips is offline   Reply With Quote
Old 08-24-2012, 04:24 PM   #12
acidburn1942
 
Join Date: Dec 2009
Reputation: 28
Posts: 156
Quote:
Originally Posted by koolaidlips View Post
Damn it
yup......at this point Im just waiting for a response from From or ATI on the issue. but ill keep trying any new fixes while they come out.
acidburn1942 is offline   Reply With Quote
Old 08-24-2012, 04:25 PM   #13
kpsnnf
 
Join Date: Feb 2010
Reputation: 67
Posts: 688
tried, didnt help me either, didnt change a thing, game still incredibly sluggish

already ticketed for a refund, when we asked for a port, this isnt what we meant..
kpsnnf is offline   Reply With Quote
Old 08-24-2012, 04:28 PM   #14
PhilDogTheMan
 
Join Date: May 2010
Reputation: 4
Posts: 25
Looks like some of you guys are experiencing different issues to what I was. My game was just running incredibly badly until I did this.
PhilDogTheMan is offline   Reply With Quote
Old 08-24-2012, 04:30 PM   #15
koolaidlips
 
Join Date: Aug 2012
Reputation: 24
Posts: 283
Quote:
Originally Posted by PhilDogTheMan View Post
Looks like some of you guys are experiencing different issues to what I was. My game was just running incredibly badly until I did this.
What's your card? Maybe I'll try it.
koolaidlips is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.