Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls

Reply
 
Thread Tools Display Modes
Old 08-24-2012, 05:11 PM   #1
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Exclamation GFWL not using UPnP even if you have it enabled? Look here.

!PLEASE NOTE! - This thread was only meant for those people out there who have experienced the same problem I have, which is specifically that GFWL will not create an IGD through UPnP to accept incoming connections even though UPnP is properly enabled and configured on your router and computer. I have added extra steps to help people make sure that UPnP is properly configured for them in the case that the last and most important step does not get it working. If GFWL already shows your NAT as being open, whether or not UPnP is enabled, then your system and network is already properly configured for GFWL online gameplay.

This has been driving me nuts for a long time. It didn't bother me much in the past because nearly all the games I played with GFWL were single player. With Dark Souls, however, the online features are an integral part of the game and should be taken advantage of for the full experience.

So anyway, I have UPnP enabled both on my computer and router, and every game I play that doesn't use GFWL was able to create an IGD and forward the required ports. However, when connecting to GFWL, opening the console ("Home" or "Guide" key), going all the way right to "Settings," and clicking "Network Information," it would report that my NAT is Strict and that "UPnP is available, not used." Why in the hell was it not used?

Anyway, after looking around everywhere, I finally stumbled on to a way to make GFWL use UPnP. These directions are for Windows Vista, but it should be very similar to Windows 7.

DISCLAIMER: If you're using a third party firewall I cannot guarantee that my instructions will work for you. My router is a Belkin N300 Wireless Router with 802.11g&n support. My PC is connected to the router with a Cat5e LAN cable.

Network Discovery Control Panel
First, make sure Network Discovery is enabled by going to Control Panel -> Network and Sharing center. If none of the radio buttons are enabled, that's okay. Before turning it on, however, click on Change settings next to Workgroup. In the new window, click the "Network ID..." button and make sure the radio button for "This is a home computer..." is enabled and click next. You will have to restart your computer. Go back to the Control Panel window mentioned earlier, enable the "Turn on network discovery" radio button under Network discovery and click Apply.

Windows Services interface
Next, if you're not sure UPnP is turned on on your PC, press Windows+R on your keyboard (or Start and start search), type "services.msc" and press enter. Sort the list by name and scroll down to "Network Location Awareness," "SSDP Discovery," and "UPnP Device Host." If they say Automatic or Manual in the Startup Type column, then you're good. If not, right-click on each of these, click Properties, and change the "Startup type" listbox to Manual or Automatic and start the service if not already started.

Windows Firewall Control Panel
This next step is optional, but ensures the ports are being forwarded through the Windows firewall if you have it enabled. Go back to Control Panel -> Network and Sharing Center, click "Windows Firewall" on the bottom-left under "See also." In the new window click "Allow a program through Windows Firewall" on the right. Then click the "Add port..." button and add each of the required ports one-by-one for each port type, even if it's the same number. I will list the ports at the bottom of this post.

If you don't have the option to add a port, check to see if there are already exceptions for "Dark Souls: Prepare to Die Edition" and "Games for Windows Marketplace." If not, add an exception for "DARKSOULS.exe," "DATA.exe," "GFWLive.exe," and "GFWLClient.exe." These are located in "..\SteamApps\common\Dark Souls Prepare to Die Edition\DATA" and "x:\Program Files (x86)\Microsoft Games for Windows - LIVE\Client," respectively. Replace 'x' with your drive letter and/or remove "(x86)" if you're running a 32-bit version of Windows.

Port-forwarding Belkin example
UPnP enabling Belkin example
To ensure UPnP works properly on your router, you need to clear the port forwarding list on it if you've added one. This is called "Virtual Servers" on my router. Look up how to do this if you're not sure, as all routers are different. This is important for UPnP to function because your router can get confused when both port forwarding and UPnP are used at the same time. Some places on the web tell you to do both on your router, but this is wrong. You only need to tell the operating system which specific ports are allowed and need to be forwarded. Make sure UPnP is also enabled while you're doing this on your router.

Where to find your router in Windows Explorer
Now the most important step follows. Open Windows Explorer by either using the "My Computer" shortcut or pressing Windows+E on your keyboard. In the left pane, click the Network tree. If you've followed the first two steps your router should show up in the right pane. Right-click on your router and click Properties. Click the "Settings..." button in the "General" tab. The window that appears should have a "Services" tab that may be populated with the ports that you forwarded in your router before clearing the list. Ah, now we're getting somewhere! Now you have to add each individual port in the same way I described in the Windows firewall step.

!IMPORTANT! - You may have to repeat the above step every time you restart your computer. Unfortunately I don't know of a way to make the settings stick.

After you have done all of this, the GFWL console should now say your NAT is Open and that UPnP is both available and in use! If your NAT is moderate, but it still says UPnP is in use, you're still good.

The following ports are required for P2P connections to work when connected to GFWL:
  • 53, TCP & UDP - DNS resolution, GFWL uses to resolve P2P connections
  • 80, TCP - Internet
  • 88, UDP - Internet
  • 443, TCP - HTTPS, GFWL uses for voice communication and Live logon
  • 3074, TCP & UDP - GFWL P2P communication
Remember that when you add these ports to your Windows firewall and router in Windows Explorer, you need to add each port type for the same number! So for example, you need separate entries for both TCP 53 and UDP 53.

Depending on how your computer is configured you may only need to open ports 3074 TCP & UDP. If GFWL does not show it using UPnP with just these ports open, then you can try adding the others to your router in Windows Explorer.

I hope this works for anyone looking here. Everywhere I searched on the internet never led to the right result. They never mention the last step in my instructions, which in my experience was the key to finally get it working.

Last edited by Armenius: 09-10-2012 at 05:36 PM. Reason: Added a disclaimer; Added details on what the ports are used for; Added images for example; Added note to last step
Armenius is offline  
Reply With Quote
Old 08-24-2012, 09:31 PM   #2
xrisrobin
 
 
 
Join Date: Jan 2012
Reputation: 0
Posts: 11
Holy crap. I haven't been able to fix this no matter what I did until now. Thanks man, finally got UPnP working and an open NAT.
xrisrobin is offline   Reply With Quote
Old 08-25-2012, 09:47 AM   #3
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Glad I could help! It was maddening, wasn't it?
Armenius is offline   Reply With Quote
Old 08-25-2012, 09:55 AM   #4
deltaxxmintpie
 
Join Date: Aug 2012
Reputation: 15
Posts: 171
Can a mod make this a sticky please. Also Armenius go post this in General FAQ thread and PM freyar so that more people are aware of this fix. Even better spread it around on darksouls official forums and NeoGaf you'll help a tons of people
deltaxxmintpie is offline   Reply With Quote
Old 08-25-2012, 10:01 AM   #5
puppymang
 
Join Date: Jul 2011
Reputation: 3
Posts: 106
how come my NAT says moderate?
puppymang is offline   Reply With Quote
Old 08-25-2012, 10:44 AM   #6
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Quote:
Originally Posted by puppymang View Post
how come my NAT says moderate?
You should be fine if your NAT is moderate. If the Network Settings in the GFWL console says "UPnP is available, in use" you should be able to connect to others just fine because the ports are being forwarded correctly.
Armenius is offline   Reply With Quote
Old 08-25-2012, 10:52 AM   #7
puppymang
 
Join Date: Jul 2011
Reputation: 3
Posts: 106
Quote:
Originally Posted by Armenius View Post
You should be fine if your NAT is moderate. If the Network Settings in the GFWL console says "UPnP is available, in use" you should be able to connect to others just fine because the ports are being forwarded correctly.

i was just curious, thought maybe that would improve connection because im already able to connect and get invaded/coop but getting lag stabbed ing sucks
puppymang is offline   Reply With Quote
Old 08-25-2012, 10:54 AM   #8
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Quote:
Originally Posted by puppymang View Post
i was just curious, thought maybe that would improve connection because im already able to connect and get invaded/coop but getting lag stabbed ing sucks
Yes, it does suck, but unfortunately this is an issue with the networking code in the game itself.
Armenius is offline   Reply With Quote
Old 08-25-2012, 12:07 PM   #9
Kythis
 
Join Date: Jan 2009
Reputation: 7
Posts: 39
I've forwarded my ports. Can't find a way to do that through Firewall though. Have my uPnP enabled through my router and even have it DMZ'd. Was Open earlier (NAT) and now I'm back to Moderate. Can't see any messages or signs and can't even play with friends. Very annoying. Might as well chalk it up to GFWL being useless.
Kythis is offline   Reply With Quote
Old 08-25-2012, 12:09 PM   #10
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Quote:
Originally Posted by Kythis View Post
I've forwarded my ports. Can't find a way to do that through Firewall though. Have my uPnP enabled through my router and even have it DMZ'd. Was Open earlier (NAT) and now I'm back to Moderate. Can't see any messages or signs and can't even play with friends. Very annoying. Might as well chalk it up to GFWL being useless.
Replied to the other thread you posted in. I think it's a From server problem, not necessarily a GFWL or client problem. They may not have expected so many people playing the game on PC.
Armenius is offline   Reply With Quote
Old 08-25-2012, 12:16 PM   #11
Kythis
 
Join Date: Jan 2009
Reputation: 7
Posts: 39
Quote:
Originally Posted by Armenius View Post
Replied to the other thread you posted in. I think it's a From server problem, not necessarily a GFWL or client problem. They may not have expected so many people playing the game on PC.
I hope so. Sucks to sit in skype hearing my friends playing together and I can't even see a single message, much less a sign.
Kythis is offline   Reply With Quote
Old 08-25-2012, 12:22 PM   #12
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
I read somewhere else that a person had to wait 10-20 minutes for the server to catch up to them and they were finally able to see summon signs :/
Armenius is offline   Reply With Quote
Old 08-25-2012, 12:25 PM   #13
shroompants
 
Join Date: Jul 2010
Reputation: 0
Posts: 6
I'm using a Verison 9100 em router, and I followed all your instructions as best as I could and GFWL still says uPnP available but not used.
shroompants is offline   Reply With Quote
Old 08-25-2012, 12:27 PM   #14
Armenius
 
Join Date: Nov 2010
Reputation: 88
Posts: 371
Quote:
Originally Posted by shroompants View Post
I'm using a Verison 9100 em router, and I followed all your instructions as best as I could and GFWL still says uPnP available but not used.
If you're using a third party firewall I cannot guarantee that my instructions will work for you. If you're not using a third-party firewall, you may have to upgrade your router's firmware if there is one available.
Armenius is offline   Reply With Quote
Old 08-25-2012, 12:30 PM   #15
Kythis
 
Join Date: Jan 2009
Reputation: 7
Posts: 39
Quote:
Originally Posted by Armenius View Post
I read somewhere else that a person had to wait 10-20 minutes for the server to catch up to them and they were finally able to see summon signs :/
Huh. What do you mean by catch up to them? Sounds odd.
Kythis is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 10:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.