Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls

Reply
 
Thread Tools Display Modes
Old 08-29-2012, 02:46 PM   #1
lukasaurus
 
Join Date: Nov 2010
Reputation: 4
Posts: 69
Adding ports to firewall in Windows 7 - solved

There is another thread about this, but the guide is for XP/Vista and some people were getting frustrated, because W7 doesn't have the option to add ports to the firewall.

GFWL seems to ignore any port forwarding on your router and looks at the firewall settings.

So, for this to work, you need to have BOTH your router set up to forward the ports AND Windows firewall.

And through a quick google search, I found a great link to add ports to Windows 7 firewall

http://www.dummies.com/how-to/conten...-firewall.html

Follow that and add in the appropriate ports for GFWL

The TCP ports are 80, 3074, 53, 443 (you can type them in with a comma)
the UDP ports are 3074, 88, 53

Unlike most routers, you can't select TCP & UDP at the same time with windows firewall, so you need to make two new rules. I called one GFWL Dark Souls TCP and the other GFWL Dark Souls UDP.


Now my in game network settings say that uPnP is enabled and that NAT is open. Finally. Now, if only everyone else would do the same thing I might be able to summon & invade them!
lukasaurus is offline  
Reply With Quote
Old 08-29-2012, 02:47 PM   #2
vacao747
 
 
 
Join Date: Jul 2012
Reputation: 0
Posts: 29
What if we just disable firewall:
vacao747 is offline   Reply With Quote
Old 08-29-2012, 02:48 PM   #3
stalkerhelp
 
Join Date: Jul 2012
Reputation: 61
Posts: 308
Quote:
Originally Posted by lukasaurus View Post
There is another thread about this, but the guide is for XP/Vista and some people were getting frustrated, because W7 doesn't have the option to add ports to the firewall.

GFWL seems to ignore any port forwarding on your router and looks at the firewall settings.

So, for this to work, you need to have BOTH your router set up to forward the ports AND Windows firewall.

And through a quick google search, I found a great link to add ports to Windows 7 firewall

http://www.dummies.com/how-to/conten...-firewall.html

Follow that and add in the appropriate ports for GFWL

The TCP ports are 80, 3074, 53, 443 (you can type them in with a comma)
the UDP ports are 3074, 88, 53

Unlike most routers, you can't select TCP & UDP at the same time with windows firewall, so you need to make two new rules. I called one GFWL Dark Souls TCP and the other GFWL Dark Souls UDP.


Now my in game network settings say that uPnP is enabled and that NAT is open. Finally. Now, if only everyone else would do the same thing I might be able to summon & invade them!
I appreciate both your threads, but "GFWL seems to ignore any port forwarding on your router and looks at the firewall settings" that's false.

I only have a router which acts a hardware firewall, and GFWL is running at NAT open.

1st Router (bridge) -> 2nd router (NAT-proper ports forwarded) --> game = NAT OPEN
stalkerhelp is offline   Reply With Quote
Old 08-29-2012, 02:48 PM   #4
lukasaurus
 
Join Date: Nov 2010
Reputation: 4
Posts: 69
That might work, but it isn't recommended. I didn't try. I do know the above works and I still have my firewall up.
lukasaurus is offline   Reply With Quote
Old 08-29-2012, 02:50 PM   #5
lukasaurus
 
Join Date: Nov 2010
Reputation: 4
Posts: 69
Quote:
Originally Posted by stalkerhelp View Post
I appreciate both your threads, but "GFWL seems to ignore any port forwarding on your router and looks at the firewall settings" that's false.

I only have a router which acts a hardware firewall, and GFWL is running at NAT open.

1st Router (bridge) -> 2nd router (NAT-proper ports forwarded) --> game = NAT OPEN
That's great for you, but this was for people who were having issues with Windows 7 firewall. You aren't using it
lukasaurus is offline   Reply With Quote
Old 08-29-2012, 02:52 PM   #6
stalkerhelp
 
Join Date: Jul 2012
Reputation: 61
Posts: 308
Quote:
Originally Posted by lukasaurus View Post
That's great for you, but this was for people who were having issues with Windows 7 firewall. You aren't using it
Oh sorry, didn't read it was aimed at windows firewall.

Thanks for your threads! Someone should stick both your threads.
stalkerhelp is offline   Reply With Quote
Old 08-31-2012, 08:54 AM   #7
amaranty
 
 
 
Join Date: Nov 2011
Reputation: 0
Posts: 117
Doesn't work for some reason. I followed the guide and opened the ports in windows firewall and also in my router. I added a profile to Dark Souls in my router and added the ports.

Game still says uPnP available, not used and NAT is on strict.
amaranty is offline   Reply With Quote
Old 08-31-2012, 08:59 AM   #8
Kyorisu
 
 
 
Join Date: Jun 2006
Reputation: 274
Posts: 2,160
If you're behind NAT you really don't need a software firewall running. If you are directly connected via a modem then yes by all means run a firewall.
Kyorisu is offline   Reply With Quote
Old 08-31-2012, 09:11 AM   #9
amaranty
 
 
 
Join Date: Nov 2011
Reputation: 0
Posts: 117
I'm not very smart considering routers and port forwardings and whatever NAT and uPnP actually mean.

I thought I could get NAT and uPnP working if I do the port forwarding but it seems my only option is to activate SSDP discovery and uPnP services in Windows.
amaranty is offline   Reply With Quote
Old 08-31-2012, 09:14 AM   #10
monoculo_jim
 
Join Date: Jul 2010
Reputation: 0
Posts: 6
Quote:
Originally Posted by amaranty View Post
Doesn't work for some reason. I followed the guide and opened the ports in windows firewall and also in my router. I added a profile to Dark Souls in my router and added the ports.

Game still says uPnP available, not used and NAT is on strict.
If you have uPnP enabled in your router, you may need to disable it. Some routers don't play nice if you use uPnP and forward ports at the same time.
monoculo_jim is offline   Reply With Quote
Old 08-31-2012, 09:17 AM   #11
amaranty
 
 
 
Join Date: Nov 2011
Reputation: 0
Posts: 117
Quote:
Originally Posted by monoculo_jim View Post
If you have uPnP enabled in your router, you may need to disable it. Some routers don't play nice if you use uPnP and forward ports at the same time.
I have it disabled. I just tried using this site to check my ports: http://www.yougetsignal.com

All of the ports listed in this thread are closed. I disabled my Windows Firewall and they were still closed, so I am guessing the problem is coming from my router.

EDIT: Just called my internet provider, they told me that port forwarding is disabled. They will allow me to forward ports tomorrow.

Asked them why was it disabled, they told me that not everyone needs to open ports. Funny stuff, considering all ports are closed anyways unless you yourself, the administrator, allows them.

Last edited by amaranty: 08-31-2012 at 09:32 AM.
amaranty is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.