Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls

Reply
 
Thread Tools Display Modes
Old 08-31-2012, 02:25 PM   #1
hb.
 
Join Date: Jan 2009
Reputation: 1
Posts: 21
Broken stereo in Dark Souls

first off

http://www.youtube.com/watch?v=U6aVNwIMCbY&
http://www.youtube.com/watch?v=7oHeBXR0lNI


Does anybody know how to solve this problem (get normal stereo) on realtek hd audio? I could not find myself any way to downmix 5.1 to stereo as was suggested in description to second video .

Last edited by hb.: 09-01-2012 at 12:37 AM. Reason: title typo
hb. is offline  
Reply With Quote
Old 09-01-2012, 12:35 AM   #2
hb.
 
Join Date: Jan 2009
Reputation: 1
Posts: 21
another GREAT comparison of the problem that AFFECTS EVERYONE
http://www.youtube.com/watch?v=ku1ZBwB7Ghs
hb. is offline   Reply With Quote
Old 09-01-2012, 06:50 AM   #3
rojimboo
 
Join Date: Feb 2012
Reputation: 52
Posts: 494
I can confirm this doesn't happen for X-fi users with this tweak

Tweaks

Quote:
•Better sound for X-fi users:
Use Creative Alchemy after setting data.exe to windows xp (sp3) compatibility. This should force FMOD to use Directsound calls which are snatched up by Alchemy and sent to the sound card. Note, this is by no means verified so it is up to individual users to note any difference. It did work in WOW:

http://blog.k1dblitz.com/2010/12/wor...to-enable.html

Personally, I noticed an improvement in positional sound, with no side-effects.
And also setting 5.1 in Windows Sound settings, and downmix it to headphones/stereo with your soundcard via Creative Control panel.

This issue was the reason I looked into it as without music AND positional sound, it was pretty boring to play.

Edit: Actually the downmixing is the key here - the Alchemy tweak just improves some of the effects like reverb.
rojimboo is offline   Reply With Quote
Old 09-01-2012, 07:09 AM   #4
Mr. Death
 
 
 
Join Date: Sep 2006
Reputation: 0
Posts: 41
Quote:
Originally Posted by rojimboo View Post

And also setting 5.1 in Windows Sound settings, and downmix it to headphones/stereo with your soundcard via Creative Control panel.

This issue was the reason I looked into it as without music AND positional sound, it was pretty boring to play.

Edit: Actually the downmixing is the key here - the Alchemy tweak just improves some of the effects like reverb.
Will doing this affect anything else like watching videos or playing other games?
Mr. Death is offline   Reply With Quote
Old 09-01-2012, 07:23 AM   #5
rojimboo
 
Join Date: Feb 2012
Reputation: 52
Posts: 494
Quote:
Originally Posted by Mr. Death View Post
Will doing this affect anything else like watching videos or playing other games?
Well, the Alchemy tweak is specific for each game.

The downmixing - it depends. I think for any program that takes its que from the windows speaker settings, then yes it will attempt to output 5.1 and your soundcard (if you set it up in Creative Control panel) downmixes it to stereo. For headphones, it's not too much of an issue, but if you have stereo, and are watching a blu-ray or dvd the effect might not be optimal, certainly not as intended by the sound directors. This wouldn't affect music of course.

But if it is a codec video and you are using one of the codec packs that say include ffdshow, then you have the option (or are forced to) downmix it. Many movies come with 5.1 compressed audio only.

At the end of the day, it is a bit subjective and you should experiment with downmixing and see if you prefer it to proper stereo, left and right. Personally, with my headphones I prefer downmixing movies as it gives me a pseudo surround effect without losing too much fidelity.
rojimboo is offline   Reply With Quote
Old 09-01-2012, 08:18 AM   #6
TheManko
 
Join Date: Aug 2012
Reputation: 1
Posts: 1
I made those videos and I'm glad to see them linked here!

To work around the problem with Asus cards it's pretty simple. All of their internal sound cards, even the very cheapest ones, have downmixing controls on the first page of their driver settings. There are two drop down menus, the top one controls what Windows and all software believes you have and the bottom one controls output. Set the top one to 5.1 and the bottom one to stereo and you'll get 5.1 downmixing like in the videos.

If you've got a surround receiver with hdmi input you can use that to downmix as well, as you'll set Windows to 5.1 and then the receiver will downmix the signal to whatever your speaker setup is.
TheManko is offline   Reply With Quote
Old 09-01-2012, 08:32 AM   #7
Mr. Death
 
 
 
Join Date: Sep 2006
Reputation: 0
Posts: 41
Quote:
Originally Posted by rojimboo View Post
Well, the Alchemy tweak is specific for each game.

The downmixing - it depends. I think for any program that takes its que from the windows speaker settings, then yes it will attempt to output 5.1 and your soundcard (if you set it up in Creative Control panel) downmixes it to stereo. For headphones, it's not too much of an issue, but if you have stereo, and are watching a blu-ray or dvd the effect might not be optimal, certainly not as intended by the sound directors. This wouldn't affect music of course.

But if it is a codec video and you are using one of the codec packs that say include ffdshow, then you have the option (or are forced to) downmix it. Many movies come with 5.1 compressed audio only.

At the end of the day, it is a bit subjective and you should experiment with downmixing and see if you prefer it to proper stereo, left and right. Personally, with my headphones I prefer downmixing movies as it gives me a pseudo surround effect without losing too much fidelity.
Thanks, I was more concerned with the downmixing stuff if it was going to make other games/videos sound awkward or quiet or just messed up in general. I just set the Windows Speakers setting to 5.1 while leaving my creative card to output in 2.1/2 and man, does the game sound a lot better now instead of being muted.

edit: Watching a youtube video with the above settings makes the audio sound a bit, without knowing the better terms for it, a bit scratchy and "not clear".

Last edited by Mr. Death: 09-01-2012 at 08:35 AM.
Mr. Death is offline   Reply With Quote
Old 09-01-2012, 01:46 PM   #8
Anima3
 
Join Date: May 2010
Reputation: 1
Posts: 22
I'm unable to downmix from 5.1 to stereo on my realtek soundcard as well (configuration only shows stereo). Any suggestions?
Anima3 is offline   Reply With Quote
Old 09-01-2012, 10:31 PM   #9
Franpa
 
Join Date: Aug 2010
Reputation: 94
Posts: 1,396
Holy I didn't even realize there WAS a problem. I figured things like that wind ambience in the first video was just caused by the location of the camera being out in the wind more when positioned out in the open and looking at the bridge.
Franpa is offline   Reply With Quote
Old 09-07-2012, 01:51 PM   #10
DAOWAce
 
 
 
Join Date: Oct 2009
Reputation: 20
Posts: 208
I've downmixed, but now I get some weird issues with the interface sounds repeating themselves at least twice (basically, reverb echo fade out). The interface sounds are also quieter in places.

Also, when in an interior the reverb is so dramatic that it actually appears to echo, like the interface sounds, which themselves are more pronounced in an interior.

Using a X-Fi card with ALchemy and the XP compatibility tweak. Maybe I'll try disabling ALchemy to see if it fixes that.

But yeah; while I hear more sounds now, the reverb is out of control and making the game terrible to listen to indoors.

Edit: Disabling ALchemy fixed the insane reverb, but now indoor areas sound really flat.

Don't suppose there's any way around this other than actually using headphone mode? Really don't want to be forced to use headphones as they are irritating to wear. Using headphone mode with speakers sounds terrible as it actually changes the quality of the audio which sounds horrendous if not actually using headphones.

Last edited by DAOWAce: 09-07-2012 at 02:52 PM.
DAOWAce is offline   Reply With Quote
Old 09-07-2012, 02:18 PM   #11
andy4theherd
 
Join Date: Jan 2010
Reputation: 23
Posts: 266
i have an Asus Xonar DS. i use headphones 100% of the time for gaming. i always have my windows speakers set at 8 (7.1) and then headphones selected for output. do i need to change the speaker setting to 5.1 for this to work?
andy4theherd is offline   Reply With Quote
Old 09-07-2012, 05:54 PM   #12
rojimboo
 
Join Date: Feb 2012
Reputation: 52
Posts: 494
Quote:
Originally Posted by DAOWAce View Post
Also, when in an interior the reverb is so dramatic that it actually appears to echo, like the interface sounds, which themselves are more pronounced in an interior.

But yeah; while I hear more sounds now, the reverb is out of control and making the game terrible to listen to indoors.

Edit: Disabling ALchemy fixed the insane reverb, but now indoor areas sound really flat.

Don't suppose there's any way around this other than actually using headphone mode? Really don't want to be forced to use headphones as they are irritating to wear. Using headphone mode with speakers sounds terrible as it actually changes the quality of the audio which sounds horrendous if not actually using headphones.
Actually, without Alchemy, the game introduces the reverb in indoor areas and even applies it to the interface sounds. Enabling Alchemy might make it more pronounced, but actually it was very similar without ALchemy.

You might be getting really loud EAX effects (just means hardware accelerated sound in Creative control panel) if you have pumped up the decibels under "EAX effects". Try it +0.0db.

For me, I can't go back to not using Alchemy. It just adds so much to the game.

Regards to headphone mode - this has always puzzled me as my understanding is that downsampling to headphones is different than downsampling to stereo (and then using headphones). I can only assume Creative has its own algorithms for this, but considering if you had say Dolby headphones and the fact that you have to set it to 5.1 and downsample to headphones to capture surround sound, this to me would indicate all the sound channels are being sent to the headphones in that mode. This is reinforced by the fact that setting it to stereo mode instead sounds distinctly worse. This works for most open-ended headphones due to their nature, but this might be a terrible idea for stereo speakers.

TL DR - if you have stereo speakers, you probably should not use headphone mode for optimal sound.
rojimboo is offline   Reply With Quote
Old 09-07-2012, 06:55 PM   #13
Sp32
 
Join Date: Aug 2009
Reputation: 0
Posts: 18
How can this issue be fixed with a VIA soundcard with no downmixing option?
Sp32 is offline   Reply With Quote
Old 09-07-2012, 07:15 PM   #14
RaidSoft
 
 
 
Join Date: Dec 2008
Reputation: 18
Posts: 278
Quote:
Originally Posted by rojimboo View Post
I can confirm this doesn't happen for X-fi users with this tweak

Tweaks



And also setting 5.1 in Windows Sound settings, and downmix it to headphones/stereo with your soundcard via Creative Control panel.

This issue was the reason I looked into it as without music AND positional sound, it was pretty boring to play.

Edit: Actually the downmixing is the key here - the Alchemy tweak just improves some of the effects like reverb.
So I just tried this (got an X-Fi card and use headphones) and the audio ends up weird, I do get the ambient sound but the problem is other sounds seem to vanish (especially attack sounds) or become SUPER low volume.

I set windows to 5.1 and the control panel to headphones.

edit: ok actually I found out why it did that, I had checked the box for "Disable Sound Blaster enhancements" in windows settings and apparently that also affected the downmix, now I am happy

Last edited by RaidSoft: 09-07-2012 at 07:22 PM.
RaidSoft is offline   Reply With Quote
Old 09-08-2012, 04:08 AM   #15
DAOWAce
 
 
 
Join Date: Oct 2009
Reputation: 20
Posts: 208
Quote:
Originally Posted by rojimboo View Post
Actually, without Alchemy, the game introduces the reverb in indoor areas and even applies it to the interface sounds. Enabling Alchemy might make it more pronounced, but actually it was very similar without ALchemy.
Okay, did some more testing and I can't seem to reproduce the effects I had before; that or I am stupid and was testing in a different area which made the sound appear flat.

This reverb issue persists in the main menu after exiting the game when inside an area. When around bonfires the game sounds like an absolute mess. This is regardless of sound mode, seems like it's a bug with the game.

I disabled the XP tweak which removed directsound calls, thinking I disabled alchemy entirely when I didn't remove the dsound.dll. I've removed it now and kept the audio at 5.1 downmixed and have the massive echoing reverb.

I enabled ALchemy again on its own; still massive reverb.

I changed the sound to stereo; still massive reverb.

I enabled XP tweak to force directsound calls; still massive reverb.

As it stands, I can't seem to get the sound to change at all aside from the 5.1 downmix vs stereo. I can't say I notice a difference with ALchemy on or off.

Quote:
Originally Posted by rojimboo View Post
You might be getting really loud EAX effects (just means hardware accelerated sound in Creative control panel) if you have pumped up the decibels under "EAX effects". Try it +0.0db.
I keep that at +0.1dB. Reset it to 0 and it's still a problem.

Quote:
Originally Posted by rojimboo View Post
Regards to headphone mode -
Here's a sample video I recorded a few years ago with 'headphone' mode selected via the Creative drivers (Crysis): https://www.youtube.com/watch?v=lsxZJS4ed0o

I had no idea it sounded that bad because I was playing the entire game with headphones. Gaming in stereo mode with headphones actually sounds pretty terrible. Only good for listening to music and people talking.


PS: About speaker settings, if anyone knows; should I enable or disable 'full range speakers'? I honestly have no idea what my speakers are, they're like 10 years old and came with one of my early computers. JBL Platinum is the brand/series and according to specs I can find they have a 100-20KHz frequency range, which AFAIK is basically full range? I've never noticed this setting until I fiddled with Windows' sound settings and it asked me. I am pretty illiterate when it comes to advanced audio stuff, even though I act like I'm a cheap audiophile.

Last edited by DAOWAce: 09-08-2012 at 04:19 AM.
DAOWAce is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dark Souls


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:23 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.