Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Team Fortress 2

Reply
 
Thread Tools Display Modes
Old 12-11-2012, 06:48 AM   #1
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
My TF2 is suddenly censored again after almost 2 years

So, I live in Germany and bought TF2 from here too, meaning, I received the low violence version. After some research in the Steam Subscriber Agreement, I learned that it doesn't say anything against modifications of low violence games. I've installed a blood-patch, which is basically overrides all the files from the censored version with those of the original version.

This worked fine from the day I joined TF2 (December 22, 2010) until recently. About a week ago or two my TF2 was suddenly made censored again. Blood is black and has yellow lines in it, gibs are replaced with sillygibs, and there are no blood imprints when shooting someone.

So I've tried to fix this problem... for days. I've redownloaded the patch, extracted the files from the GCF myself, and even tried to modify the blood particles by hand. Nothing. So far I've only managed to get the blood on map objects back (not the actual map), but that's barely worth anything. Settings like violence_hblood are all set to 1, so don't worry about that.

Does anyone here have ANY clue about how to fix this or what it could have caused? Also, it would interest me if anyone else has or had a similar problem recently.

(Before someone says "You live in Germany, deal with it." or "What's so bad about sillygibs and no blood?": It's not illegal to play uncensored games, they just may not be sold as that. And I don't want to play with sillygibs because, well, they're silly. Could be fun to see them once or twice, but you get bored real quickly. Plus, it's often a serious downside to players with blood, since they have better hit indication, can see if there has been a recent fight in a specific area, etc.)


tl;dr: My German TF2 is censored again, I don't know how to fix it, it's not illegal.
Selbi is offline  
Reply With Quote
Old 12-11-2012, 06:51 AM   #2
Pinkie Pie™
 
Join Date: Mar 2012
Reputation: 882
Posts: 1,624
Well, the mod is over a year old, if it replaced any particles recent TF2 updates may have overwritten it.
Pinkie Pie™ is offline   Reply With Quote
Old 12-11-2012, 06:52 AM   #3
Enthers
 
 
 
Join Date: May 2012
Reputation: 177
Posts: 954
Is this on sv_pure servers or official servers in your area?

If not, perhaps your patch is messed up. Try to download some new ones with really bloody gibs.
Enthers is offline   Reply With Quote
Old 12-11-2012, 06:59 AM   #4
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
Quote:
Originally Posted by Pinkie Pie™ View Post
Well, the mod is over a year old, if it replaced any particles recent TF2 updates may have overwritten it.
That mod was only a demonstration because I couldn't find the one I've originally used. But as I've said, I already tried to extract the files from the GCF files, which are all up to date, without success.

Quote:
Originally Posted by Enthers View Post
Is this on sv_pure servers or official servers in your area?

If not, perhaps your patch is messed up. Try to download some new ones with really bloody gibs.
That server in particular was an offline one. And no, sv_pure is not enabled there, since I also have weapon skins which all work fine.

Also, I've already tried using this mod, but it's still censored. It almost seems like the game doesn't recognize that there are alternate files there, even though I triple-checked that the path is correct (after all, it hasn't changed in two years).
Selbi is offline   Reply With Quote
Old 12-11-2012, 07:07 AM   #5
Geotpf
 
 
 
Join Date: Nov 2008
Reputation: 750
Posts: 7,783
It is quite possible a new patch broke the hack you did to uncensor the game.
Geotpf is offline   Reply With Quote
Old 12-11-2012, 07:54 AM   #6
Timerlane
 
 
 
Join Date: Oct 2012
Reputation: 266
Posts: 993
U.S. here, but I am still getting sillygibs on my regular account from one of the last post-Halloween updates, and the recent Beta-sync patch added it to Beta, as well. I also still get Detonator flare impacts instead of the standard impact effect(I have blood off, but ragdolls and gibs on).

My autoexec hasn't changed since August, no mods unless you count highframes, Garm3nHUD 7MF, and hitsound.

So, yes, IMO, Valve did something involving the censor-content in the last month or so, but it only seems to have affected a relative minority of people.
Timerlane is offline   Reply With Quote
Old 12-11-2012, 08:10 AM   #7
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
Quote:
Originally Posted by Timerlane View Post
I also still get Detonator flare impacts instead of the standard impact effect(I have blood off, but ragdolls and gibs on).
Wait wait wait, the game is actually loading the Detonator particles, not the blood particles? Well, that could explain why nothing ever happened when I edited my blood particles.

I want to see what happens when I disable the Detonator particles. Be back in a few minutes.
Selbi is offline   Reply With Quote
Old 12-11-2012, 08:22 AM   #8
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
Nope, this is just coincidence, because nothing changes with the blood effects when I disable the Detonator particles (though those obviously don't show up). My guess is that Valve was just lazy and copied the Detonator particles from the German TF2 version.

Oh well, back to square one.
Selbi is offline   Reply With Quote
Old 12-11-2012, 11:31 AM   #9
D3l3rium
 
 
 
Join Date: Nov 2009
Reputation: 65
Posts: 579
I just tried to delete the ClientRegistry.blob after starting steam,
that allways worked in the past to enable blood for me, im also
german, however, it seems to be fixed because only the vocals
changed to english and blood on walls was sometimes visible but
thats all. Half a year ago i was able to make the game completely
uncut from just deleting the .blob after steam was started.

I you find any way to enable it again please tell me how to..
The only reason i didnt use any patches was because i wanted to
keep the german vocals just because my game has allways been german
for the past few years.

Edit:
Oh and btw this also worked on sv_pure servers because it just
made the whole game uncut instead of changing the particles like
many "bloodpatches" do.

Last edited by D3l3rium: 12-11-2012 at 11:40 AM.
D3l3rium is offline   Reply With Quote
Old 12-11-2012, 12:43 PM   #10
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
Quote:
Originally Posted by lemon&lime View Post
Care to explain why you are killing an endangered species?
No idea, actually. I just turned on the option and made the screenshots, without really thinking about it. I train on tr_walkway every day.
Selbi is offline   Reply With Quote
Old 12-11-2012, 07:12 PM   #11
laaars
 
 
 
Join Date: Feb 2010
Reputation: 7
Posts: 118
yes i can confirm this problem and i am also not happy about it.

If valve can't provide a way to proof that you're 18 then they should please leave us and our little tricks to get the original version alone!
laaars is offline   Reply With Quote
Old 12-11-2012, 07:40 PM   #12
Piper5by5
 
 
 
Join Date: Jan 2010
Reputation: 549
Posts: 3,209
I'm in the US, and this recently happened to me too after owning the game for 3 years and having blood + normal gibs. I eventually fixed it by deleting my tf folder. Maybe try that?
Piper5by5 is offline   Reply With Quote
Old 12-12-2012, 06:39 AM   #13
laaars
 
 
 
Join Date: Feb 2010
Reputation: 7
Posts: 118
deleting didn't work for me :/

some other people in german forums are saying they had a friend from outside germany buy the orange box and gift it then to them. this apparently works... but come on. i already bought the game and now when it's f2p, i don't want to buy it again
laaars is offline   Reply With Quote
Old 12-12-2012, 07:07 AM   #14
Selbi
 
 
 
Join Date: Oct 2010
Reputation: 1311
Posts: 5,342
Quote:
Originally Posted by Piper5by5 View Post
I'm in the US, and this recently happened to me too after owning the game for 3 years and having blood + normal gibs. I eventually fixed it by deleting my tf folder. Maybe try that?
Do you mean just the folder that is actually named tf (SteamApps/NAME/team fortress 2/tf) or the entire TF2 folder? Might give it a try.
Selbi is offline   Reply With Quote
Old 12-12-2012, 07:23 AM   #15
DSky
 
 
 
Join Date: Jul 2010
Reputation: 63
Posts: 538
A few weeks back we had several threads of peoplr playing a "censored" version (myself included). What I found is that oddly 2 commands changed in my autoexec.
Make sure these commands are set to 1 (if you don't have them, put them into your autoexec.cfg):

v i o l e n c e _ a g i b s 1
v i o l e n c e _ h g i b s 1
DSky is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > T - Z > Team Fortress 2


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 03:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.