Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion

Reply
 
Thread Tools Display Modes
Old 04-19-2013, 03:02 PM   #1
PatchOne
 
Join Date: Nov 2008
Reputation: 2
Posts: 67
CS:GO SDK does not launch at all

Hello.

Today i tried to launch the CS:GO SDK because i would like to start on a little project.

So i opened the tools section, installed the CS:GO SDK and started it - nothing happend, except that for a second my status was showing i am using the SDK and then it was closed again.

No Error Message, nothing. The launcher for the tools that would then show the Hammer, Modelviewer etc. does not even start.

Does anyone know this problem, or how to fix this?

Sorry if this is the wrong forum but since ther is no CS:GO SDK subforum i thought it might fit in here.

regards.
PatchOne is offline  
Reply With Quote
Old 04-19-2013, 11:31 PM   #2
gulliwog
 
Join Date: May 2007
Reputation: 284
Posts: 883
This kind of launching problem has been floating around the SDKs for years, and crops up from time to time with different people on all sorts of SDK versions. Thats not to say that the cause is always the same, however...

Normal "first stop" fixes for a problem like this are:

Verify game caches
Reinstall SDK
Reinstall CS:GO and SDK

If that doesn't work you can try to force steam to do a full update: Exit steam. Navigate to the "steam" folder - delete everything in "steam" EXCEPT "steam.exe" and the folder called "steamappps" (for Gods sake do NOT delete steamapps!!) - this will force steam to fully update the platfrom, and is basically one step down from reinstalling steam completely, which you can also do.

If none of these work then you may find the problem is more specific to your machine/hardware/setup - so you may need to include more info here.

Sometimes just running the game once before launching the SDK can be enough, but I assume you tried that already...

Oh and maybe check the shortcut if thats how you launch: steam://rungameid/745

Last edited by gulliwog: 04-19-2013 at 11:34 PM.
gulliwog is offline   Reply With Quote
Old 08-08-2013, 06:44 PM   #3
TorQueMoD
 
Join Date: Jan 2008
Reputation: 8
Posts: 46
I had the same issue. What I figured out was that I installed CS:GO on a different HD than the SDK so they couldn't find each other. Uninstalling the SDK and re-installing it on the correct HD fixed the issue for me.

Last edited by TorQueMoD: 08-08-2013 at 06:52 PM.
TorQueMoD is offline   Reply With Quote
Old 08-09-2013, 02:07 AM   #4
Cpt.Goomba
 
 
 
Join Date: Oct 2012
Reputation: 128
Posts: 740
I had this before, restarting Steam fixed the problem.
Cpt.Goomba is offline   Reply With Quote
Old 08-10-2013, 12:09 PM   #5
TorQueMoD
 
Join Date: Jan 2008
Reputation: 8
Posts: 46
Quote:
Originally Posted by Cpt.Goomba View Post
I had this before, restarting Steam fixed the problem.
Restarting steam didn't fix the issue for myself or the OP. Its not that it wouldn't start once after launching before, its that it never started after the first install.
TorQueMoD is offline   Reply With Quote
Old 08-10-2013, 01:16 PM   #6
Cpt.Goomba
 
 
 
Join Date: Oct 2012
Reputation: 128
Posts: 740
There's probably something (a file) that won't let the tool start.

Refresh the game's cache files.
Cpt.Goomba is offline   Reply With Quote
Old 10-25-2013, 10:45 AM   #7
cubuspl42
 
 
 
Join Date: Jan 2013
Reputation: 0
Posts: 2
Quote:
Originally Posted by TorQueMoD View Post
I had the same issue. What I figured out was that I installed CS:GO on a different HD than the SDK so they couldn't find each other. Uninstalling the SDK and re-installing it on the correct HD fixed the issue for me.
It was the case for me! Thanks!
cubuspl42 is offline   Reply With Quote
Old 11-29-2013, 04:26 PM   #8
Coolsil
 
Join Date: Dec 2008
Reputation: 0
Posts: 2
Quote:
Originally Posted by cubuspl42 View Post
It was the case for me! Thanks!
I was having same issue, had cs go on my ssd and sdk on my storage drive thanks!
Coolsil is offline   Reply With Quote
Old 01-08-2014, 07:47 PM   #9
Imrhien
 
 
 
Join Date: Aug 2012
Reputation: 0
Posts: 1
Solved it for me as well

I was having errors with missing files (in particular, tier0.dll). After getting those files the app simply failed to load.

Placing the SDK on the same drive as CS:GO solved the issue for me as well.

Thanks so much guys ^^
Imrhien is offline   Reply With Quote
Old 01-19-2014, 08:42 PM   #10
Midnitte1
 
 
 
Join Date: Feb 2007
Reputation: 63
Posts: 606
Quote:
Originally Posted by Imrhien View Post
I was having errors with missing files (in particular, tier0.dll). After getting those files the app simply failed to load.

Placing the SDK on the same drive as CS:GO solved the issue for me as well.

Thanks so much guys ^^
This also solved my issue, thanks!
Midnitte1 is offline   Reply With Quote
Old 03-13-2014, 11:19 PM   #11
EnragedNinja
 
Join Date: Dec 2012
Reputation: 3
Posts: 67
Quote:
Originally Posted by TorQueMoD View Post
I had the same issue. What I figured out was that I installed CS:GO on a different HD than the SDK so they couldn't find each other. Uninstalling the SDK and re-installing it on the correct HD fixed the issue for me.
This was my fix - TYVM
EnragedNinja is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Tool Discussions > Source SDK General Discussion


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -7. The time now is 02:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.