Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist

Reply
 
Thread Tools Display Modes
Old 07-25-2013, 12:48 AM   #1
Janitorus
 
 
 
Join Date: Nov 2011
Reputation: 104
Posts: 760
PAYDAY2 mouse lag (FOUND WORKAROUND)

WHAT FIXED IT FOR ME: I use Dxtory to limit the FPS of the game to 60, which is also my monitors refresh rate. When your game runs at a minimum FPS of 40 and a maximum of 65, you should enter 40 into Dxtory.


-------------------------------------------------

I'm just wondering who has mouse lag (and who doesn't) and what kind of system and drivers they're running. Maybe this is a known issue for Overkill already, I haven't heard yet.

1920x1080 full screen = mouse lag

This is on an i7 930, Radeon 5870, Catalyst 13.1 / 13.4 / 13.6 (beta).

It's not the worst mouse lag you've ever seen, but it's definitely there. On lower resolutions like 1280x720 all seems fine and the game runs much, and I mean MUCH better. It simply runs as supposed to, just like the first payday. FPS is always high and without any unexplained drops and never goes below my monitors refreshrate, no matter the resolution. Here's how it goes for me anyway:

When the game is not running at it's natural framerate cap of 130FPS, mouselag is present.

Some users reported that vsync totally fixed the problem, weird enough. So in other cases it seems that:

Variation in framerate is responsible for causing mouse lag.


Possible causes:

- Vsync
- A framerate less than 130
- Variation in framerate, even if your framerate is still high
- ???

Possible fixes:

- Vsync
- Any resolution lower than monitor native resolution
- Any resolution that results in your game running at 130FPS stable
- Windowed mode
- Turn vsync on/off
- Turn off post processing effects (turning off depth of field did not fix it)
- Possible fixes suggested by xerrolavengerii

What didn't work for me:

- Turning off steam in-game
- Catalyst 13.1 / 13.4 / 13.6 (beta)
- Closing all other background applications
- Disabling antivirus software

I'll try to update this post as the thread evolves into Big ol'PAYDAY2 mouse lag thread level 2.

Last edited by Janitorus: 07-26-2013 at 11:19 AM.
Janitorus is offline  
Reply With Quote
Old 07-25-2013, 11:53 PM   #2
Janitorus
 
 
 
Join Date: Nov 2011
Reputation: 104
Posts: 760
Bumped for update. Please post your findings and hardware configuration.
Janitorus is offline   Reply With Quote
Old 07-26-2013, 12:08 AM   #3
xerrolavengerii
 
Join Date: Sep 2010
Reputation: 5
Posts: 129
MY SOLUTION:

The same as payday classic:

Browse local game files for "context.xml" in the executable directory.

change the line:
<physics settings="settings/physics_settings" fps="60" physx_effects="hardware" multithreaded="true"/>
TO
<physics settings="settings/physics_settings" fps="60" physx_effects="hardware" multithreaded="false"/>

THIS RIGHT THERE FIXES MOUSE LAG IN PAYDAY CLASSIC FOR A LOT OF PEOPLE, BUT IF YOUR INTERESTED IN IMPROVING FRAMERATE MORE OR OTHER GRAPHICS TWEAKS TRY THESE:


AFTER THIS,
I used my nVidia control panel to force off a bunch of graphics features, like antialiasing and multisampling.

LASTLY,
navigate to Users/Yourprofile/Appdata/Local/Payday 2/renderer_settings.xml

go to the section
<render_settings>
<variable name="max_anisotropy" value="1"/>
<variable name="texture_quality_default" value="very low"/>
</render_settings>

I added/changed it to this:
<render_settings>
<variable name="dynamic_lights" value="true"/>
<variable name="effect_quality" value="disable"/>
<variable name="environment_detail" value="0"/>
<variable name="post_effect_quality" value="disable"/>
<variable name="shadow_map_size" value="0"/>
<variable name="max_anisotropy" value="1"/>
<variable name="texture_quality_default" value="medium"/>
</render_settings>

feel free to mess with these settings to get the best result!
Now it runs just as well as payday classic for me.
Good luck to you.

I'll post this in it's own thread so everyone can see.
http://forums.steampowered.com/forum....php?t=3159552
Would be nice for OK to implement this into the game menus.

Last edited by xerrolavengerii: 07-26-2013 at 12:15 AM.
xerrolavengerii is offline   Reply With Quote
Old 07-26-2013, 12:36 AM   #4
Janitorus
 
 
 
Join Date: Nov 2011
Reputation: 104
Posts: 760
Thanks, I hope that helps for a lot of us!

Even though I don't have low framerates, I tried all of your suggestions but nothing improved. The only solution for me currently is to drop to 1280x720.

OP updated.
Janitorus is offline   Reply With Quote
Old 07-26-2013, 03:12 AM   #5
Skater901
 
 
 
Join Date: May 2011
Reputation: 154
Posts: 1,471
I'm running 1366x768 on a laptop with an Nvidia GeForce GT 420M. Gonna try the fix that involves editing that XML file.
Skater901 is offline   Reply With Quote
Old 07-26-2013, 11:21 AM   #6
Janitorus
 
 
 
Join Date: Nov 2011
Reputation: 104
Posts: 760
I fixed my mouselag by running Dxtory and limiting the FPS of the game to 60, which is also my monitors refresh rate. When your game runs at a minimum FPS of 40 and a maximum of 65, you should enter 40 into Dxtory.

Let us know if this works.
Janitorus is offline   Reply With Quote
Old 06-06-2014, 03:13 PM   #7
coldfusion3k
 
Join Date: Feb 2012
Reputation: 0
Posts: 3
Lightbulb

If you changed the screen resolution via in game options then check to make sure the game saved the correct 'refresh rate' for the chosen resolution.

Navigate to: C:\Users\YOURUSERNAME\AppData\Local\PAYDAY 2\

Find and edit the file: renderer_settings.xml

Scroll down to renderer_config section:

<renderer_config>
<d3d_device
adapter = "NVIDIA GeForce GTX 580"
adapter_index = "0"
resolution = "1920 1080"
windowed = "false"
refresh_rate = "60"
aspect_ratio = "1.77083"
v_sync = "1"
/>

Ensure that the refresh_rate is set to 60 or whatever your monitor's refresh rate actually is.

After setting the correct value the game ran perfectly with high frame rates and no mouse lag.

-----------------------------------------------------------------

For some reason when I changed the resolution to 1920x1080 via in game gui, it set this value to 25

Which I believe is because of the detected resolutions listed at the beginning of renderer_settings.xml.
Here is what it detected for my resolutions at 1920x1080 listed in order. When selecting 1920x1080 in game it looks like it chooses the first one in the list and saves the respective refresh rate of... 25

1920x1080x25
1920x1080x59
1920x1080x29
1920x1080x50
1920x1080x60
1920x1080x30
1920x1080x23
1920x1080x24

-----------------------------------------------------------------

Optionally you can then use Dxtory or Riva Statistics Tuner to limit the frame rate to 59 for improved smoothness... in this and many other games. However these programs alone will not fix the mouse lag/frame rate issue in PAYDAY 2 if the game saved the wrong refresh rate in renderer_settings.xml

Last edited by coldfusion3k: 06-06-2014 at 04:54 PM.
coldfusion3k is offline   Reply With Quote
Old 07-01-2014, 08:11 AM   #8
Xuhybrid
 
Join Date: Feb 2011
Reputation: 3
Posts: 29
I managed to fix the mouse lag by setting my frame limit to 30.

Last edited by Xuhybrid: 07-01-2014 at 08:16 AM.
Xuhybrid is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 07:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.