Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Counter-Strike: Global Offensive

Reply
 
Thread Tools Display Modes
Old 09-12-2013, 10:23 AM   #16
takk只
 
 
 
Join Date: Sep 2006
Reputation: 2
Posts: 105
the URL was posted a few times in this thread. scroll up
takk只 is offline   Reply With Quote
Old 09-12-2013, 10:41 AM   #17
Govik_420
 
Join Date: Jun 2007
Reputation: 0
Posts: 16
Quote:
Originally Posted by takk只 View Post
the URL was posted a few times in this thread. scroll up
That link is of no help to me, that is the original page I used to set up workshop maps very shortly after they even launched the map workshop. I've tried all the things posted on that page. my server when this issue started reflected what is instructed on that page. could anyone having luck with workshop maps point out specifically what on that page I need to implement to get this working?

Please! and thanks in advance, not sure why this is being so bothersome. it was working!!!
Govik_420 is offline   Reply With Quote
Old 09-12-2013, 01:41 PM   #18
Govik_420
 
Join Date: Jun 2007
Reputation: 0
Posts: 16
Well I finally figured it out. It's my collection that seems to be the problem I set up the collection as Valve's ..._se collection and the starting map as de_dust2_se and it is now working so I'm going to try deleting and reconstruction my collection to see if I can get my own collection working again. so I'm using wepapi_authkey.txt and "start c:/csgo_ds/srcds -game csgo -console -usercon +game_type 0 +game_mode 1 +host_workshop_collection 125499818 +workshop_start_map 125488374" as my command line and workshop maps are working and my server is joinable. halleluiah!!!
Govik_420 is offline   Reply With Quote
Old 09-12-2013, 02:02 PM   #19
takk只
 
 
 
Join Date: Sep 2006
Reputation: 2
Posts: 105
what do you mean with "i set up as valves .._se collection"? There aren't different ways to create a collection?!
takk只 is offline   Reply With Quote
Old 09-12-2013, 02:36 PM   #20
Govik_420
 
Join Date: Jun 2007
Reputation: 0
Posts: 16
Quote:
Originally Posted by takk只 View Post
what do you mean with "i set up as valves .._se collection"? There aren't different ways to create a collection?!
Sorry thought that might confuse yet I did it anyway lol, I set the server collection as Competitive "se" maps, found here: http://steamcommunity.com/workshop/f.../?id=125499590. Then set the starting map as de_dust2_se, found here: http://steamcommunity.com/sharedfile.../?id=125488374 so my startup command was:

Code:
"start c:/csgo_ds/srcds -game csgo -console -usercon +game_type 0 +game_mode 1 +host_workshop_collection 125499590 +workshop_start_map 125488374"
and that works, it hosts the workshop maps in that collection and I can join my server. Also that collection is an official_csgo collection valve did. But my own collection for some reason is not working. I deleted my whole collection and remade it, but still not working. I'm going to try starting with the same map that is working from valve's collection cause that is also apart of my collection

*EDIT*
So I started the same map dust2_se from my collection and it's not working just starts with de_dust like it has been so it has to be an issue with the collections, and since I tore mine down rebuilt it and it's still not working and the csgo_official collection is working my conclusion is it's on the workshop side and hopefully valve fixes it soon. The only other thing I can try is hosting someone else's collection and see if the issue is still happening.

Last edited by Govik_420: 09-12-2013 at 05:54 PM. Reason: clarification
Govik_420 is offline   Reply With Quote
Old 09-12-2013, 07:04 PM   #21
hamilton5
 
Join Date: Sep 2012
Reputation: 31
Posts: 441
Exclamation linux issue

the few i see going are windows os...

not using +host_workshop_collection in the command line, and just relying solely on my webapi_authkey.txt file I am able to change to workshop maps.

Last edited by hamilton5: 09-12-2013 at 11:05 PM.
hamilton5 is offline   Reply With Quote
Old 09-13-2013, 12:19 AM   #22
Govik_420
 
Join Date: Jun 2007
Reputation: 0
Posts: 16
Quote:
Originally Posted by hamilton5 View Post
the few i see going are windows os...

not using +host_workshop_collection in the command line, and just relying solely on my webapi_authkey.txt file I am able to change to workshop maps.
so nothing relating to workshop maps in your startup command? are you only using myapi_authkey.txt containing your authkey, or also subscribed_collections_ids.text as well? also changing to and starting your server with a specific map are two different things, are you able to do both by chance? sorry just need some clarification. (I think I answered that my self. If I have JUST the webapi_authkey.txt no subscribed....txt files or even start up commands I can type map fy_iceworld_2012 and it switched to that map and I can join the server, although this wont give you control of the maps your server is using when it comes to mapchanges)

If I hosted my collection I was able to change to the maps but then my server became un-joinable ,gave me a lobby reservation error or just gave me the error that it was skipping DL and didn't change map. I have tried a handful of other collections with the +host_workshop_collection and +workshop_start_map (haven't tried the subscribed....txt files) and they are all working and server is joinable, also starts with the map I specify. I imagine using the subscribed_collection_ids.text would garner similar results (although I'm confused on that since hosting and subscribing are different things aren't they?).

So again this seems to point to the collections themselves not 100% sure but the 4-5 other collections I have tried all work but for some reason my collection doesn't I'm sure that some others aren't but have no way of knowing how many are affected (if any) as this is solely speculation based on this one persons experience so far.

My startup command was:
Code:
start c:/csgo_ds/srcds -game csgo -console -usercon +game_type 0 +game_mode 1 +host_workshop_collection 175436892 +host_workshop_collection 166862650 +host_workshop_collection 132106229 +workshop_start_map 122404013
however I found that it only hosts the first collection specified so it seems you can't host more than one collection. I can enter host_workshop_collection in the console and it switches to that collection. whichever collection is dictated first I can use +workshop_start_map and specify a map from that collection and it will start with said map, but if I try to specify a map not part of that first collection it doesn't start with that map. I can however type map "mapname" and it switches to it (provided my server has downloaded the map by hosting a collection it belongs to first). I believe this will throw the collection out the window and would allow other/any maps to be chosen when it comes to mapchange and/or end of map vote, and doesn't give you control of the maps you want to use from the workshop on your server. again this all points to my collection not working for some reason and only being able to host one collection at a time. I was hoping that through a handful of other collections I could replicate my collection for the time being.

The only thing I can think of is having someone try my collection and see if they have similar issues with it, here is a link if someone wants to try that: http://steamcommunity.com/sharedfile.../?id=177949041

these are collections that work for me:
http://steamcommunity.com/sharedfile.../?id=177949041
http://steamcommunity.com/sharedfile.../?id=175436892
http://steamcommunity.com/sharedfile.../?id=132106229

Last edited by Govik_420: 09-13-2013 at 12:28 AM.
Govik_420 is offline   Reply With Quote
Old 09-13-2013, 12:34 AM   #23
hamilton5
 
Join Date: Sep 2012
Reputation: 31
Posts: 441
yea as soon as you use the host_workshop_collection command it's locked up. you cant play the workshop maps.

Im pretty sure the ids.txt files do the same thing as the commands - the 'for server operators' link posted says you can do either or

your right about not handling map changes.. hopefully its solved soon

and these too; where clients crash after getting an updated version of the map. clients not getting updated versions of the map if not subscribed. and clients not downloading the required workshop map when getting on a server playing it.


EDIT; Turned out to be a bad map in the collection messing it up (Seige)

Last edited by hamilton5: 09-15-2013 at 04:00 AM.
hamilton5 is offline   Reply With Quote
Old 09-16-2013, 01:49 PM   #24
Govik_420
 
Join Date: Jun 2007
Reputation: 0
Posts: 16
Quote:
Originally Posted by hamilton5 View Post
yea as soon as you use the host_workshop_collection command it's locked up. you cant play the workshop maps.

Im pretty sure the ids.txt files do the same thing as the commands - the 'for server operators' link posted says you can do either or

your right about not handling map changes.. hopefully its solved soon

and these too; where clients crash after getting an updated version of the map. clients not getting updated versions of the map if not subscribed. and clients not downloading the required workshop map when getting on a server playing it.


EDIT; Turned out to be a bad map in the collection messing it up (Seige)
That is indeed the problem, I have that map in my collection as well. Once removed fixed the issue. That's why other collections were working but not mine. Thanks for figuring that out hamilton5
Govik_420 is offline   Reply With Quote
Old 04-17-2014, 02:34 PM   #25
forrestparkay
 
 
 
Join Date: Feb 2010
Reputation: 340
Posts: 4,259
I just wanted to point out that this issue still exists. I'm attempting to create a new server and even though it's exactly the same as another server that I currently run with no problems it still causes issues because it's a new install.
forrestparkay is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Counter-Strike: Global Offensive


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:43 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.