Go Back   Steam Users' Forums > Dedicated Server Discussions > Half-Life DS (Linux)

Reply
 
Thread Tools Display Modes
Old 03-20-2007, 10:24 AM   #1
annoyingproblem
 
Guest
Posts: n/a
svc_bad error kicking 3/4's of my server

I know this is a problem many have and there isn't a fix for it, or if there is someone isn't sharing it. I'm sick of it being pushed aside and blamed on router firmware of all things.

THIS IS A PROBLEM. Game server hosts like to blame addons and plugins, yet my server I rent still has the errors while running them without any form of addon/plugin installed or running. I've been with 4 different hosts over 3 years and all of them do it.

How is it I can run a 64 man BF2 server without huge errors that kick people, yet I can't run a simple 1.6 32 man server with no addons without 3/4's of my population being kicked atleast twice day sometimes more?

I really hate it when it happens in the AM, I'll have 30+ ppl error occurs kicks 25 of them and I'm left with an empty server that doesn't refill until 12 noon the next day while I'm at work.

BLAH!
 
Reply With Quote
Old 03-20-2007, 06:07 PM   #2
Slyguy42o
 
Join Date: Jul 2003
Reputation: 4
Posts: 491
I have seen it.. happens with alot less frequency on my serv... but never been able to get to the root of it.
How often do you restart your server instances? I do mine in the morning when it's dead.
Slyguy42o is offline   Reply With Quote
Old 03-21-2007, 02:11 AM   #3
annoyingproblem
 
Guest
Posts: n/a
Try to do it once a day, my server rarely dies out unless the error happens. I've seen the error happen with no mods installed, or addons with a completely full 32 ppl within an hour of a fresh restart. Sometimes it wont do it but once a day sometimes it does it 6+ times.

EDIT*** Wanted to add my server averages over 26 ppl on game monitor also, so if your server is not a 32 man or full all the time I dont think the error will happen as often. I have 20 man servers full 24/7 without the error.
  Reply With Quote
Old 03-23-2007, 04:00 AM   #4
tierr
 
Join Date: Apr 2006
Reputation: 0
Posts: 19
i have this sam problem on my server. bad svc.... :/
tierr is offline   Reply With Quote
Old 03-28-2007, 04:02 PM   #5
Belzebub0911
 
Guest
Posts: n/a
Solution

Hi Guys!

This error occurs, when at least 8 players are connected to a server and one of them has not disconnected correctly (connection problem or something like that). Does now a Round-Start occurs twice in the time (for example on a fast round map like fy_iceworld) when his connection to server broke down and the server automatic timeout kick happens, most of the people are getting kicked with this error message!

Just set "sv_timeout 22" ...

This will kick the "timeout player" right in time, before 2 Rounds-Starts occurs ...

Thats all!

Cya, Belzebub
--
24/7 Iceworld by Belzebub CS1.6 *VAC/HLGuard Secured* @ jabt.net
Server-IP : 85.131.248.102:28015 -- Web: http://247iceworld.de.vu
  Reply With Quote
Old 04-10-2007, 09:55 AM   #6
WW2-WARDOG
 
Join Date: Apr 2004
Reputation: 1
Posts: 243
Actually, we have traced it to the bot pluggin, turn it off, it goes away,turn it on, it comes back. I've posted on the shrikebot site trying to get an answer to the bug.

I will try the timeout time you mentioned, but it may have to go the other way, because the bots join first before the players.
WW2-WARDOG is offline   Reply With Quote
Old 04-22-2007, 03:24 PM   #7
Despise
 
Guest
Posts: n/a
I cant say theres a fix for this bug but I have seen svc_bad across many servers over different mods of HL1. One thing I noticed is the higher you set the tickrate of your server the more frequently it will kick people with svc_bad.
  Reply With Quote
Old 04-22-2007, 06:57 PM   #8
annoyingproblem
 
Guest
Posts: n/a
sv_timeout 22

This solved my svc_bad errors 100%. My server has not had one since I changed it over a month ago.

Thank you to the person who posted this, much appreciated.
  Reply With Quote
Old 04-22-2007, 09:28 PM   #9
Belzebub0911
 
Guest
Posts: n/a
@ annoyingproblem

No problem!

@ all

Guys, read my first reply and try it out! THIS WILL HELP !!

Cya, Belzebub
--
24/7 Iceworld by Belzebub CS1.6 *VAC/HLGuard Secured* @ jabt.net
Server-IP : 85.131.248.102:28015 -- Web: http://247iceworld.de.vu
  Reply With Quote
Old 04-24-2007, 02:01 PM   #10
RB1955
 
Guest
Posts: n/a
it worked for me too
thanks!
  Reply With Quote
Old 04-29-2007, 12:34 PM   #11
-GF-
 
Join Date: Sep 2003
Reputation: 0
Posts: 394
Just topping this, as it's worked for us too. Since setting sv_timeout to 22 we've not had a mass server player kick at all.

This is on TFC servers
-GF- is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Dedicated Server Discussions > Half-Life DS (Linux)


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:53 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.