Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)

Reply
 
Thread Tools Display Modes
Old 11-03-2007, 04:06 AM   #1
Grottenolm
 
Guest
Posts: n/a
Exclamation Solution for: SRCDS / TF2 vs. VAC disabled / insecure, "disconnected from Steam3"

Short: Use the command line option "-sourceport 2690x" on every srcds command line, using 26900 for the first server, 26902 for the second, and so on.


Long Story: (so that ppl who search for details find this post)

I was getting a lot of trouble with running multiple source servers on one machine. Especially my TF2 ones would loose their VAC secure status after a while, or not even start secure. The console output was like this:

Quote:
Adding master server 72.165.61.189:27011
Adding master server 68.142.72.250:27011
Could not establish connection to Steam servers.
status
hostname: [RdE]Ententeich
version : 1.0.0.34/7 3224 insecure (secure mode enabled, disconnected from Steam3)
Sometimes it would work OK, if starting TF2 first and after that starting the DOD:S and CS:S servers. But after a few mapchanges or restarts some source servers would be without VAC again.

So I used TCPVIEW to see what's happening... I found that SRCDS tries to connect to the steam/VAC server through port 26900 and up. When starting multiple srcds servers, unfortunately not each new server uses a new port, some use ports that are already used. Even more unfortunate, the SRCDS command line options (http://developer.valvesoftware.com/w...d_Line_Options) don't seem to allow to force or assign a certain steam / VAC port.

But there is an "undocumented" command line option "-sourceport". After I added this option to every source server, using a different port for each one, now all servers are VAC secure...

Hope that helps - and I hope the documentation for the source servers will be improved
 
Reply With Quote
Old 02-17-2011, 03:01 PM   #2
muppetmauler
 
Join Date: Aug 2009
Reputation: 0
Posts: 20
I had a similar issue with our dedicated servers running on a linux box in a data center. I tried your solution above but found no immediate joy.
Our problems only happened after we upgraded our firewall system (server got hacked) so immediately knew it had something to do with that. However; we already added these ports to allow proper steam server connections; but that clearly wasn't enough.
Before the ports were opened we found in the log files that the steam server IP trying to connect to ours had been blocked on port 26901. I had to add the IP (208.111.158.53) to the allowed list. As soon as it was done, VAC secure mode kicked straight in.

Hopefully this will help more people fix their steam disconnection issues and fortify your solution as well mate. If I find any more Steam server IPs I'll post them here.

We do seem to manage ok without the -sourceport 2690x in startup line though. never used it and have more than one TF2 server running.
Thanks for putting me on the right track Grottenolm.

Last edited by muppetmauler: 02-17-2011 at 03:09 PM.
muppetmauler is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Dedicated Server Discussions > Source DS (Windows)


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:03 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.