Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Beyond Good & Evil

Reply
 
Thread Tools Display Modes
Old 05-14-2008, 01:10 PM   #1
CrimsonTwilight
 
Join Date: Nov 2007
Reputation: 20
Posts: 133
Fix for flashing textures/artifacting problems.

Go into your Steam > steamapps > common > beyond good and evil > SettingsApplication.exe

On the tab you start out in "Graphics Settings", you can mess with your resolution, I have mine at 1440x900. Jump to the "Advanced Settings" tab and you can jack up water detail, antialiasing, flare, and shadows quality as high as you want. I had to lower antialiasing just a bit to keep my FPS up.

Now on the right click on the "manual compatibility" checkbox. Everything except W Buffer should be checkmarked. Now, all you need to do is uncheck "HW Vertex Processing".

HW Vertex Processing is the option I found that causes all of the artifacting and shifty eyes.

This fixed the flashing textures problem for me.
CrimsonTwilight is offline  
Reply With Quote
Old 05-14-2008, 05:25 PM   #2
dustin_62
 
 
 
Join Date: Jul 2007
Reputation: 1
Posts: 55
Fixed the problem for me too.
Thanks!
dustin_62 is offline   Reply With Quote
Old 05-15-2008, 03:34 PM   #3
placeboing
 
 
 
Join Date: Jan 2008
Reputation: 86
Posts: 1,346
Thanks a lot, this fixed it.
placeboing is offline   Reply With Quote
Old 05-16-2008, 07:55 AM   #4
ctheiss
 
Join Date: May 2008
Reputation: 0
Posts: 4
Unhappy

I have the same texture artefacting errors. Removing the "HW Vertex Processing" check fixes the texture problems, but slows down the framerate unacceptably (down to ~3fps), even when all settings are significantly lowered.

I searched around and also tried lowering the "prerender limit", but this had no effect.

Any other ideas? I would really appreciate it... I really want to play this game, but seem to have the choice between epilepsy-inducing flicker or stuttering framerate.

Oh, I've got an nVidia 8800GTS and am running the latest forceware drivers.
ctheiss is offline   Reply With Quote
Old 06-06-2008, 09:55 AM   #5
Windcast
 
Join Date: Jul 2007
Reputation: 0
Posts: 20
Thanks for the tip. The option turned off that annoying flickering. I've experienced some low FPS in just the city so far.

Windows Vista™ Ultimate 64bit Service Pack 1
NVIDIA GeForce 8800 GTS
6GB RAM
Intel(R) Core(TM)2 Quad CPU @ 2.40GHz

1920 x 1200 (32 bit) (60Hz)
Windcast is offline   Reply With Quote
Old 06-27-2008, 09:53 PM   #6
cyberyan
 
Guest
Posts: n/a
Getting slowdown as well...

That fixed the glitch for me but I am getting slowdown now as well.....I can play it but it's not fun at that framerate. :-(

I'm on a quad core machine with 4 gigs of ram and an 8800gt so I should have this problem with this game. Running it without HW acceleration isn't fun!
  Reply With Quote
Old 06-30-2008, 02:37 AM   #7
TheGunslinger
 
Banned
Join Date: Jun 2004
Reputation: 0
Posts: 2,708
Sticky this topic imo
TheGunslinger is offline   Reply With Quote
Old 07-04-2008, 09:10 PM   #8
artofwar420
 
 
 
Join Date: Sep 2007
Reputation: 16
Posts: 148
The fix did get rid of the artifacts and texture problems, and as stated it also made the fps a little inconsistent.

Now, just to see, I put the settings back to default, and started the game up, what do you know? It didn't give me any problems like the first time I started the game.

UPDATE: It seems that populated areas do give the same artifacting problems. And the fix makes the water look weird, we can't win them all


I suggest if the inconsistent fps is bothering you, try the default settings again, and check, it might work fine.

Last edited by artofwar420: 07-05-2008 at 09:36 AM.
artofwar420 is offline   Reply With Quote
Old 07-19-2008, 09:47 PM   #9
myeyes121
 
Guest
Posts: n/a
just wanted to say thanks. that fix worked for me!!
  Reply With Quote
Old 07-20-2008, 09:55 AM   #10
Warbadger
 
Join Date: Oct 2007
Reputation: 0
Posts: 78
Yeah, it worked for me as well, but like everyone else is saying the water is now terrible and the FPS in the city is very, very low. I really enjoy this game but the technical issues are ruining the experience for me. Oh well, thanks for the help.

EDIT: You know what? I reset everything back to default and then turned Antialiasing all the way off and it works beautifully. Honestly,I can't even really tell the difference between it being on and off. I'm sure if I look hard enough I would be able to tell, but the game runs silky smooth now in all aspects and the water now looks good. I am running an 8800GTS with the latest drivers. Maybe that will work for the others as well?

Last edited by Warbadger: 07-20-2008 at 02:37 PM.
Warbadger is offline   Reply With Quote
Old 08-24-2008, 09:16 PM   #11
Artistdude88
 
Join Date: Aug 2008
Reputation: 0
Posts: 19
Thanks, I had the glitchy textures as well. Disabling that fixed it right up!

All I did was disable HW Vertex Processing... But I have noticed that some animations aren't as smooth and the water looks funky. Other than that, it's all good!

Win XP + 8600GT for the record :P

---

UPDATE: I tried what Warbadger did, turning off Antialiasing and turning HW Vertex Processing back on. That also fixed the glitchy textures. Sure, no smooth edges, but the water and everything is fine.

Last edited by Artistdude88: 08-24-2008 at 09:31 PM.
Artistdude88 is offline   Reply With Quote
Old 11-26-2008, 07:03 PM   #12
Storm_Maniak
 
Guest
Posts: n/a
Disabling Anti-Aliasing also did the trick for me.

Anyway, if you have any modern video card, you should be able to crank the resolution very high which compensate for the loss of AA.
  Reply With Quote
Old 11-26-2008, 11:44 PM   #13
Psamathos
 
 
 
Join Date: Feb 2008
Reputation: 48
Posts: 707
Yes, disabling HW Vertex Processing did fix the flickering, but I did get a lousy framerate around areas with complex effects. The water looked fine but it just ran at a noticeably lower framerate. I turned it back on and disabled AA instead and it runs great now. I have it up to 1600x1200@100Hz with my GeForce 8800 GTS. Thanks everyone, this game is actually playable now!
Psamathos is offline   Reply With Quote
Old 01-27-2009, 01:25 PM   #14
Masterspeed
 
Guest
Posts: n/a
thanks alot man..it worked! i love this game so much
  Reply With Quote
Old 03-29-2009, 01:32 AM   #15
Komix
 
Banned
Join Date: Jan 2009
Reputation: 22
Posts: 425
thanks, that worked
Komix is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > # - C > Beyond Good & Evil


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 09:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.