Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 01-03-2009, 04:32 AM   #1
lightningx36
 
Guest
Posts: n/a
Steam is running in windows compatability error, please help!

Dear Steam Users,

I started steam 2 days ago and an error popped up saying "running steam in windows compatibility mode is not recommended. Please remove any windows compatibility settings for steam.exe under all users. and restart steam. Press cancel to permanently ignore this warning and continue."

I then looked under all users but none had the windows compatibility mode checked. I done a system restore and it worked fine then. Last night I bought left 4 dead and this morning when I started up steam the same message came up. I looked under all users but windows compatibility was not checked for steam.exe. I do not know whether to click cancel or not could you please help me.

Regards,
Lightningx36
 
Reply With Quote
Old 01-03-2009, 04:35 AM   #2
Ramzy
 
 
 
Join Date: Jan 2005
Reputation: 1361
Posts: 12,938
What operating system are you running?
Ramzy is offline   Reply With Quote
Old 01-03-2009, 04:42 AM   #3
lightningx36
 
Guest
Posts: n/a
Vista Home Premium SP1
  Reply With Quote
Old 01-03-2009, 04:53 AM   #4
Ramzy
 
 
 
Join Date: Jan 2005
Reputation: 1361
Posts: 12,938
Alright, so if you right click Steam.exe > Properties > Compatibility, it looks like this?:

http://i40.tinypic.com/mm4uaw.png

Are there multiple user accounts on your computer? And do you have UAC enabled?
Ramzy is offline   Reply With Quote
Old 01-03-2009, 05:01 AM   #5
lightningx36
 
Guest
Posts: n/a
Yes it looks like that only I have run as admin checked. There are multiple users. I don't know what UAC is.
  Reply With Quote
Old 01-03-2009, 06:38 AM   #6
Ramzy
 
 
 
Join Date: Jan 2005
Reputation: 1361
Posts: 12,938
Do the other accounts on your computer all access Steam? Or is it just you that uses it?
Ramzy is offline   Reply With Quote
Old 05-03-2009, 08:24 AM   #7
Robinhu10
 
Guest
Posts: n/a
Just do this.

In that Steam.exe-»properties--»compability

Click on show settings for all users

And take off the compability mode
  Reply With Quote
Old 07-17-2009, 03:54 AM   #8
crusader8463
 
Join Date: Mar 2009
Reputation: 6
Posts: 113
Quote:
Originally Posted by Robinhu10 View Post
Just do this.

In that Steam.exe-»properties--»compability

Click on show settings for all users

And take off the compability mode
TY i have had been having the same error from steam for a week now. But that fixed it. IDK how it got checked though as i am the only user and account on this computer. Oh wells thanks.
crusader8463 is offline   Reply With Quote
Old 07-29-2009, 05:15 PM   #9
ZeroHour
 
Join Date: Mar 2009
Reputation: 76
Posts: 16
I had a similar problem. Try:
http://www.edugeek.net/forums/gaming...lity-mode.html
ZeroHour is offline   Reply With Quote
Old 07-29-2009, 05:36 PM   #10
>X<
 
Banned
Join Date: Jan 2009
Reputation: 475
Posts: 3,310
If nothing else fixs it try:
Hit start->run->regedit
Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Delete that entry
If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

start Steam

Thanks ZeroHour +rep
>X< is offline   Reply With Quote
Old 06-28-2010, 08:32 PM   #11
Happy13ee
 
Join Date: Apr 2010
Reputation: 0
Posts: 48
Thanks ZeroHour at least I'm able to start steam again, but my mouse is a bit wonky still.

I also started having problems after buying Left 4 Dead 2 6-26-10. I played it just fine and after I quit my mouse wasn't smooth at all.

It's a bit hard to hit the X to close a browser tab. It's a bit better after removing the registry key, but I never had a problem with the mouse being precise. Before the FIX Zero mentioned my mouse was very hard to point it where I wanted it to go. I had to redrag it several times to finally get it to where I wanted it to go. Any idea what caused this?

Anyway thanks a lot for the steam fix ZeroHour. +rep

PS My mouse is a Logitech MX Revolution and running the latest drivers. Any info on the mouse would be appreciated.

Last edited by Happy13ee: 06-28-2010 at 08:46 PM.
Happy13ee is offline   Reply With Quote
Old 07-03-2010, 08:49 AM   #12
Daeluin
 
Guest
Posts: n/a
Hey Happy13ee - I also installed left for dead 2, when it was on sale a few days ago. it played ok, but the next day at work I had some strange mouse lag, using the logitech software. After an hour or so that went away and my mouse has worked fine.

But...

That night steam started warning about compatibility mode, I checked the steam.exe compat properties and it was clean for all users.

But starting then and ever since while playing TF2 I have occasional video lag, the whole thing freezes up for 5-10 seconds then runs smooth again.

Same thing happens in Galcon Fusion.

Tried installing new nvidia drivers, virus scan, video benchmark, and ran a memtest. All clean so far.

Just removed that reg key, will see if it helps.

Edit: Nope, that wasn't it... must be an overheating issue.

Last edited by Daeluin: 07-03-2010 at 09:36 AM.
  Reply With Quote
Old 11-13-2010, 08:03 PM   #13
Cronus
 
 
 
Join Date: Dec 2008
Reputation: 0
Posts: 22
Quote:
Originally Posted by >X< View Post
If nothing else fixs it try:
Hit start->run->regedit
Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Delete that entry
If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

start Steam

Thanks ZeroHour +rep
This thread was the second google result and the above fixed it for me. Thanks.
Cronus is offline   Reply With Quote
Old 11-29-2010, 05:58 PM   #14
Axekick
 
Guest
Posts: n/a
Thumbs up

Quote:
Originally Posted by Cronus View Post
This thread was the second google result and the above fixed it for me. Thanks.
Same here! Good call on that fix. Out of curiosity, does anyone know what causes this error in the first place?
  Reply With Quote
Old 01-04-2011, 01:39 PM   #15
Jeearr
 
 
 
Join Date: Aug 2010
Reputation: 0
Posts: 12
Thumbs up

Quote:
Originally Posted by >X< View Post
If nothing else fixs it try:
Hit start->run->regedit
Go to key: HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
Look for a entry with your path to steam.exe
Delete that entry
If you dont find it there try HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers

start Steam

Thanks ZeroHour +rep
Worked for me; try looking under HKEY_LOCAL_MACHINE as well for it (I found it under local machine, deleted it, and it worked). Thanks guys.
Jeearr is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error messege as admin NIMIS Source DS (Windows) 5 11-30-2006 02:06 PM


All times are GMT -7. The time now is 06:19 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.