Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 11-15-2009, 04:59 PM   #16
TetraNitro
 
Join Date: Oct 2008
Reputation: 187
Posts: 285
Quote:
Originally Posted by aarste View Post
Registry fix also worked for Windows 7. Why Windows had the nerve to automatically apply compatibility fixes to steam without an option not to when I manually exited it from system tray and the application closed fine, I don't know...
It's worse than that. The Registry key in question isn't an XP compatibility mode flag - It's a flag to elevate privileges for the application in question.

In effect, what happens is that Steam crashes and Vista/Win7 decide automatically (and without telling you or letting you say NO) to give the program unrestricted Admin access, and doesn't show this option outside the registry. Steam interprets this as being in compatibility mode for some reason.

I find it highly unnerving that the OS can be so easily fooled into elevation. What if it wasn't Steam, but a malicious program that purposefully crashed to simulate these conditions?

But that's not Valve's fault, so much as a Windows flaw.
TetraNitro is offline   Reply With Quote
Old 11-17-2009, 03:40 AM   #17
ogre_x
 
Join Date: Jan 2007
Reputation: 1
Posts: 66
Quote:
Originally Posted by ZeroHour View Post

UPDATE: Take a look in the registry at:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
You may notice steam.exe listed there. Removing that may help. Also check under HKEY_LOCAL_MACHINE as well in case its admin set.
Thanks for this! I ran into this today in Windows 7. Really stupid operating system if you ask me. The registry fix did the trick right away.
ogre_x is offline   Reply With Quote
Old 11-17-2009, 09:12 AM   #18
Malangyar
 
Guest
Posts: n/a
Quote:
Originally Posted by ogre_x View Post
Thanks for this! I ran into this today in Windows 7. Really stupid operating system if you ask me. The registry fix did the trick right away.
Worked for me too, but annoyed that Windows would do this by itself without confirmation.
  Reply With Quote
Old 11-17-2009, 09:19 AM   #19
Jrm
 
Guest
Posts: n/a
Thumbs up

Quote:
Originally Posted by ZeroHour View Post
Right this happened to me. I have not found a nice solution yet but one thing that worked was to reinstall steam but installing it in a new location (say "c:\steam" rather then program files)
For some reason windows can automatically apply settings and after the event it can be very hard to remove but these settings are based on app install path so changing this should fix the issue.

Please note uninstalling steam removes your installed games so I would copy the steamapps folder then remove and paste it back into the new install location.

Hope this fixes your issue.

UPDATE: Take a look in the registry at:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
You may notice steam.exe listed there. Removing that may help. Also check under HKEY_LOCAL_MACHINE as well in case its admin set.

Edit: Posted extra details/instructions at:
http://www.edugeek.net/forums/gaming...lity-mode.html
Recieved the message this morning and used this fix; running Windows 7. Thanks!
  Reply With Quote
Old 11-17-2009, 11:52 AM   #20
lostsomething
 
 
 
Join Date: Jun 2008
Reputation: 22
Posts: 392
Happened to me too just yesterday.

This is *really* werid - Windows 7 tells you that it's doing it but doesn't give you an option to stop you from doing it and I'd checked both the .exe and shortcut and neither looked like it had anything odd checked.
lostsomething is offline   Reply With Quote
Old 11-17-2009, 11:59 AM   #21
BS_1
 
Join Date: May 2008
Reputation: 4064
Posts: 3,342
Happening to me right now on Windows 7.

Since I am too lazy to do any fixes right now, will it hurt to just ignore it? I just pressed cancel to ignore it.

Last edited by BS_1: 11-17-2009 at 12:03 PM.
BS_1 is offline   Reply With Quote
Old 11-20-2009, 09:11 AM   #22
rondawg
 
Guest
Posts: n/a
hey guys the same thing happened to me today with the whole compatibility thing and it happened when i created a short cut for left4dead and i fixed it by going to the left4dead shortcut properties -compatibilities and saw that compatibiility mode wasnt checked and at the bottom of the compatibility screen it has show settings for all users and in there it had compatibility mode checked so i unchecked it apply and ok and the message went away when i restarted steam so try it on all of your shortcuts to see witch one it is and i hope this helps cause i didnt do these reg fix's or reinstalling have fun and please reply if it works for you
  Reply With Quote
Old 11-20-2009, 09:35 AM   #23
mslongjr
 
Join Date: Nov 2009
Reputation: 0
Posts: 4
I had the same issue Tuesday night (Win7, 64 bit) after I ran L4D2 for the first time. Big big thanks to ZeroHour for the fix.

Now I never created a specific shortcut for LFD2 like rondawg did, but I notice that if Steam is in your Win7 startup menu, then recently played games are automatically given shortcuts in the expanded menu that opens if you hover over the icon. Maybe that could be a culprit? I already did the regedit fix, but if the problem returns I might take a look at that shortcut first.
mslongjr is offline   Reply With Quote
Old 11-21-2009, 02:47 AM   #24
HertzaHaeon
 
Join Date: Sep 2007
Reputation: 3
Posts: 13
This fix didn't work for me, but I found another registry entry for steam.exe in HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted. I deleted that as well, and Steam now works.
HertzaHaeon is offline   Reply With Quote
Old 11-26-2009, 07:10 PM   #25
bumblebee200
 
Join Date: Dec 2008
Reputation: 7
Posts: 168
THANKS!!! IT WORKED FOR ME!!!
bumblebee200 is offline   Reply With Quote
Old 11-28-2009, 02:32 AM   #26
ZeroTheHero
 
Join Date: Mar 2008
Reputation: 11
Posts: 293
Quote:
Originally Posted by ZeroHour View Post
[...]
UPDATE: Take a look in the registry at:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
You may notice steam.exe listed there. Removing that may help. Also check under HKEY_LOCAL_MACHINE as well in case its admin set.
[...]
Thanks, +Rep for you, good sir!
ZeroTheHero is offline   Reply With Quote
Old 11-29-2009, 10:01 AM   #27
SabaTheHobo
 
Guest
Posts: n/a
Thumbs up

Quote:
Originally Posted by ZeroHour View Post

UPDATE: Take a look in the registry at:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
You may notice steam.exe listed there. Removing that may help. Also check under HKEY_LOCAL_MACHINE as well in case its admin set.
]
Worked like a charm, many thanks mate.
  Reply With Quote
Old 12-04-2009, 07:14 PM   #28
James01
 
Guest
Posts: n/a
I also had this problem in Windows 7 x64. The registry edit fixed it. Thanks!
  Reply With Quote
Old 12-22-2009, 05:05 AM   #29
Spacedementia87
 
Join Date: Dec 2007
Reputation: 0
Posts: 31
I have also been having this problem. After reading this I fixed it and have send off a quick e-mail to Microsoft informing them of the situation and my concerns about it. Hopefully they will release a fix that allows you to click No when the compatibility popup appears.
Spacedementia87 is offline   Reply With Quote
Old 12-28-2009, 02:27 PM   #30
Jesse_Dylan
 
 
 
Join Date: Oct 2009
Reputation: 0
Posts: 74
I gotta say, I'm pretty ****ing annoyed by this. Thank you kindly for the fix. I sure hope it works; I'm assuming it will since so many others with my OS (Windows 7 64-bit) say it works fine.

I do almost all my gaming through Steam, so if there are Steam issues, I'm NOT a happy dude. Thanks a lot, Windows. This is the only problem I've had so far, but it's a pretty obnoxious one.

Edit: Ugh, not only that, but now I accidentally clicked the "cancel" button, which will remove all future warnings. Now how will I know if the fixes work and if it's still running in compatibility mode or not? I'm so cranky today. NOT a good day to try to fix computer issues. Sigh...

Edit edit: Oh, uh, also, thank you. I made the changes to the registry. Since I'm dumb and hit cancel, though, I won't have any warning really if it does it again without my knowledge.

Last edited by Jesse_Dylan: 12-28-2009 at 03:30 PM.
Jesse_Dylan is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Some questions about Offline Mode & "Standalone" retail discs. AisuSeijin Help and Tips 15 10-06-2011 12:52 AM
steam update StianLeRoux Help and Tips 1076 04-04-2010 01:57 PM


All times are GMT -7. The time now is 09:10 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.