Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 07-05-2009, 09:49 AM   #1
Ferth
 
Guest
Posts: n/a
Exclamation Error: Failed to create key.

My girlfriend is getting this error prompt when she tries to start Steam. Is there anyone out there who knows how to resolve this issue?

Cheers /Ferth
 
Reply With Quote
Old 07-05-2009, 10:40 AM   #2
Sierra Oscar
 
Sierra Oscar's Avatar
 
Volunteer Moderator
Join Date: Dec 2005
Reputation: 6782
Posts: 44,760
It is often a firewall issue, tell her to have a read over this FAQ.
Sierra Oscar is offline   Reply With Quote
Old 03-10-2010, 02:40 PM   #3
garlax11
 
Guest
Posts: n/a
Failed to create key

We had this problem well over a year ago. I tried disabling the firewall, enabling every single port of the router and nothing worked. REad the FAQ inside out and upside down.

Posted questions to steam, and then even twitter in desperation but no help from anywhere. There is no one to talk to, no online chat, no real person to communicate with and as far as i can see no proper help.

So my son still has a game that we paid good money for that he received for Christmas 2008 that won't work. Yet if we didn't have to use steam, then the game would work just fine.
  Reply With Quote
Old 03-11-2010, 10:32 AM   #4
Westridge
 
Join Date: Dec 2009
Reputation: 0
Posts: 35
Quote:
Originally Posted by Sierra Oscar View Post
It is often a firewall issue, tell her to have a read over this FAQ.
And what do you do when it isn't a firewall issue?
I had this problem when I installed three months ago. The Steam client updated itself yesterday and now I'm stuck again with the same problem and none of the usual fixes work. Hell, even uninstalling everything including registry entires and reinstalling still ends up with the same message. I'd been playing everything fine for the last three months until yesterday so don't tell me its a firewall issue.
Westridge is offline   Reply With Quote
Old 07-02-2010, 06:18 PM   #5
TheAlmighty
 
Guest
Posts: n/a
The solution is following (it works for me) :

Click Start > Run...

Type "regedit" and press Enter.

Right-click on HKEY_CURRENT_USER and click Permissions

Under "Group or user names:" click Add...

Type in your Windows user account name and click "Check Names." If you entered the name properly, this should work and you should then be allowed to click OK.

Select your account in Group or user names and check "Allow" for Full Control and Read. Click OK.

Right-click on HKEY_LOCAL_MACHINE and click Permissions

Under "Group or user names:" click Add...

Type in your Windows user account name and click "Check Names." If you entered the name properly, this should work and you should then be allowed to click OK.

Select your account in Group or user names and check "Allow" for Full Control and Read. Click OK.

Once you have completed these steps, please exit the Registry Editor and reboot your computer, then re-test the issue.

tx to http://forums.steampowered.com/forum...d.php?t=976228
  Reply With Quote
Old 10-18-2010, 05:18 PM   #6
boise_piper
 
Guest
Posts: n/a
fixed it!

I had to manually assign my account as the owner of the HKCU/software/valve key. Then assign myself full-control of it. Then I had to do the same exact thing for the HKCU/software/valve/steam key.
  Reply With Quote
Old 11-10-2010, 03:12 PM   #7
famousfigures
 
Guest
Posts: n/a
Cleared up

Quote:
Originally Posted by boise_piper View Post
fixed it!

I had to manually assign my account as the owner of the HKCU/software/valve key. Then assign myself full-control of it. Then I had to do the same exact thing for the HKCU/software/valve/steam key.
I had the same problem, came to this forum, and just said forget it. A year later, I came back and thought, "OK, i'm going to figure this out".

The above works! To clear it up,

Step 1:
go to Start>Run> type regedit and hit enter

Step 2:
go to HKEY_CURRENT_USER
expand that and find the "software" folder, expand that and find the "Valve" folder.

Step 3:
on the "Valve" folder, right click and find permissions on the menu and click that. In the permissions box checkmark the "full control" box.

Step 4:
in the "Valve" folder if you expand that you will find the "Steam" folder. Right click on that and do the same as step 3.

That's it!

It was pretty easy. It'll take you like 10 seconds to fix it. I hope this clears up anyone elses problem.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 05:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.