Go Back   Steam Users' Forums > Steam Discussions > Help and Tips

Reply
 
Thread Tools Display Modes
Old 07-23-2009, 10:09 AM   #1
blackAngel
 
Guest
Posts: n/a
failed to find Steam interface

When starting Team Fortress 2: i get this error:
CFileSystem_Steam::Init() Failed: failed to find Steam interface.
When starting CSS i get Unable to load C:<more path here>\counter-strike source\bin\filesystem_steam.dll
when starting non valve games, they just crash...

The System:
e6850
4GB ram
8800GTX 768MB
Windows7 64bit

I didn't have any problems some weeks ago... already played on windows7 and worked.
I still can play on my notebook (also win7) but that's not exactly my gaming rig...

I already tried: google, search forums, reinstall steam, disabling windows firewall, compatibility mode, redownload tf2, delete all steam.dll on my pc... (because it said to do so on some sites...)
then again deleted everything and made a 100% clean install of steam and tf2... still nothing.
i don't really want to reinstall windows already again...
Any ideas? hope someone can help me...
 
Reply With Quote
Old 07-23-2009, 11:23 AM   #2
cryptodan
 
Banned
Join Date: Feb 2007
Reputation: 405
Posts: 7,625
Did you try verifying the cache?
cryptodan is offline   Reply With Quote
Old 07-23-2009, 04:30 PM   #3
blackAngel
 
Guest
Posts: n/a
yes i did :/
  Reply With Quote
Old 07-23-2009, 04:45 PM   #4
>X<
 
Banned
Join Date: Jan 2009
Reputation: 475
Posts: 3,310
Have a read here see if anything helps

Try launching steam from the steam.exe as administrator first, then go from there.
>X< is offline   Reply With Quote
Old 07-23-2009, 05:03 PM   #5
blackAngel
 
Guest
Posts: n/a
i did that too, but nohing...
i read the thread, didn't find anything... but i'll check again tomorrow (it's 2am here^^).
  Reply With Quote
Old 07-23-2009, 05:11 PM   #6
>X<
 
Banned
Join Date: Jan 2009
Reputation: 475
Posts: 3,310
What security are you running?
>X< is offline   Reply With Quote
Old 07-24-2009, 01:45 AM   #7
blackAngel
 
Guest
Posts: n/a
nod32 anti virus
firewall i have only router and windows firewall... same for the laptop, and there it works -.-
  Reply With Quote
Old 07-24-2009, 01:57 AM   #8
>X<
 
Banned
Join Date: Jan 2009
Reputation: 475
Posts: 3,310
Try disable nod at startup and try again.

Or the advanced steam reset.

It really looks like windows need reinstalling.
>X< is offline   Reply With Quote
Old 07-24-2009, 03:20 AM   #9
blackAngel
 
Guest
Posts: n/a
seems like the problem is somewhere in the windows :/ ... but i don't really want to format again...
strange that it nearly seems i'm the only one having this problem. I'd be happy to hear some more ideas before i try reinstalling windows again...
I really can't understand what's causing this problem...
  Reply With Quote
Old 07-24-2009, 05:07 AM   #10
cryptodan
 
Banned
Join Date: Feb 2007
Reputation: 405
Posts: 7,625
Have you made sure all your windows updates are completed?
cryptodan is offline   Reply With Quote
Old 07-24-2009, 05:13 AM   #11
blackAngel
 
Guest
Posts: n/a
yes, everything installed (language packs not obviously, nothing else left..)
  Reply With Quote
Old 07-24-2009, 05:14 AM   #12
cryptodan
 
Banned
Join Date: Feb 2007
Reputation: 405
Posts: 7,625
Try this: https://support.steampowered.com/kb_...1381-EHKV-4295
cryptodan is offline   Reply With Quote
Old 07-24-2009, 03:50 PM   #13
blackAngel
 
Guest
Posts: n/a
alreay did... still nothing :/
  Reply With Quote
Old 07-24-2009, 03:52 PM   #14
cryptodan
 
Banned
Join Date: Feb 2007
Reputation: 405
Posts: 7,625
Try this: http://developer.valvesoftware.com/w...stalling_Steam
cryptodan is offline   Reply With Quote
Old 07-25-2009, 02:59 AM   #15
blackAngel
 
Guest
Posts: n/a
it suddenly works now... not sure why, though...
huh... hope steam doesn't change its mind again...
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Discussions > Help and Tips


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 01:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.