Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Fallout series

Reply
 
Thread Tools Display Modes
Old 08-18-2009, 10:05 PM   #1
caleb500424
 
Join Date: Jul 2009
Reputation: 163
Posts: 819
fallout 1 color problem

then the opening fallout movie pops up the colors kinda look funny miscolered parts of the screens pop up in difrent colors

no major problem

just a bug in the fallout 1 opening movie

Last edited by caleb500424: 08-18-2009 at 10:07 PM.
caleb500424 is offline  
Reply With Quote
Old 08-19-2009, 02:53 AM   #2
Shiny-Crowbar
 
Join Date: May 2008
Reputation: 35
Posts: 512
Hmm..You tried changing color quality?
Shiny-Crowbar is offline   Reply With Quote
Old 08-19-2009, 12:53 PM   #3
Arkhanor
 
 
 
Join Date: Apr 2009
Reputation: 15
Posts: 226
You can try alt + tab and the problem is solved.
Arkhanor is offline   Reply With Quote
Old 08-19-2009, 05:53 PM   #4
papelipo
 
Guest
Posts: n/a
I have the same worries, alt + tab changes nothing.
  Reply With Quote
Old 08-20-2009, 12:14 AM   #5
Zoidberg
 
 
 
Join Date: Apr 2006
Reputation: 46
Posts: 1,519
Right click on the exe and play a bit with the compatibility checkboxes (the last 3 should work).
Zoidberg is offline   Reply With Quote
Old 08-20-2009, 10:39 AM   #6
TappistRT
 
Guest
Posts: n/a
Quote:
Originally Posted by Zoidberg View Post
Right click on the exe and play a bit with the compatibility checkboxes (the last 3 should work).
It seems that if you change the compatibility settings for one steam app from their start menu shortucts, it changes those settings for ALL the apps in Steam, since all apps are launched like:

"Steam.exe -applaunch 4440"

Is there a way to just change the compatibility settings for one game on Steam and not ALL of them?
  Reply With Quote
Old 08-20-2009, 10:58 AM   #7
aerundel
 
 
 
Join Date: Apr 2007
Reputation: 124
Posts: 2,249
Change the shortcut to the game's .exe.
aerundel is offline   Reply With Quote
Old 08-20-2009, 03:03 PM   #8
RestInPeas
 
 
 
Join Date: Oct 2007
Reputation: 0
Posts: 18
This solution on the Interplay forums did the trick for me:

http://www.interplay.com/forums/view...33e4cffcf0e249
RestInPeas is offline   Reply With Quote
Old 08-21-2009, 07:46 AM   #9
gfoxcook
 
Guest
Posts: n/a
Quote:
Originally Posted by RestInPeas View Post
This solution on the Interplay forums did the trick for me:

http://www.interplay.com/forums/view...33e4cffcf0e249
Basic point of that thread was to change the first "Mode=" to "Mode-4", which unfortunately didn't change any of the color issues in the opening movie for me (on Vista). Couldn't hurt to try it first like I did, though, maybe on some rigs it does help.

Quote:
Originally Posted by Zoidberg View Post
Right click on the exe and play a bit with the compatibility checkboxes (the last 3 should work).
I actually went ahead and tried changing the compability for falloutw.exe to Win95 or Win98 first, but both prompted a DirectX 3.0 error... so then I went with XP (SP2) (which is one of the last 3 that you mentioned) and it worked like a charm. No color issues, etc.

Dunno what to tell the folks with XP (SP2) actually on their PCs who still have color problems...

Quote:
Originally Posted by TappistRT View Post
It seems that if you change the compatibility settings for one steam app from their start menu shortucts, it changes those settings for ALL the apps in Steam, since all apps are launched like:

"Steam.exe -applaunch 4440"

Is there a way to just change the compatibility settings for one game on Steam and not ALL of them?
Don't change the compatibility of a shortcut to a Steam game, as you noted, they're all to Steam.exe, with an -applaunch tag doing the actual specific game selection.

Change the compatibility of your game's exe file. For Fallout 1, it is named "falloutw.exe" and is in the SteamApps\common\fallout directory.

I already knew you could do this and not have it affect any other Steam games because for Bioshock to work properly on my rig back last year, I had to change it to XP (SP2) compatibility mode, and I did so JUST for the Bioshock .exe file with no unintended issues caused to any other games, they all launch in Vista native mode unless you go fiddle with their .exe compatibilities as well.
  Reply With Quote
Old 08-23-2009, 12:23 AM   #10
magnetik
 
Guest
Posts: n/a
Thanks a lot RestInPeas !
The solution works fine on Windows 7.
  Reply With Quote
Old 08-24-2009, 09:05 AM   #11
Skylark95
 
Join Date: May 2009
Reputation: 0
Posts: 13
So far I have Tried everything in this thread and none of the solution work for me. I am running Windows 7 32-bit
Skylark95 is offline   Reply With Quote
Old 08-28-2009, 03:00 PM   #12
antonio_bone
 
Guest
Posts: n/a
I had the same problem but I just ran the game from SteamApps/common/fallout and not through Steam without altering any compatability and the colour problems are gone maybe it just doesn't like being run through Steam?
  Reply With Quote
Old 08-30-2009, 03:37 PM   #13
gfoxcook
 
Guest
Posts: n/a
Quote:
Originally Posted by antonio_bone View Post
I had the same problem but I just ran the game from SteamApps/common/fallout and not through Steam without altering any compatability and the colour problems are gone maybe it just doesn't like being run through Steam?
Maybe, but I keep running it through Steam and it keeps working okay.

Oh, to add on to my post a few posts up, though:

Every now and then, maybe every 3rd or 4th time I launch the game, the color issue with the startup screen/video will come back. I quit back out, change the compatibility from XP to 2000, restart the game, and the color issue is gone.

And of course, if it happens again days later, I switch back from 2000 to XP mode, and it's gone again.

Weirdest thing, but that flipping between XP/2000 modes seems to be keeping it at bay for the most part. Hope it works for someone else, too.
  Reply With Quote
Old 09-29-2009, 02:08 AM   #14
Lunne
 
 
 
Join Date: Oct 2007
Reputation: 0
Posts: 5
What worked for me was to remove the file "ddraw.ini" all together.
Lunne is offline   Reply With Quote
Old 11-12-2009, 05:43 PM   #15
Brisket
 
Guest
Posts: n/a
Quote:
Originally Posted by gfoxcook View Post
Basic point of that thread was to change the first "Mode=" to "Mode-4", which unfortunately didn't change any of the color issues in the opening movie for me (on Vista). Couldn't hurt to try it first like I did, though, maybe on some rigs it does help.
I'm pretty sure that was a typo, change it from "Mode=0", to "Mode=4". Worked like a charm for me (Running Windows 7).

Unfortunately the movies in the game are still really glitchy, but the colour issues are gone.
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Fallout series


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 06:06 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.