Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Jedi Knight: Dark Forces II

Reply
 
Thread Tools Display Modes
Old 09-16-2009, 05:29 PM   #1
awilliams1701
 
Guest
Posts: n/a
Game doesn't work at all

I try to run the game and it says "preparing to launch star wars jedi knight" then it dissapears and nothing happens. I tried to launch dk.exe dirrectly and got the same thing. Does anyone have any ideas?♦

I'm running:
windows vista x64 ultimate (vista is on the requirements)
8gb ram
geforce 8800 gts 512
dual raptor 160gb in raid 0
 
Reply With Quote
Old 09-16-2009, 08:43 PM   #2
Nova_Darkstar
 
Guest
Posts: n/a
Same thing is happening to me, I just get a quick flash of black on my screen after "Preparing to launch..." and that's all.

WinXp SP 3
Intel P4 3.40Ghz
2GB RAM
Nvidia Geforce 9400GT 512MB

You'd think with my below average specs that I would be able to run it, but I suppose not =/
  Reply With Quote
Old 09-16-2009, 08:48 PM   #3
Browncoat1984
 
Join Date: Jan 2009
Reputation: 11
Posts: 374
Ditto to what you two said, Windows XP SP3. I click the game and the screen flashes black and...nothing. This happens with Jedi Knight and Mysteries of the Sith.
Browncoat1984 is offline   Reply With Quote
Old 09-16-2009, 09:01 PM   #4
BurningTofu
 
Join Date: May 2009
Reputation: 14
Posts: 212
System Requirements
OS: Windows 2000, XP or Vista

so they lied to us?
BurningTofu is offline   Reply With Quote
Old 09-16-2009, 09:04 PM   #5
StingingVelvet
 
Join Date: Apr 2008
Reputation: 264
Posts: 4,796
Quote:
Originally Posted by BurningTofu View Post
System Requirements
OS: Windows 2000, XP or Vista

so they lied to us?
Just because it doesn't work for you, doesn't mean it is your OS. At all. Not even a little bit, really.
StingingVelvet is offline   Reply With Quote
Old 09-17-2009, 11:30 AM   #6
OptimusHun
 
 
 
Join Date: Dec 2008
Reputation: 12
Posts: 577
XP SP3
Celeron D 3 GHz
1.5 GB RAM
Geforce 8600 GT with 190.62 driver

The game doesn't start to me! No JK or MotS.
The funniest thing is the demo run fine, even 1440x900 - this is my monitor highest res - so the full and fixed - I mean 1.1v - why not run?
OptimusHun is offline   Reply With Quote
Old 09-17-2009, 01:05 PM   #7
GrimCW
 
 
 
Join Date: Apr 2008
Reputation: 169
Posts: 3,234
Quote:
Originally Posted by BurningTofu View Post
System Requirements
OS: Windows 2000, XP or Vista

so they lied to us?
running fine on my vista aside from the windowed startup/cutscenes

so vista isn't the issue alone

i mean, its like battlefield 2, a lot of people run it on Vista too, but for me.. no dice. it won't even install, and if i get it to do that (by installing though my XP partition) the game will usually CTD without warning or error upon either loading a map, or soon after i start playing.

M$ really killed backwards compat in Vista, and as for XP.. i've had JK2 running in that a number of times thats easier to get it going TBH.
GrimCW is offline   Reply With Quote
Old 09-17-2009, 01:32 PM   #8
awilliams1701
 
Guest
Posts: n/a
The two of you running xp sp3 are you running 64 bit? I'm wondering if that has something to do with it.
  Reply With Quote
Old 09-17-2009, 02:24 PM   #9
awilliams1701
 
Guest
Posts: n/a
Based on what i've seen from other people
The problem is not any of the following
quad core
vista
64 bit
page file turned off

haven't yet eliminated
8800 gts 512 (but someone said they used a 8800 gt which is a very similar card)
8gb ram (why would that matter)
forcing george lucas to do what it takes to fix or remake the game. (probably this is the most likely)
  Reply With Quote
Old 09-17-2009, 03:09 PM   #10
Citizen86
 
Join Date: Sep 2009
Reputation: 0
Posts: 63
I'm running Win7 64-bit, 8800m GTS (mobile version), and 3 gb's Ram. Forcing AA and AF off got the game running great in 3D accelerated mode.
Citizen86 is offline   Reply With Quote
Old 09-18-2009, 01:32 PM   #11
awilliams1701
 
Guest
Posts: n/a
I think i've elminated all of my problems except that it doesn't get past the preparing to launch thing. Its just something random with my configuration. I haven't seen anyone else that said they had 8gb of ram though. I still don't see why having that much would cause a problem if it runs in 64 bit mode just fine. I'll be upgrading to 7 in a month or two anyway. Maybe it will work then.
  Reply With Quote
Old 09-20-2009, 04:45 AM   #12
Nova_Darkstar
 
Guest
Posts: n/a
I'm running on the 32 bit OS, is there anyone who has the game running on a 32 bit? I don't think I've seen a single post on someone with one who has.
  Reply With Quote
Old 09-20-2009, 09:16 AM   #13
Wolf68k
 
Join Date: Sep 2009
Reputation: 0
Posts: 25
Ok we get it. A game that has been around since the mid to late 90s works great on a 64-bit OS, which is a bit odd to say the least.
The question still remains how to get the same game work on a 32-bit OS?
Wolf68k is offline   Reply With Quote
Old 09-20-2009, 10:44 AM   #14
Browncoat1984
 
Join Date: Jan 2009
Reputation: 11
Posts: 374
I'm running SP3 32-bit and can't get it to work...
Browncoat1984 is offline   Reply With Quote
Old 12-27-2009, 08:43 PM   #15
syckit
 
Guest
Posts: n/a
same problem. Have tried different monitor resolutions.

32bit Windows XP SP3
3.0GHz Pentium 4 (Hyper Threading enabled)
1 GB RAM
NVIDIA GeForce 9600 GSO 768MB

page file enabled (2GB)

[edit] Just tried a whole slew of compatibility tab options (for JK.exe) and monitor resolution combination but no luck.

Last edited by syckit: 12-27-2009 at 08:56 PM. Reason: tried comapablility tab
  Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > Star Wars collection > Jedi Knight: Dark Forces II


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 08:24 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2015, All Rights Reserved.