Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > SiN Episodes

Reply
 
Thread Tools Display Modes
Old 10-16-2009, 12:00 PM   #1
TeraNova09
 
Guest
Posts: n/a
Exclamation SiN Steam won't work (Buffer Overrun Detected)

Hello guys, new member here!

I was wondering if there was a fix for my problem, I have a SiN steam and this strange error won't allow me to run the game!

Quote:
Window Header reads: "Microsoft Visual C++ Runtime Library"
Buffer Overrun Detected

a buffer overrun has been detected which has corrupted the program's internal state, The program cannot safely continue execution and must now be terminated.
I run my steam client under Windows 7 Ultimate

My PC specifications are:
Intel Core Quad Q6600 @ 2.40Ghz
2 GB RAM
GeForce 8600 GT
Creative SB Audigy

Please help me out as soon as possible..

Thanks in advance
 
Reply With Quote
Old 10-19-2009, 10:19 AM   #2
TMorph
 
Join Date: Oct 2009
Reputation: 0
Posts: 17
Hello drivers 191.07 error drivers 190.38 Ok

Mi grafic Nvidia 9800 GT

I feel my English, Translation with translator
TMorph is offline   Reply With Quote
Old 10-20-2009, 02:51 AM   #3
Hi2u! Tw1TcH
 
 
 
Join Date: Dec 2005
Reputation: 800
Posts: 5,773
Right click your game in your games list, go the properties tab. Defrag the cache files and verify the integrity of the files.

Have you tried running in XP Compatibility mode?
Hi2u! Tw1TcH is offline   Reply With Quote
Old 10-20-2009, 07:12 AM   #4
TMorph
 
Join Date: Oct 2009
Reputation: 0
Posts: 17
Quote:
Originally Posted by Hi2u! Tw1TcH View Post
Right click your game in your games list, go the properties tab. Defrag the cache files and verify the integrity of the files.

Have you tried running in XP Compatibility mode?
All this and tried it and did not work. change the driver to version 190.38 for testing and the game works with Win ME compatibility win98

I feel my English, Translation with translator
TMorph is offline   Reply With Quote
Old 12-10-2009, 04:45 PM   #5
Psy-Crow
 
Join Date: Dec 2009
Reputation: 37
Posts: 22
Lightbulb

Quote:
Originally Posted by TeraNova09 View Post
Hello guys, new member here!

I was wondering if there was a fix for my problem, I have a SiN steam and this strange error won't allow me to run the game!



I run my steam client under Windows 7 Ultimate

My PC specifications are:
Intel Core Quad Q6600 @ 2.40Ghz
2 GB RAM
GeForce 8600 GT
Creative SB Audigy

Please help me out as soon as possible..

Thanks in advance
I've encountered the same problem. The fix is simple: goto nVidia control panel, click "Manage 3D settings", goto to the tab "Program Settings", select in the list "SiN:Episodes (sin.exe)" and set "Extension limit" to "On". SiN should run fine after this.

I'm still curios who's to blame, Ritual & Valve for non-fixing such obvious bug (Oni for ex. has the same problem, look here and here) or nVidia, who messed with SiN profile in latest drivers.

BTW, you may read more about "Extension limit" and its tweaking using nHancer here.

UPD. Since completely disabling extensions is no good, i've found maximim amount of them, that SiN can handle: 4999. Enter this in nHancers profile editor...

Last edited by Psy-Crow: 12-12-2009 at 01:52 PM. Reason: added nHancer tweak
Psy-Crow is offline   Reply With Quote
Old 12-25-2009, 06:50 AM   #6
dukmiester2
 
Join Date: Nov 2004
Reputation: 96
Posts: 730
Quote:
Originally Posted by Psy-Crow View Post
I've encountered the same problem. The fix is simple: goto nVidia control panel, click "Manage 3D settings", goto to the tab "Program Settings", select in the list "SiN:Episodes (sin.exe)" and set "Extension limit" to "On". SiN should run fine after this.
Problem is, I don't see a setting for "Extension Limit"

I'm using driver version 195.62
Not that I play SIN 1 often, I just re-installed all my Steam games since I did a fresh new install of Win 7 Pro 64 bit and can't get SIN 1 to work (same error as OP):

Window Header reads: "Microsoft Visual C++ Runtime Library"
Buffer Overrun Detected

a buffer overrun has been detected which has corrupted the program's internal state, The program cannot safely continue execution and must now be terminated.

Any idea why I don't have a "Extension Limit" setting?
Thanks for any help.
dukmiester2 is offline   Reply With Quote
Old 12-27-2009, 04:17 PM   #7
Gvaz
 
 
 
Join Date: Oct 2007
Reputation: 14
Posts: 784
I don't have an extention limit option on my nvidia control panel either. I'm running windows 7 professional with an 8800gts 512mb.

It worked on vista...
Gvaz is offline   Reply With Quote
Old 12-27-2009, 05:40 PM   #8
brotrrwinner
 
Banned
Join Date: Mar 2009
Reputation: 83
Posts: 1,054
I'm also having this exact problem and I also don't have an extension limit option in the game profile. I'm using Windows XP 32bit, a GTX 275 with the latest drivers
brotrrwinner is offline   Reply With Quote
Old 12-27-2009, 05:50 PM   #9
Gvaz
 
 
 
Join Date: Oct 2007
Reputation: 14
Posts: 784
downloading nHancer and putting 4999 in the extention limit works.

It seems later patches removed this ability, along with mipmaps and such.
Gvaz is offline   Reply With Quote
Old 12-29-2009, 06:18 PM   #10
dukmiester2
 
Join Date: Nov 2004
Reputation: 96
Posts: 730
Quote:
Originally Posted by Gvaz View Post
downloading nHancer and putting 4999 in the extention limit works.

It seems later patches removed this ability, along with mipmaps and such.
Any idea where to get it? Looked at Nvidia downloads but could not find nHancer.

Thanks
dukmiester2 is offline   Reply With Quote
Old 12-30-2009, 01:16 PM   #11
brotrrwinner
 
Banned
Join Date: Mar 2009
Reputation: 83
Posts: 1,054
www.nhancer.com

Just tried it and it worked
brotrrwinner is offline   Reply With Quote
Old 12-30-2009, 02:07 PM   #12
dukmiester2
 
Join Date: Nov 2004
Reputation: 96
Posts: 730
Thank you! I've always heard of people mentioning nhancer, just never needed it or knew where to get it.

Thanks again
dukmiester2 is offline   Reply With Quote
Old 12-30-2009, 04:27 PM   #13
brotrrwinner
 
Banned
Join Date: Mar 2009
Reputation: 83
Posts: 1,054
I have another problem now. I was playing and then minimized it. When I tried to restore it stopped responding. I figured it was one of those game that just don't deal with minimizing that well, so I killed the process. When I tried to start it again, it just froze on the main screen. I tried reinstalling it but it keeps freezing at the beginning. It's odd because it was working just fine
brotrrwinner is offline   Reply With Quote
Old 12-31-2009, 06:45 AM   #14
brotrrwinner
 
Banned
Join Date: Mar 2009
Reputation: 83
Posts: 1,054
Nevermind, it's xfire that causes the crash. Just need to play with it turned off

Last edited by brotrrwinner: 12-31-2009 at 04:09 PM.
brotrrwinner is offline   Reply With Quote
Old 01-08-2010, 03:54 PM   #15
Kriv
 
Join Date: Jul 2009
Reputation: 10
Posts: 32
For those having difficulties with the settings in nHancer use the following.

Open the app and wait for it to scan your games.
SiN: Episodes will appear
Highlight the title
In the left hand window click the tabs Compatibility and then OpenGL

Tick the following
OpenGL Support - Leave on General Compatibility
OpenGL Support 2 - Leave on General Compatibility
Conformant texture clamp - Click Hardware radio button
Driver extension limit - Type 11a8 into the box
Reported OpenGl version - default in drop down
OpenGL Multi Display Mode - Optomized for single display
Single Back Depth Buffer - Enabled
Multi Monitor Buffer - Disabled

Info taken from http://forums.guru3d.com/showpost.ph...&postcount=146
Kriv is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > Q - S > SiN Episodes


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2014, All Rights Reserved.